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Introduction  
OneStream XF 6.0.0 is a major release containing significant new features, enhancements to existing 
features, new API’s, and a required database schema update. The features of this release were 
developed to enhance the design capabilities, performance, and improve ease of use of applications. 
Designers, system administrators, and users will benefit from the enhancements across their 
application.  

New features include: 

• Dynamically Highlight Evaluated Cells within a cube view to automatically display updated values 
in an existing workbook, a sheet or sheets, external workbooks, and external renamed 
worksheets. 

• Use an existing cube view in Excel or Spreadsheet to create highly formatted reporting by using 
existing cube view formatting, adding new styles to apply changes to rows, columns, or cells, or 
a combination of existing styles with new styles. 

• Insert Suppressed Member which allows you to select a row that is currently suppressed 
without asking the administrator to change row properties. 

• Relationship Security which allows you to change the security model to allow who controls the 
relationship member in the consolidation dimension. 
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• FX Lock Rate which allows you to lock and unlock currency rates, by rate type and time.  

• Cube View Column Math, which gives the option to perform math on columns when the 
columns aren’t visible. 

Important Notes 
Prerequisites 
Refer to the Upgrade OneStream XF 6.0.0 section for important notices and details regarding planning 
your upgrade.  

Compatibility and Important Notices 
Refer to the Upgrade OneStream XF 6.0.0 section for information on compatibility of the OneStream 
Studio and OneStream Excel Add-in versions.  

OneStream XF users are encouraged to adopt the OneStream Windows App. The OneStream XF web 
interface has been developed using Microsoft’s Silverlight web browser plug-in.  Microsoft officially 
announced in 2012 that development of Silverlight will be discontinued with support ending in October 
2021.  The OneStream Windows Application is the replacement for the Silverlight-based browser 
interface.  Customers should note that certain new features may only be available in the OneStream 
Windows App due to its technology advantages.  In addition, users can access OneStream XF through 
the HTML5-based OneStream Mobile and OneStream Excel Add-in.  OneStream will not support the 
Silverlight-based web browser interface beyond 2021.  

OneStream XF version 5.3 was the last version to support the Windows 7 operating system.  Windows 7 
is no longer supported as a client operating system as of January 14, 2020, in line with Microsoft’s 
mainstream support policy.   

Schema Update  
For OneStream XF 6.0.0, you are required to perform a Database Schema Upgrade on the Framework 
and application databases when upgrading from version 5.3.0 and prior using the OneStream Database 
Configuration Utility.   

MarketPlace Reference Application 
The Application Basic videos, previously only available on OneStream Academy, have been added to the 
Reference Materials. The Application Basics videos provide users with an introduction to key OneStream 
XF concepts and explain what is possible within the product. They are meant to show how the 
application is built on the administrator side and should be viewed before the build of a project. The 
videos contain deep dive demos into the product which are followed by explanations on how this is built 
during a project. Users will learn key OneStream terminology, OneStream Dimensions and how they 
relate to the Cube, how to load data into OneStream, Workflow Profiles, and analysis and reporting.  
Finally, it includes points of reference for resources that will help users with OneStream XF 
implementations and beyond. (14398) 
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Security Enhancements 
The IIS Version is not revealed in the web banner. (16840) 

The code now validates the table names, pageGridColumnFilters, and dbOrderBys when used in the 
Windows application. (16838) 

In the XFWebServerConfig.xml settings, a new setting called UseDetailedErrorLogging has been added. 
The default is set to true.  In the XFAppServerConfig.xml settings, UseDetailedLogging has been renamed 
UseDetailedErrorLogging. The default is set to true. (16839)  

System Enhancements 
Updated theme from Office 2016 to Office 2019. (16922) 

OneStream XF 
New 

Application 
Time Dimension 

The OneStream XF 6.0 Database Schema Update process will increase the end limit year of all 
OneStream applications to the year 2100.  The extension of years defines the available Time 
range as 1996 to 2100 for all applications. (16382) 

Business Rules Search 

All users, with access to Business Rules, now can search for a Business Rule Name.  The new 
Toolbar utility is a context-based search which functions across all the Business Rule Types. 
(15386) 

Lock FX Rates 

A new feature found in this version of OneStream XF is the capability to lock FX Rate Types.  
Administrators, and users with appropriate security roles, will be able to access the Lock/Unlock 
page through a new FX Rates toolbar button.  The new page will allow FX Rate Types to be 
locked or unlocked by the selected Time.  Existing FX Rate Excel or Spreadsheet workbooks can 
be update with the new XFIsFxRateLocked function to display the status.  A set of BRAPI’s have 
been added to provide Business Rule automation and Dashboard control of the lock and unlock 
actions.  The feature is fully managed with new Security Roles, Audit Logging and Task Activity 
notifications. (15094) 

Workflow 
Workflow Names 

A broad set of Workflow, Forms channel, Workflow Names has been added to provide designers 
with more flexible and efficient options when using Workspaces.  Many of these options 
eliminate unnecessary processes, such as Forms and Process, that may be designed as functional 
operations within a Workspace. (15813) 
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Security 
Consolidation Dimension Security 

Application Designers and Architects have the ability to modify the Security model by Cube.  The 
Application/Cubes property, Use Parent Security For Relationship Consolidation Members will 
expose the relationship members of the Consolidation Dimension to application Security.   This 
model will control the access of the Relationship Consolidation members to be based on the 
Security Access defined on the immediate parent Entity. (15804) 

Presentation 
Cube View Paging Controls 

Cube View Paging now has two new configuration methods.  The OneStream Application Server 
Configuration Utility contains two new properties to set a global application configuration for 
the display of the maximum number of unsuppressed rows as well as a control for the maximum 
number of seconds to process Cube Views.   Second, specific Cube Views may be tailored to 
modify the paging behavior with two new properties in the General Settings/ Common area as 
Max Unsuppressed Rows Per Page and Max Seconds to Process. (17155) 

Cube View Insert Suppressed Row Member 

A new Cube View data entry design element has been added to the Cube View Row 
Data/Suppression properties.  The Allow Insert Suppressed Member property has been created 
to allow a designer a method to provide end users the ability to access suppressed members for 
the purposes of data entry.  This new setting can be enabled at the Row Expansion level to 
control the user experience in Data Explorer or Workflow Forms. (16165) 

Cube View Column Math Support for Hidden Columns 

Complex Cube View Column Math calculations can now be derived using hidden columns.  The 
IsColumnVisible, Column Header Formatting property now contains a new setting, 
CVMathOnly, which allows the column(s) to be hidden from view, yet still function within a 
GetDataCell Cube View Column calculation. (17847) 

BI Viewer Component Properties 

You can set dashboard borders to show or be hidden by setting Show Borders to True or False. 
(17249) 

Excel Enhancements 
Maintain Dynamic Dirty Cell Status with Preserve Formulas in Cube Views  

You can use retain formulas and dynamically highlighted evaluated cells within a cube view to 
automatically display updated values in an existing workbook, a sheet or sheets, external 
workbooks, and external renamed worksheets in Excel. You can also do this in Spreadsheet 
within the OneStream application, however, you can’t point the cell references to external 
workbooks. (16223) 

Excel Add-in: Retain Formatting on Retrieval in an Attached Cube View using Selection Styles 
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You can bring an existing cube view into Excel or Spreadsheet and format to create highly 
formatted reporting using Excel/Spreadsheet functionality. It can be modified locally as well as 
in spreadsheet. You can use existing cube view formatting, add new styles to apply changes to 
rows, columns, or cells, or a combination of existing styles with new styles. (16570) 

Changed 

Financial Model 
• The Reset Scenario Data Management Step has been enabled for Scenarios with Yearly and 

Range Workflow Tracking Frequencies and Monthly Input Frequencies. (10940, 9252) 

Security 
• Login Authentication processing has been enhanced to retry on other servers if an unresponsive 

server is encountered. (15506, 17821) 

• SAML character padding has been removed to resolve failures on base64 decoding. (16803) 

Presentation 
• A new Dashboard Component has been created which masks password text entry. (16802) 

• The Large Data Pivot Grid will refresh the records by page went dimensions are pivoted between 
rows and columns. (15999) 

• Cube View Data Explorer rows will not be impacted be preceding rows having the IsRowVisible 
property as False. (15719) 

• The SQL Table Editor has been enabled to support filtering on Date Time defined columns. 
(15503) 

• The Pivot Grid Dashboard components can create, define and rename custom calculated fields. 
(14163) 

• Dashboard Label Components have a new property to enable text wrapping. (12643) 

• Dashboard Grid Viewer Component now has the capability to format the background cell colors, 
by column. (13237) 

• The Grid View Dashboard Component Save State property has been expanded to additional user 
actions.  The Save State setting will now save the users selection of Columns placed in the Group 
By bar, Column Order, Sorting, as well as any Filter selections in the Group By bar. (12514, 
12096, 17150) 

• The Dashboard Grid View and SQL Table Editor Components now contain the option to Re-set 
State.  This right-click option will allow a user to clear their “Saved State” settings, returning the 
Component to its default design. (17430) 



OneStream XF Version 6.0.0 Release Notes Page 6 of 19 
 

• When multiple data adapters are used in a Dashboard Grid View Component, the table name 
displayed will be that of the table specified in the design of the component. (15646) 

• The Grid View and SQL Table Editor Dashboard Component Column Filter Icon will display with 
an orange fill color when a column filter is active. (17151) 

• A new formatting property has been added to the BI Viewer Component, Show Dashboard Item 
Borders, which allows the display of content borders to be shown or hidden. (16576) 

Fixed 
• Copy POV from Data Cell/paste POV as XFGetCell function does not work for users with non-

english locale. (12101) 

• Application Metadata files, in .zip file format, can be used to load files which are sized 2gig or 
greater.  (13975) 

• Task Activity description details will show the correct subperiods when using Matrix Data 
Sources through the Harvest Batch folder. (14715) 

• When using Row Templates, the horizontal scrollbar will display in the Cube View Designer. 
(14717) 

• Pivot Grid Components will display culture formatting, while suppressing currency symbols. 
(14992, 15589) 

• Dashboard “Undo/Refresh” button is enabled to cancel all changes since the last saved state. 
(15854) 

• Server error handling corrected for error: Violation of PRIMARY KEY constraint 'PK_MetricValue' 
(15863) 

• Reset Scenario Data Management step will now reset the Workflow Status related to Scenarios 
having a Range Workflow Tracking Frequency. (16041) 

• Delete Dashboards button re-enabled to delete Dashboard Profiles. (16043) 

Requested Enhancements 
• A new XF Excel/Spreadsheet Function, XFGetCalculatedFXRate, which will allow the designer to 

retrieve direct as well as triangulated derived rates. (16829) 

• SQL Table Editor’s Save State property now supports sorted columns. (17277) 

• The Grid View Dashboard Component Filtering is now supporting Saved State Filtering on Date-
Time Columns. (17012) 

• SQL Editor Dashboard Component columns will support sorting when the Component is 
predefined with Group By properties. (15943) 
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• The SQL Table Editor Dashboard Component supports source table columns with blank spaces. 
The design property Order By Clause no longer require brackets “[ ]” to reflect column names 
having blank spaces separating text. (17108, 16374) 

• A new formatting property has been added to the SQL Table Editor which allows the background 
color to be customized. (13237) 

• Quick View queries can now be renamed using the Rename Quick View toolbar button. (17252) 

• The OneStream Excel Add-In has been enhanced to eliminate conflicts and expand compatibility 
when other Excel Add-Ins are enabled. (13322) 

Known Issues 
• Using Cube View Excel Style Formatting, if more than one row or column returned uses the 

same label, then only the first occurrence will support the style.  Unique styles are required. 
(17287) 

• Non-Administrator Application Pool User Returns Errors for PerfLib and PerfNet When Recyling 
IIS and also Background Intelligent Transfer Service When Using "Recycle App Pool". (14336) 

• The XF Dox Builder may not correctly update Table of Contents page numbering when content is 
added. (10704) 

• Users editing dimension hierarchies through the Silverlight-based web interface may experience 
an intermittent issue where the Dimension Library page becomes unavailable.  Use of the 
OneStream Windows Application is the recommended solution for application management to 
avoid this situation. (10274) 

• Viewing Dashboards in the Silverlight Web Browser, which are designed to contain more than six 
levels of nested Dashboards, may not render as expected.  Users encountering this issue should 
use the OneStream Windows Application interface as a solution. (10136, 10102) 

• Mapping to Data to UD Entity Default Is Not Aggregating With Row Mapping to Same UD 
Explicitly When Loading to Cube. (9549) 

• Excel Extensible Documents may not retain the margin and print area formatting when assigned 
to a OneStream Book of reports. (9052) 

• Monitor displays set for over 125% may impact complex Dashboards by partially hiding content.  
The Windows Application content zoom is recommended. (6255)  

• When opening a Workbook that contains OneStream Formulas/Cube Views/Quick Views directly 
from the file system before opening a blank Excel workbook and logging into the OneStream 
Excel Add-In, the user may receive a “Cannot run the macro ‘XFInternalSetConnectionInfo’ error. 
As a workaround, the user can open Excel, log in and then open the XLSX file, or they can launch 
the file from within OneStream if it is in the File Repository. (5024) 
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• To have SSL security configured between the OneStream Application and Web Servers, 
Application Pools must use a local administrator account rather than a domain account for On-
Prem. (4603) 

• When navigating to a Linked Cube View, the drill-down feature may not properly open a source 
document. (3056) 

• The Report Preview may Error in a Cube Views that are Sharing Rows/Columns and they both 
have the same row or column names. (2651) 

• When Cube Views are designed with cell border formatting on header and data cells, text 
wrapping may display unevenly between the headers and data cells. (2348) 

• If Process Selection Changed for Inserts is set to False and you add a new row, the lower 
dashboard refreshes and the time updates. (18458) 

Contacting Support 
To contact OneStream support, first register at our support site http://support.onestreamsoftware.com 
and then email support@onestreamsoftware.com.   

To gain access to the XF MarketPlace, email OneStream Support. 

  

http://support.onestreamsoftware.com/
mailto:support@onestreamsoftware.com
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OneStream XF MarketPlace Updates 
The following updates were made to the XF MarketPlace since the OneStream XF 5.3.0 Release. 

New 

Predictive Analytics 
Predictive Analytics 123 provides a forecast baseline based on historical data patterns. The solution 
cycles through multiple forecast methods based on Seasonality and Trend to determine the most 
accurate forecast. It creates and presents models to support forecasting, prediction, and what-if analysis 
to determine the most appropriate forecast scenario. 

Transaction Matching 
Transaction Matching is a OneStream XF MarketPlace solution that supports matching of transactional 
level data utilizing a configurable rules-driven approach for the purpose of identifying differences. The 
solution will match any transactions, allows for manually matching, and includes a review and approval 
process.  

Changed 

Data Entry 123 
The theme of this release includes usability improvements and UI modernization.  Selector values can be 
limited based on another Selector within the same Selector Bar.  Forms will no longer refresh 
automatically and are now controlled by a Refresh button.  Height and Font Size for each Selector in a 
Selector Bar are now definable.  Forms within Workflow Profiles can be designated as Required or 
Optional Form Templates.  Member Filter values can be displayed in their appropriate dimensional 
hierarchy.  

MarketPlace Solution Tools 
The Solution Analysis Tool feature helps enforce XF MarketPlace solution development standards. By 
uploading a series of extracted solution files within a zip file, this feature will review the related Business 
Rules to determine if any prohibited or noted inefficient coding practices are included within and then 
report to the user. 
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Upgrading OneStream XF 6.0.0  
Use this procedure when upgrading from an earlier OneStream XF release to 6.0.0. The anticipated 
audience for the upgrade process is Information Technology professionals responsible for installing, 
maintaining and supporting OneStream XF.    

Review the following OneStream XF 6.0.0 requirements prior to scheduling an upgrade and any related 
notes in the OneStream XF Installation and Configuration Guide, available on XF MarketPlace.  

1.) If upgrading from OneStream XF version 5.3.x or earlier, it is required to update OneStream to .NET 
4.7 for Microsoft’s security standards and for advanced features to stay current on the latest version 
of the .NET Framework.   

NOTE: Microsoft provides the .NET Framework 4.7 optional update through standard Microsoft 
Windows Updates.   

2.) The most recent database schema update was 5.2.0. You will need a database schema update if 
upgrading from 4.2.x, 4.3.x or 5.2 to version 6.0.0. If upgrading from version 4.2.0 or earlier, 
Database Schema updates must be implemented as part of the upgrade on every Application and 
Framework database. We recommend full database backups. 

3.) The 6.0.0 version of the OneStream Studio and OneStream Excel Add-in are not backward-
compatible with versions up to 5.x. You must update them by either uninstalling and reinstalling or 
using the Client Updater. For more information, refer to the OneStream XF Installation and 
Configuration Guide for details in section, “Upgrade or Downgrade via OneStream.”  

4.) If upgrading from a version 5.3.0 or earlier, it is required that all OneStream Applications complete 
the Compile All Business Rules and Formulas to Check for Syntax process as part of the upgrade.  
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Scheduling the Upgrade 
We recommend that the OneStream Software Technical Support Team performs this upgrade.  Contact 
OneStream Technical Support to schedule this upgrade: support@onestreamsoftware.com. 

Pre-Installation Upgrade Checklist 
The checklist below details the items that you will complete prior to beginning the upgrade operation. 

Step 1: Perform a Full Backup of All OneStream Databases. 

Step 2: The App Pool Service Account must use an administrator ID or you must add it to the 
Performance Monitors User Group, IIS_IUSRS Group and Performance Log Users Group.  

Step 3: Download OneStream XF Installation Software from the OneStream XF MarketPlace. 

1.) Login to the OneStream XF MarketPlace and select Software Download to access the latest version 
of OneStream XF. 

2.) Download the Full Package or Server Software to acquire the appropriate setup files for the server 
installation. 

Step 4: Verify the location of the OneStream XF configuration files. 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility). 

2.) Right-click the utility and select Run as Administrator. 

3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 
Software\OneStreamAppRoot\OneStreamApp on application servers or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers, and choose the 
web.config file. 

4.) The web.config will open and display the path to the corresponding configuration files: 
XFAppServerConfig.xml and XFWebServerConfig.xml. 

5.) Copy the config file. 

6.) Copy and paste the configuration file path in a place that is easily accessible. You will need to re-
enter this information following the upgrade process. 

7.) Close the file and select No when prompted to save.  

8.) Close the OneStream Server Configuration Utility. 

Step 5: Verify the OneStream service account in Internet Information Services Manager (IIS). 

1.) The Service Account must be an Admin ID or in the IIS_IUSRS Group, Performance Log User and 
Performance Monitor Users groups. 
This ID is necessary to use for Queuing and CPU Monitoring. 

mailto:support@onestreamsoftware.com
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2.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager). 

3.) Expand the server in the left pane and select Application Pools. 
This will display a list of application pools in the right pane.  The OneStreamAppAppPool and 
OneStreamWebAppPool are displayed in the Identity column.  Keep note of this Windows account 
and its password because you will re-enter the information in IIS following the upgrade process.  

Step 6: Verify the OneStream Application Server with the OneStream Database Configuration Utility 
are Installed. 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server has the OneStream Database Configuration Utility installed. You will need to re-
install this on the application server during the upgrade operation. 

Step 7: Verify the OneStream Application Server with OneStream Studio is Installed (if applicable). 

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify 
which application server(s) has OneStream Studio installed.  You will need to re-install this on the 
application server during the upgrade operation. 

Pre-Installation Member Object Rules Evaluation 
OneStream XF Version 5.2 introduced a coding change making Member Objects Read-Only as part of 
regular, ongoing code enhancements.  This change may cause issues with some existing applications 
where business rules are used to create or edit metadata.  

This issue can be identified by: 

• Analyzing Business Rules for problematic syntax that create or update metadata. 

• Compiling all Business Rules if errors appear related to read-only objects (after 5.2). 

Member Object Application Errors 
You can identify this rules error after upgrade by a standard Business Rules compile.  The Member 
Objects will cause an error to display. 

 

The error will also display when the rules are executed through the application. 
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Member Object Identify Problematic Rules 
Early rules may have been designed in a manner where the Member object was written-to directly.  This 
syntax is no longer valid and is the cause of the compile and application errors. 

 

The Objects related to Member can be viewed using the “IntelliSense” feature, and each will be 
identified with their “read-only” status. 

 

Member Object Rules Solution  
The new design of the rule must define the objects while the member is constructed in the rules using 
the Member constructor to define the Member variable.  The resulting variable is then used to update 
the metadata or metadata properties. 

This function contains multiple variations depending upon the use requirements.   

The example below is the common syntax requirement to create a new member, such as a User Defined 
member. 

Member( memberPk , Name as String, Description as String, dimID as Integer ) 
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Member Object Updates to Existing Members 

There may also be instances where business rules are used to modify existing metadata member 
properties.   Since the Objects are now read-only, updates to existing member objects, such as 
Descriptions, must be performed using the Member constructor.  This will require the use of an 
alternate syntax on the Member function. 

The existing member’s properties must be passed into the function, updating only the desired property.  
For example, all the existing properties of the current member can be used in the New Member 
constructor, modifying only the “Description” property to perform an update to the existing member. 
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Upgrading System Components 
The following section describes the process to upgrade the complete OneStream XF system. 

Step 1: Stop OneStream Application Pools Prior to Uninstall.  

1.) On each OneStream server, launch Internet Information Services Manager  
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager). 

2.) Expand the server in the left pane and select Application Pools. 
This will display a list of application pools in the right pane. 

3.) Close any open OneStream Configuration Utilities. 

4.) Stop the OneStreamAppAppPool and/or OneStreamWebAppPool by right-clicking on each and 
selecting Stop.  

5.) Repeat these steps for each server in the environment. 

Step 2: Uninstall the OneStream XF Servers Package. 
To upgrade to a new release, the previous software release must be uninstalled from all servers before 
the new release can be installed on each server in the environment. 

1.) Navigate to Control Panel > Programs and Features > Uninstall a Program and locate the OneStream 
Servers component in the list. 

2.) Right-click on the OneStream Servers component and select Uninstall. 

3.) If the OneStream Studio is also installed, locate the OneStream Studio component in the list, right-
click and select Uninstall. 

Step 3: Re-Install the OneStream XF Servers Package on an Application Server. 

This is the primary OneStream XF installation package. This wizard-based package is used to install a 
complete server setup, which includes the web server, application server, and all utilities.  This can also 
be used for a custom install, which allows the user to pick and choose the appropriate components for 
the server type being built. 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package. 

2.) Click Next at the landing page and accept the License Agreement. 

3.) Select the Custom option and click Next. 

4.) Choose the installation directory where the software was previously installed and click Next. 

5.) Choose the Application Server and Server Configuration Utility on the Select Features page and 
click Next. 
Note: The Database Configuration Utility may also be chosen if the application server is the server 
where the Database Configuration Utility was installed in the previous version of OneStream XF. 
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6.) Click Install to install the software and click Finish when it is complete. 

Step 4: Re-Install the OneStream XF Servers Package on a Web Server. 

1.) Browse to the OneStream Servers package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package. 

2.) Click Next at the landing page and accept the License Agreement. 

3.) Select the Custom option and click Next. 

4.) Choose the installation directory where the software was previously installed and click Next. 

5.) Choose the Web Server and Server Configuration Utility on the Select Features page and click Next. 

NOTE: If Mobile is installed, check the Mobile Web Server Option also. 

6.) Click Install to install the software and click Finish to complete. 

Step 5: Re-Install the OneStream XF Studio Package. 

1.) Browse to the OneStream Studio package, right-click on Setup.exe and select Run as Administrator 
to execute the server installation package. 

2.) Click Next at the landing page and accept the License Agreement. 

3.) Select the Custom option and click Next. 

4.) Select the installation directory where the software was previously installed 
(C:\ProgramFiles(x86)\OneStreamSoftware), and click Next. 

5.) Choose all options on the Select Features page and click Next. 

6.) Click Install to install the software and click Finish to complete. 

Step 6: Upgrade OneStream XF Framework and Application Databases. 

Note: Make sure to have the DBA backup all OneStream Databases (Framework/Application Databases) 
prior to running the schema update operation. 

1.) On the OneStream application server with the OneStream Database Configuration Utility installed, 
navigate to the utility 
Start > Programs > OneStream Software > OneStream Database Configuration Utility. 

2.) Right-click on the utility and choose Run as Administrator. 

3.) Right-click on the OneStream Framework Database and choose Upgrade Database Version. 
Note: If this is grayed out, an upgrade to the database is not necessary. 

4.) Confirm the upgrade of the database. 
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5.) Repeat this process for the application database(s) as necessary. 

Step 7: Update ASP.NET Configuration File with Configuration File Folder Location. 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility). 

2.) Right-click on the utility and select Run as Administrator. 

3.) Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream 
Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program 
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers and select the 
web.config file. 

4.) When the web.config opens, paste the Configuration Files Folder path. 

5.) Close the file and Save. 

6.) Repeat this process on each server in the environment. 

Step 8: Update Application and Web Server Config Files. 

1.) Open the Application Server Configuration file and Click File > Save. 

2.) Close and re-open the Application Server Configuration File. 

3.) Scroll to Database Server Connections and select the ellipsis (…) icon. 

• Update the command Time-outs for the OneStream Database Server Connection: 

o Short = 90 *must do 

o Large = 900 (minimum of 900) 

4.) Save and Close the Application Server Configuration file. 

5.) Open the Web Server Configuration file. 

6.) Click File > Save. 

7.) Close the Web Server Configuration file. 

Step 9: Update the Identity to the OneStream Service Account in Internet Information Services 
Manager (IIS) Using OneStream Server Configuration Utility “Configure IIS Tool.” 

1.) On each OneStream server, navigate to the OneStream Server Configuration Utility  
(Start > Programs > OneStream Software > Server Configuration Utility). 

2.) Right-click on the utility and select Run as Administrator. 

3.) Choose Tools > Configure IIS. 
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4.) Update the Configure IIS Dialog as follows: 

a. Web Site Name: Enter the name of the OneStream IIS Website to update. 

i. OneStream App Server Site 

ii. OneStream Web Server Site 

iii. OneStream Mobile Server Site 

b. Check the “Update IIS Default Settings” box. 

c. Set the radio button for updating the appropriate website. 

i. Set the radio button to “Use XF Web Server Settings” when updating IIS for the 
OneStream Mobile Web Server Site. 

ii. Set the radio button to “Use XF Web Server Settings” when updating IIS for the 
OneStream Web Server Site. 

iii. Set the radio button to “Use XF App Server Settings” when updating IIS for the 
OneStream App Server Site. 

d. User Account Type: Select Custom Account. 

e. Enter the User Name and Password of the OneStream Service Account. 

5.) Click the Update IIS Settings button after setting the appropriate fields and click OK. 
6.) Repeat this to set the appropriate IIS Settings for the application pools in IIS. 
7.) Click the Reset IIS button to perform an IISRESET on the server for the changes to take effect. 
 

Step 10: Test the OneStream Environment Login. 

1.) Navigate to the OneStream Web URL or Windows App URL: 
http://<webserver>:50001/OneStreamWeb/OneStreamXF.aspx. 
http://<webserver>:50001/OneStreamWeb/OneStreamWindowsApp.aspx. 

2.) Verify the ability to login to OneStream XF. 

3.) Select System Administration from the application drop-down list and click Connect. 

4.) Navigate to the System tab, Tools > Environment. 
This will display a list of all application servers and their server status. 

5.) Verify each server’s status shows as active and green. 

Step 11: Verify the application. 

1.) Compile ALL Business Rules. 
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• Right-click the grid and Export any errors for analysis using an Excel file format. 

• Apply updates to Business Rules as need. 

2.)  Import new Standard Reports after downloading from the Store on XF MarketPlace. 
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