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Overview

The Snippet Editor solution lets you create and edit sample OneStream snippets. Snippets

provide pre-tested code samples, making it easier to write high quality scripts in OneStream in a

shorter amount of time.

Hundreds of sample snippets are included and ready to be imported into any OneStream server

instance. There are several categories of snippet samples, including:

l Formulas

l Calculations

l Lists

l Data flows

l Rules

l Helpers

l Mappings
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Setup & Installation

This section contains important details related to the planning, configuring, and installation of

your solution. Before you install the solution, familiarize yourself with these details.

See also: OneStream Solution Modification Considerations

Dependencies

Component Description

OneStream 6.2.0

or later

MinimumOneStream Platform version required to install this version

of Snippet Editor.

Experience is required to write VB.NET code snippets in OneStream and in the Snippet Editor.

Refer to Microsoft VB.NET reference documentation for more information on writing snippets.

Select the Snippet Editor Development

Location

Before installation, decide whether to build the solution directly in the Production OneStream

application or in a separate Development OneStream application. This section provides some key

considerations for each option.
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Production OneStream Application: The primary advantage of building the solution in a

Production application is that you will not have to migrate the resulting work from a Development

application. However, there are intrinsic risks when making design changes to an application

used in a Production capacity and it is not advised.

NOTE: OneStream strongly recommends that you implement the solution in the

Development environment with a fresh copy of the Production application before

starting work.

Development OneStream Application: As a best practice, use the Development OneStream

application to build the solution.

Create the OneStream Development

Application

1. Ensure all OneStream artifacts relating to Snippet Editor are in the Production application.

2. Copy your Production OneStream application to your Development environment and

rename it. This Development version is used for your Snippet Editor project.

Application Server Settings

You may need to edit the OneStream Application Server Configuration so users can create and

change data in the additional database tables. If other OneStream Solutions (such as Specialty

Planning) are already in the application, these adjustments may already exist.

See also: Solution Database Migration Advice
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Configure the OneStream Application Server

Be sure that the security group settings include the users who work on and set up the solution

before proceeding.

NOTE: Group settings are applicable to all OneStream Solutions; it is important to

keep the group names generic.

1. Start the OneStream Server Configuration Utility as an Administrator.

2. ClickOpen Application Server Configuration File > Database.

3. Edit the followingOneStream Database Server properties:

l Access Group for Ancillary Tables: Select a group that includes those who will access

records.

l Can Create Ancillary Tables: True

l Can Edit Ancillary Table Data: True

l Maintenance Group for Ancillary Tables: Select a group to edit and maintain tables.
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l Table Creation Group for Ancillary Tables: Select a group who can create tables.

4. Restart Internet Information Server.

Application Server Settings

You may need to edit the OneStream Application Server Configuration so users can create and

change data in the additional database tables. If other OneStream Solutions (such as Specialty

Planning) are already in the application, these adjustments may already exist.

See also: Solution Database Migration Advice

Configure the OneStream Application Server

Be sure that the security group settings include the users who work on and set up the solution

before proceeding.

NOTE: Group settings are applicable to all OneStream Solutions; it is important to

keep the group names generic.
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1. Start the OneStream Server Configuration Utility as an Administrator.

2. ClickOpen Application Server Configuration File > Database.

3. Edit the followingOneStream Database Server properties:

l Access Group for Ancillary Tables: Select a group that includes those who will access

records.

l Can Create Ancillary Tables: True

l Can Edit Ancillary Table Data: True

l Maintenance Group for Ancillary Tables: Select a group to edit and maintain tables.

l Table Creation Group for Ancillary Tables: Select a group who can create tables.

4. Restart Internet Information Server.
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Install Snippet Editor

1. In the OneStream Solution Exchange, go toOneStream Solution > Snippet Editor.

2. On the Snippet Editor Solution page, select the appropriate OneStreamplatform version

from theMinimum Platform Version drop-down list.

3. Select the most recent version from the Solution Version drop-down list and then click

Download.

4. Log in to OneStream.

5. On theApplication tab, click Tools > Load/Extract.

6. On the Load tab, locate the solution package using the Select File icons and clickOpen.

7. When the solution’s file name appears, click Load.

8. ClickClose to complete the installation.

Set Up Snippet Editor

The first time you run Snippet Editor, you are guided through the table setup process.

l In OneStream, clickCommunity Solution> Dashboards > Snippet Editor > Snippet

Editor.
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Create Tables and Launch Solution

1. Click Step 1: Create Tables.

This step may be necessary when upgrading even if tables already exist. Snippet Editor

does not drop existing tables but modifies table structures and will add new ones if

necessary.

2. When setup is complete, click Step 2: Launch Solution to open Snippet Editor.

Package Contents

The Dashboard Maintenance Unit provides the user interface for Snippet Editor and includes the

required Dashboard Groups, Components, Data Adapters, Parameters, and files.

Business Rules: The following Business Rules are included:

SNE_HelperQueries

Dashboard dataset Business Rule that can look up lists of snippets and snippet categories.

SNE_SolutionHelper

Dashboard extender Business Rule that allows for the addition, maintenance and navigation of

snippets on the main dashboard.
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SNE_ParamHelper

Dashboard XFBR string Business Rule provides conditional parameter processing functions that

allow a parameter value to be interpreted and substituted with a different string.
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Settings

The Settings page contains theGlobal Options tab in which key properties that

guide administration are set as well asCategories andUninstall options.

Global Options

TheGlobal Options page should be the first page accessed during the initial setup and

configuration of Snippet Editor.

NOTE: All global option settings are retained during solution upgrades

Default Author

The Default Author is automatically assigned to a new snippet. This freeform text field displays in

the Author field of Snippet Editor grids.

You can change an individual snippet author’s name on the Editor page.
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Categories

Organize your snippets by creating categories and sub-categories. Categories and sub-

categories align your snippets into logical groups for the current module type and let you

customize their display in Snippet Editor.

TheModule Type drop down contains a list of predefined snippet modules. Each module type is

only available in specific areas of OneStream. Module types include:

l General

l Finance

l Stage

l CubeView

l Dashboard

l Extender

l Event Handler
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The following grid shows each module’s availability in the Business Rules and other areas of

OneStream.

Categories and SubCategories Button Bar

Use buttons in the Categories and SubCategories panes to add, delete, and save category and

sub-category entries. All created categories and sub-categories appear in the Category and

SubCategory drop-downs on the Editor page, which lets you filter the list of snippets on that

page.

See also: Editor

Insert Row - Add a new category or sub-category.

Delete Row(s) - Select a category or sub-category in the Category or SubCategory pane, then

click Delete in that pane to delete the item.

Cancel - removes changes made to categories and sub-categories since the last save.

Save - Saves updated task groups.
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Create Categories and SubCategories

TheCategories page includes aCategories pane and a SubCategories pane, where you can

build out the category and sub-category relationships for the current module type:

1. In theModule Type drop-down, select the module type for which you want to create

categories and sub-categories.

2. Click theAdd button in theCategories pane to create a new row, then click the Category

column in the new row to edit its contents.

3. Enter the name of the category you want to add and click Save.

4. ClickAdd in the SubCategories pane to create a new sub-category row, then click the

SubCategory column in the new row to edit its contents.

5. Enter the name of the sub-category you want to add and click Save.

6. Repeat steps 2 through 5 to add additional categories and sub-categories.

Uninstall

The Uninstall feature allows the Snippet Editor User Interface or the entire solution to be

uninstalled.

Note that if part of an upgrade, any modifications performed on standard Snippet Editor objects

will be removed. There are two Uninstall options:
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1. Uninstall UI removes Snippet Editor, including related dashboards and Rules but leaves the

database and related tables in place. For some releases, this step should be performed

before accepting any new version of Snippet Editor since some of the Dashboards or other

objects may have been modified.

l Choose this option if you want to accept a Snippet Editor update without removing

the data tables.

l The Snippet Editor  Release Notes will indicate if an overinstall is supported.

2. Uninstall Full removes all the related data tables, all data, Snippet Editor Dashboards, and

Business Rules.

l Choose this option to completely remove Snippet Editor or to perform an upgrade

that is so significant in its changes to the data tables that this method is required.
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Editor

Once you create categories and sub-categories, use the Editor page to create and edit

snippets. You also use this page to download a Microsoft Excel template and create snippet

information to import back into the Snippet Editor.

Select the grouping (Module|Category|SubCategory) using the drop down lists. Once selected,

click Refresh to display the snippets for the selected grouping. You can also add additional

snippets directly in the snippet grid, or edit existing snippets.
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Snippet Editor Filters

Snippet Editor filters display on the Snippet Editor page. Use the drop-down lists to apply filters

to see only specific snippets.

Module Type

These are the pre-defined module types in the system that categories and sub-categories are

based. Select one of the module types from the list to display snippets created for that type.

Module types are defined when Business Rules are created in OneStream.

See also: Categories

Category

These are the categories for the selected module using the Categories page of the Snippet

Editor settings. Use the list to select the category for which you want to view and create snippets.

See also: Categories

SubCategory

These are the sub-categories you created for the selected module and category using the

Categories page of the Snippet Editor settings. Use the list to select the sub-category within the

selected category for which you want to view and edit snippets.

See also: Categories
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Snippet Editor Buttons

Refresh

Refreshes the grid that displays snippet data. Click Refresh after selecting display criteria in the

Module Type, Category, and SubCategory dropdowns to display snippet content matching the

selection criteria.

Import

Allows you to navigate to and select a Microsoft Excel file containing snippet data you want to

import into OneStream Snippet Editor.

See also: Import Snippet Data

Download

Allows you to download a Microsoft Excel template you can use to create or load snippet data

from an external source.

See also: Download Template

Import Snippet Data

OneStream provides a Microsoft Excel template you can use to create snippet data or load it

from an external source, then import data back into OneStream. In the template on the Snippet

Template tab, enter updates to or add new snippet data in the ranges between the blue lines.

Insert additional rows within this range to allow for more snippet data.

The Module Type field in the template lets you select a predefined module type . When loading

snippet data, each snippet’s module type must match the module types in the list, otherwise an

error occurs during import.

To manually enter snippet data in the template, start by selecting a valid module type from the

dropdown. Then you can enter data in the rest of the fields to complete a snippet data record.
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After entering data in the template, save it and close the file before importing.
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Download Template

OneStream provides a Microsoft Excel template you can use to define your snippets. Once

defined, you can import the snippet data into OneStream , where you can view and further edit

them in the Snippet Editor. Use the Snippet Template tab in the template to enter updates to or

add new snippet entries in the ranges between the blue lines. Insert additional rows within this

range to allow for more snippet data.

After entering data in the template, save it and close the file before importing.

Pivot

The Pivot page displays all snippets in a grid and has drag and drop capabilities

which allow users to pivot on any field in the grid.

Use the Pivot page to see only the specific existing snippets you want to focus on. Drag a column

to the blue row at the top of the grid to pivot on that field.
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Help & Miscellaneous Information

This page contains additional solution documentation for the Snippet Editor.

Display Settings

OneStream Solutions frequently require the display of multiple data elements for proper data

entry and analysis. Therefore, the recommended screen resolution is a minimum of 1920 x 1080

for optimal rendering of forms and reports.

Additionally, OneStream recommends that you adjust the Windows System Display text setting

to 100% and do not apply any Custom Scaling options.

Package Contents & Naming Conventions

The package file name contains multiple identifiers that correspond with the platform. Renaming

any of the elements contained in a package is discouraged in order to preserve the integrity of

the naming conventions.

Example Package Name: SNE_PV6.2.0_SV100_PackageContents.zip

Identifier Description

SNE Solution ID

PV6.2.0 Minimum Platform version required to run solution
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Identifier Description

SV100 Solution version

PackageContents File name

Solution Database Migration Advice

A development OneStream application is the safest method for building out a solution with

custom tables such as this one. The relationship between OneStream objects such as workflow

profiles and custom solution tables is that they point to the underlying identifier numbers and not

the object names as seen in the user interface. Prior to the solution configuration and to ensure

the identifiers match within the development and production applications, the development

application should be a recent copy of the production application. Once the development

application is created, install the solution and begin design. The following process below will help

migrate the solution tables properly.

See also:Managing aOneStream Environment in theDesign and ReferenceGuide.

1. In the production OneStream application, install the solution and create the data tables.

See Configure the OneStream Application Server for Database Server Connection settings

and installation details.

2. Data tables are created in the OneStream Development application during the solution

installation. Using the Microsoft Data Migration Assistant, copy the data from the tables to

the Production Microsoft SQL Server Database. Only the Microsoft SQL Administrator

should run the migration assistant.
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IMPORTANT: This process has the potential to overwrite existing table data in the

production application database if data already exists.

Extract and Reload Table Data

All updates made in Snippet Editor are stored in the BRSnippet table in the framework. The data

for the BRSnippet table can be extracted to an XML file, then loaded back into OneStream after

migrating the database.

1. In OneStream, click System > Tools > Load/Extract.

2. Click the Extract tab, then select Snippets from the File Type drop-down. Snippet items to

extract appear in the Items to Extract tree view. All snippets are selected for extraction by

default.

3. Click Extract, then use the Windows Save As dialog box to navigate to and select the

location to store the extract XML file.

4. ClickOK.

Once the framework database is migrated, you can load the XML file back into OneStream.

1. In OneStream, click System > Tools > Load/Extract.

2. Click the Load tab, then click the ellipsis button in the File Name field.

3. Use the WindowsOpen dialog box to navigate to and select the location where you stored

the extracted XML file.

4. ClickOpen, then click Load to load the snippet data back into OneStream.

A progress bar indicates when the load completes.
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OneStream SolutionModification

Considerations

A few cautions and considerations regarding the modification of OneStream Solutions:

l Major changes to business rules or custom tables within a OneStream Solution will not be

supported through normal channels as the resulting solution is significantly different from

the core solution.

l If changes are made to any dashboard object or business rule, consider renaming it or

copying it to a new object first. This is important because if there is an upgrade to the

OneStream Solution in the future and the customer applies the upgrade, this will overlay

and wipe out the changes. This also applies when updating any of the standard reports

and dashboards.

l If modifications are made to a OneStream Solution, upgrading to later versions will be more

complex depending on the degree of customization. Simple changes such as changing a

logo or colors on a dashboard do not impact upgrades significantly. Making changes to the

custom database tables and business rules, which should be avoided, will make an

upgrade even more complicated.
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