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Scheduling the Upgrade

Upgrading from Platform Releases pre-8.0
When upgrading from a Platform Release prior to 8.0 to Platform Release 8.0 or later, OneStream 

encourages customers to prepare for their upgrade by referencing content in the OneStream 

Community Platform v8+ Upgrades Group.

OneStream Cloud customers may initiate Platform Release 8.0 or later upgrade interest by 

submitting a Software Upgrade request through the Service Catalog. A Cloud Migration ticket will 

be opened and available to track upgrade activities.

OneStream self-hosted customers may download Platform Release 8.0 or later from Solution 

Exchange. Visit Customer v8 Upgrade Summary & Readiness Checklist Documents on 

OneSteam Community for additional resources.

Upgrading from Platform Release 8.0
Upgrades from Platform Release 8.0 or later follow traditional OneStream best practices. Cloud 

customers can initiate and schedule upgrades through the Software Upgrade request on the 

Service Catalog.

OneStream self-hosted customers may download the latest Platform Release directly from 

Solution Exchange and proceed with their upgrade.
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Requirements
Information Technology professionals responsible for installing, maintaining and supporting 

OneStream, must satisfy the following requirements to best support an upgrade. They must also 

review the requirements and special notes in the Installation and Configuration Guide and 

Release Notes.

IMPORTANT: Platform Release 8.2 and later was developed using Microsoft .NET 8. 

As a result, all Business Rules must be tailored for .NET 8. For more information, see 

Platform Release 8.0 or Later Readiness.

 l OneStream Platform Release 8.2 or later requires Microsoft .NET 8.

 o App Server and Web Servers

 n Install the latest version of ASP.NET Core Runtime (Hosting Bundle) 

(minimum v8.0.2).

 n Install the latest version of .NET Desktop Runtime (x64) (minimum v8.0.2).

 o Client

 n Install the latest version of .NET Desktop Runtime (x64) (minimum v8.0.2).

IMPORTANT: Do not install the .NET SDK package. You may run into errors 

while upgrading if this is installed. 

 l OneStream Servers requires IIS 7 or later.

 l In each application, complete the Compile all Business Rules and Formulas to verify 

that business rules use the proper syntax.
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 l If your applications are referencing any 3rd party DLLs that are not provided by OneStream, 

verify these DLLs are .NET 8 compatible. Contact OneStream Support 

(https://www.onestream.com/support/) to discuss available upgrade options.

 l When upgrading OneStream, ensure to update the database schema if an update is 

available. We recommend full database backups.

 l Backup the Configuration files in your OneStream Share directory.

 l For additional minimum system requirements, see Hardware and Software Requirements 

in the Installation and Configuration Guide.

 l When implementing Smart Integration Connector with the OneStream application, see 

Requirements in the Smart Integration Connector Guide.

IMPORTANT: Self-hosted customers must have a successful database connection 

prior to the Database Upgrade. See Enable the Trust Server Certificate.
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Before Upgrading
Perform these tasks before upgrading:

 1. Perform a full backup of all OneStream databases.

 2. Download the OneStream installation package from the Solution Exchange:

 a. Log in to the Solution Exchange and select Platform to get the latest version of 

OneStream.

 b. Download the appropriate On-Premise package to get the appropriate setup files for 

the server installation.

 3. Verify the location of the OneStream configuration files:

 a. On a OneStream server, select Start > Programs > OneStream Software > Server 
Configuration Utility.

 b. Right-click the utility and select Run as Administrator.

 c. Select File > Open ASP.NET Configuration File and browse to the appropriate 

location.

 l On web servers: C:\Program Files\OneStream Software\OneStream

WebRoot\OneStreamWeb and select appsettings.json.

 l On application servers:C:\Program Files\OneStreamSoftware\

OneStreamAppRoot\OneStreamApp and select appsettings.json.

 d. The file opens and displays the path to the XFAppServerConfig.xml and 

XFWebServerConfig.xml configuration files.
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 e. Copy and paste the path to the configuration file. You will specify this location during 

the upgrade.

NOTE: This path is commonly set to C:\OneStreamShare\Config

 4. For a backup, copy these configuration files.

 5. Close the file without saving and exit the utility.

 6. Verify the OneStream service account in Internet Information Services Manager:

 a. The service account must be an Admin ID or in the IIS_IUSRS Group, Performance 

Log User and Performance Monitor Users group. The ID is required for queuing and 

CPU monitoring.

 b. On each OneStream server, select Start > Control Panel > Administrative Tools > 

Internet Information Services (IIS) Manager.
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 c. Expand the server and select Application Pools. This displays application pools to 

the right. The OneStreamAppAppPool and OneStreamWebAppPool service 

accounts display in the Identity column. Note the Windows account and password as 

you will enter them in IIS after the upgrade.

 7. Verify the availability of the OneStream Application Server where:

 l The OneStream Database Configuration Utility is installed: On each OneStream 

application server, click Start > Programs> OneStream Software and verify that 

the OneStream Database Configuration Utility is installed.

 l OneStream is installed: On each OneStream application server, 

Start > Programs> OneStream Software to verify that OneStream is installed. 

 8. Install the following :

 l App Server and Web Servers

 o Install the latest version of ASP.NET Core Runtime (Hosting Bundle) 

(minimum v8.0.2).

 o Install the latest version of .NET Desktop Runtime (x64) (minimum v8.0.2).

 l Client

 o Install the latest version of .NET Desktop Runtime (x64) (minimum v8.0.2).

 9. On-prem customers must enable the Trust Server Certificate for the following:

OneStream Database Server 

From the OneStream Server Configuration Utility:
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 a. Locate Database Server Connections.

 b. Click  to open the Database Server Connections.

 c. Add "Trust Server Certificate=True" to the end of the Connection String.

 d. Click OK.

All Application Databases

From the OneStream Database Configuration Utility:

 a. Right-click on a database, click Edit the Database Configuration.

 b. Select Advanced.

 c. Set Trust Server Certificate to True, then click OK.
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 d. Select Test Connection to ensure a successful connection.

NOTE: Alternatively, set the Trust Server Certificate to True directly in the XML. 

Repeat these steps for all Application Databases.
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Upgrade System Components
Perform the tasks in the following sections - in order, to upgrade the complete OneStream system.

Uninstall OneStream Servers
 1. Select Control Panel > Programs and Features > Uninstall a Program and locate the 

OneStream Servers component.

 2. Right-click OneStream Servers and select Uninstall.

Uninstall OneStream Client API
If installed, perform the following steps to uninstall the Client API:

 1. Select Control Panel > Programs and Features > Uninstall a Program and locate the 

OneStream Client API component.

 2. Right-click OneStream Client API and select Uninstall.

Re-Install OneStream Servers on an 
Application Server
This is the primary installation package that performs a complete server setup, including the web 

server, application server and all utilities. You can perform a custom install to choose the 

appropriate server components.
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 1. Browse to the OneStream Servers package, right-click OneStreamServers-#.msi and 

select Install to run the server installation.

 2. Click Next on the landing page and accept the License Agreement.

 3. Specify the directory where the software was previously installed and click Next.

 4. Select Custom.

 5. On Select Features, choose Application Server and  Server Configuration Utility and 

click Next.

NOTE: Choose the Database Configuration Utility and Upgrade Assistant Utility if 

the application server is the server where the Database Configuration Utility was 

previously installed.
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 6. Click Install then Finish.

Re-Install OneStream Servers on a Web 
Server

 1. Browse to the OneStream Servers package, right-click OneStreamServers-#.msi  and 

select Install.

 2. Click Next and accept the License Agreement.

 3. Specify the directory where the software was previously installed and click Next.

 4. Select Custom.

 5. On Select Features, choose Web Server and Server Configuration Utility and click 

Next.
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 6. Click Install then Finish.

Re-Install OneStream for Desktop
 1. Browse to the OneStream package, right-click OneStreamDesktop-#.msi and select 

Install.

 2. Click Next and accept the License Agreement.

 3. Select Custom.

 4. Select the directory where the software was previously installed and click Next.

 5. On Select Features, select all options and click Next.

 6. Click Install then Finish.
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Upgrade the Framework and Application 
Databases
Changes are made to stage tables for this release, so the database update may take time.

 1. Before performing these steps, have a database administrator back up all OneStream 

databases.

 2. On the OneStream application server with the OneStream Database Configuration Utility 

installed, select Start > Programs > OneStream Software > OneStream Database 
Configuration Utility.

 3. Right-click the utility and select Run as Administrator.

 4. Right-click OneStream Framework Database and choose Upgrade Database Version. 

If disabled, an upgrade is not required.

NOTE: If you get an error, check the log for details: C:\Program Files\OneStream 

Software\XFDatabaseConfig\Log

 5. A dialog box displays giving you the option to process the schema upgrade on the database 

or the server. Leave the text field blank and click Yes to begin the database upgrade using 

the default setting, which is database. 
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 6. When complete, confirm the upgrade.

 7. Repeat the upgrade for each Application database and the Framework database until 

the option is disabled. This indicates the database is up-to-date.

Run the Upgrade Assistant Utility

Guidance for self-hosted environments

This is an additional step for when upgrading from a Platform Release pre 8.0 to a Platform 

Release 8.0 or later and must be performed. Specifically, this version of the Upgrade Assistant 

Utility will convert any legacy reports that were stored in CodeDOM format to now be stored as 

XML.

 1. On the OneStream application server with the OneStream Upgrade Assistant Utility 

installed, select Start > Programs > OneStream Software > OneStream Upgrade 
Assistant Utility.

 2. From the command line enter: 

xfupgradeassistant -c C:\OneStreamShare\Config\XFAppServerConfig.xml -t 

ReportLayoutBytes -v -update

NOTE: C:\OneStreamShare\Config is the default path to the configuration file. 

You must update this path if it has been modified for your environment.

 3. Enter exit to close the utility.

 4. Restart IIS.
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Update the ASP.NET Configuration File
The ASP.NET Configuration file (appsettings.json) must be updated on every server / folder as 

outlined below:

 l Application server

 o C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp\appsettings.json

 o C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamMgmt\appsettings.json

 l Web servers:

 o C:\Program Files\OneStream 

Software\OneStreamWebRoot\OneStreamWeb\appsettings.json

 o C:\Program Files\OneStream 

Software\OneStreamWebApiRoot\OneStreamWebApi\appsettings.json

 o C:\Program Files\OneStream 

Software\OneStreamWebUIRoot\OneStreamWebUI\appsettings.json

 1. On each OneStream server, launch the OneStream Server Configuration Utility by clicking 

Start > Programs > OneStream Software > Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Choose File > Open ASP.NET Configuration File and browse to the appropriate location 

from the folders above.

 4. Select the appsettings.json file.

 5. When the file opens, copy the directory path of the configuration files.
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NOTE: This path is commonly set to C:\OneStreamShare\Config

 6. Enable HTTP and Enable HTTPS are enabled by default. 

NOTE: Clear Enable HTTP when SSL is enabled or clear Enable HTTPS when 

SSL is not enabled.

NOTE: For the WebUI server file for the Modern Browser Experience and the 

WebApi server file, a configuration file is not saved to the OneStreamShare folder, 

and you are not asked to select a checkbox to enable HTTP or HTTPS.

 7. Save and close the file.

 8. Repeat these steps on each web and app server in the environment.

Upgrade Guide 16

Upgrade System Components



Generate Pass-Thru Stubs in the Web Server 
Configuration File
OpenIdRedirectUrl helps to configure OpenId Connect protocol redirects and cookies so that 

authentication works properly when application server is hosted under non-root virtual path and is 

behind reverse proxy. The OpenIdRedirectUrl value must have fully qualified domain name of the 

site and “/signin-oidc” path. See the example below. 

<!-- XFWebServerConfig.xml -->
<OneStreamXF>
 <WebServerConfigSettings>
 <SSOSettings>
 <OpenIdIdentityProvider>
 <OpenIdRedirectUri>enter signin url</OpenIdRedirectUri>
 </OpenIdIdentityProvider>
 </SSOSettings>
 </WebServerConfigSettings>
</OneStreamXF>

To update the Open Id Redirect Url perform the following:

 1. Open the Web Server Configuration File. 

 2. Open the Single Sign On Identity Provider.

 3. Go to Identity Provider Specific Settings and select your provider. In this example, Azure 

Identity Provider is selected.
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 4. Paste the Open Id Redirect Url from the XML code snippet under Open Id Redirect Url.

 5. Paste the OneStream Windows App Redirect UrI.
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IMPORTANT: The Open Id Redirect UrL and OneStream Windows App Redirect 

UrI cannot be the same. 

 6. Click OK twice.

 7. Click Save. 

Update the Configuration Files
 1. Open the Application Server Configuration file from C:\OneStreamShare\Config in a text 

editor and select Save.

 2. Open the OneStream Server Configuration Utility, Run as Administrator.

 3. Select File > Open and select the file from C:\OneStreamShare\Config. In Database 
Server Connections, select the ellipsis and update the command time-outs for the 

OneStream Database Server connection:

Short = 90    *must do

Large =900 (minimum or 900)
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 4. Select File > Save and close the file.

 5. Repeat these steps for the Web Server Configuration file.

Update and Configure IIS
 1. On each OneStream server, open the OneStream Server Configuration Utility by clicking 

Start > Programs > OneStream Software > Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Choose Tools > Configure IIS.

 4. In Configure IIS, specify the following:

 a. For Web Site Name, enter the name of the OneStream IIS Website to update.

 b. The OneStream App Server, and Web Server sites.

 5. Select Update IIS Default Settings.

 6. Select options to update IIS for the appropriate websites:

 a. Use Web Server Settings: Specify the Web Server site.

 b. Use App Server Settings: Specify the App Server site.

 c. User Account Type: Specify Custom Account, then enter the user name and 

password of the OneStream Service account.

 7. Click Update IIS Settings then OK.

 8. Repeat these steps to set the appropriate IIS settings for the application pools in IIS.

 9. Logon to each OneStream Web Server in the environment.

 10. Browse to C:\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb

 11. Locate the OneStreamWeb.runtimeconfig.json file and open this file in a text editor.
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 12. Update the Config Properties section with the following line: 

"System.Threading.ThreadPool.MinThreads": 128

"configProperties": {
      "System.GC.Server": true,
      "System.Reflection.Metadata.MetadataUpdater.IsSupported": false,
      "System.Runtime.Serialization.EnableUnsafeBinaryFormatterSerialization": false,
      "System.Threading.ThreadPool.MinThreads": 128
    } 

NOTE: Be sure to place a comma ahead of the previous line as shown above.

 13. Save the file for the change to take effect

 14. Click Reset IIS.

Test the Windows Client Login Using 
ClickOnce

 1. Using the Microsoft Edge Web Browser, navigate to the OneStream Windows App URL:

 l On Prem: http://<webserver>:50001/OneStreamWeb

 l Cloud: https://<customer>.onestreamcloud.com/OneStreamWeb

 2. Click Open to launch the ClickOnce Windows app.

 3. Confirm that you can log in.

 4. From Application, select System Administration then click Connect.

 5. Select System > Tools > Environment to identify the application servers and their status.

 6. Verify that each server is active.
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Test the Browser Experience Login
 1. Navigate to the OneStream Browser Experience URL:

 l On Prem for Browser Experience: http://<webserver>:50001

 l Cloud for Browser Experience https://<customer>.onestreamcloud.com

 2. Confirm that you can log in.

Verify the Application
 1. Compile all business rules, ensure to:

 l Right-click the grid and export any errors for analysis using an Excel file format.

 l Apply updates as needed.

 2. Download and import the Standard Application and Standard System Reports from the 

Solution Exchange.
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Platform Release 8.0 or Later 
Readiness
Upgrading your OneStream Platform to Release 8.2 or later requires .NET 8.

Business Rules
NOTE: Users upgrading from Platform Release 8.0 or later are not expected to require 

Business Rule maintenance.

Users upgrading from a Platform Release prior to 8.0 will require Business Rule maintenance as 

Platform Release 8.0 includes updates and enhancements to the Business Rules compiler to 

improve syntax detection. Administrators must resolve these errors to compile business rules 

fully. Warning messages identify line items that will function, but you should update them to 

support the latest compiler’s requirements. Resolving these warnings varies. You may be able to 

use a provided replacement function or change a function’s properties.
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System.Data.SqlClient to Microsoft.Data.SqlClient 
Migration

IMPORTANT: 
In order to maintain consistency with Microsoft's recommendations, in Platform Release 

8.1, the data access driver for SQL Server will be updated from System.Data.SqlClient 

to Microsoft.Data.SqlClient.  This migration will be automatic and will take place during 

the database upgrade process.  All references to System.Data.SqlClient will 

automatically be upgraded to Microsoft.Data.SqlClient in Business Rules, Member 

Formulas, and the like.

NOTE: 
These updates will take place automatically during the database upgrade to Platform 

Release 8.1, and when using the Load function of Application Load/Extract, instances 

of System.Data.SqlClient will automatically convert to Microsoft.Data.SqlClient.

IMPORTANT: 
If an application was migrated after the Platform Release 8.1 upgrade from Application 

Copy (Cloud Administration Tools (CAT)) or a database BACPAC file, then the migration 

from System.Data.SqlClient to Microsoft.Data.SqlClient will need to be applied directly 

to that application. On-prem customers can run the Upgrade SqlClient Namespace 

References from the OneStream Database Configuration utility to replace 

System.Data.SqlClient references. SaaS customer can request to have this run by 

contacting OneStream Support (https://www.onestream.com/support/).

For more information, visit the Platform v8+ Upgrades page on OneStream Community.
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Example
Business Rule Updates: Update Using and Import statements to reference 

Microsoft.Data.SqlClient using the following code:

C# Prior to 8.1

using System.Data.SqlClient;
...
SqlConnection conn1 = new System.Data.SqlClient.SqlConnection();
System.Data.SqlClient.SqlConnection conn2 = (System.Data.SqlClient.SqlConnection)conn1;

C# For 8.1

using Microsoft.Data.SqlClient;
...
SqlConnection conn1 = new Microsoft.Data.SqlClient.SqlConnection();
SqlConnection conn2 = (Microsoft.Data.SqlClient.SqlConnection)conn1;    

Visual Basic Prior to 8.1

Imports System.Data.SqlClient
...
Dim conn1 As New System.Data.SqlClient.SqlConnection()
Dim conn2 As System.Data.SqlClient.SqlConnection = CType(conn1, 
System.Data.SqlClient.SqlConnection)

Visual Basic for 8.1

Imports Microsoft.Data.SqlClient
...
Dim conn1 As New Microsoft.Data.SqlClient.SqlConnection()
Dim conn2 As SqlConnection = CType(conn1, Microsoft.Data.SqlClient.SqlConnection)
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Custom DLLs
If your implementation / business rules reference any custom DLLs that are not provided by 

OneStream, these DLLs must be .NET 8 compatible. Contact OneStream Support 

(https://www.onestream.com/support/) to discuss available upgrade options.

ERPConnect (SAP)
ERPConnect45.dll enabling connection to SAP systems is no longer available in Platform 8.0 and 

later. A newer version ERPConnectStandard20.dll is available through the download "DLL 

Packages" from the Platform page of the Solution Exchange.

On-Prem Customers:

 1. Download ERPConnectStandard20.dll file to your integrations folder.

 2. Install the required Microsoft Visual C++ Redistributable latest supported downloads.

 3. Download and copy SAP NetWeaver RFC Library DLL (sapnwrfc.dll) to the integrations 

folder.

See Theobald Software ERPConnect Requirements for more information.

 4. Modify your business rules to use the ERPConnectStandard20.dll.

Cloud/SaaS Customers: ERPConnect is available through the Smart Integration Connector. 

See ERPConnect section of the SIC Guide for installation details or contact OneStream Support 

(https://www.onestream.com/support/) to discuss morel upgrade options.

Upgrade Guide 26

Platform Release 8.0 or Later Readiness

https://solutionexchange.onestream.com/dashboard/home/browse
https://learn.microsoft.com/en-us/cpp/windows/latest-supported-vc-redist?view=msvc-170#latest-microsoft-visual-c-redistributable-version
https://help.theobald-software.com/en/erpconnect/prerequisites-and-installation/requirements#other-applications-and-frameworks


Smart Integration Connector
Smart Integration Connector is required for OneStream Cloud integration with local customer data 

sources when using OneStream Platform Release 8.0 or higher. VPN is no longer supported with 

Platform Release 8.0 or higher and will reach end of service for Platform versions prior to version 

8 on August 31, 2024.

Authentication
Cloud Customers: OneStream IdentityServer is required for OneStream Platform Release 8.0 or 

later.

Self-hosted Customers: No changes necessary. Legacy Authentication support is the standard 

for self-hosted customers. 

.NET 8 Desktop Runtime and ASP.NET Core 
Runtime
To best align with Microsoft's long-term support strategy, OneStream Platform Release 8.2 or 

later is built using .NET 8. Platform Release 8.2 or later users are required to use the latest 

versions of .NET Desktop Runtime x64 (8.0.2 minimum) and ASP .NET Core Runtime Hosting 

Bundle (8.0.2 minimum).
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VBA Changes
ProcessSSOAuthenticationAndCreateToken is no longer supported as an authentication option 

from VBA scripts. See Visual Basic for Applications (VBA) Procedures for additional details. See 

Visual Basic for Applications (VBA) Procedures in the Design and Reference Guide for additional 

details.

Client API Changes
Client API is no longer provided with Platform Release 8.0 or higher. OneStream recommends 

Task Scheduler or the REST API to replace existing Client API use cases.

Tiles Page
The ClickOnce journey is enhanced to launch the application with a single click of the Open 

button while eliminating the tiles page. For more information, see Installation Using ClickOnce in 

the Installation and Configuration Guide.For more information, see Installation Using ClickOnce in 

the Installation and Configuration Guide.

Help Documentation
Help documentation has moved from within the application to 

https://documentation.onestream.com. Clicking the in-app help icon routes you to this site.
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Business Rule Groups
In version 8.0 the default for new Business Rule Access or Maintenance Groups is the 

Administrators group. This default can be changed by the Server Configuration Utility.

OneStream Solution Compatibility
Visit OneStream Solution Content on OneStream Community to ensure your OneStream 

Solutions are ready for your OneStream Platform upgrade.
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Help and Miscellaneous

Upgrade Troubleshooting

Incorrect Installation Order

Follow the steps in order as outlined in the Before Upgrading section. Use the following checks to 

help determine installation issue resolutions.

To check that you have the latest .NET versions installed, run the following command in the 

PowerShell:

dotnet --info

NOTE: The hosting bundle should be Microsoft.AspNetCore.App 8.0.x and the desktop 

runtime should be Microsoft.WindowsDesktop.App 8.0.x

To check that IIS is properly installed, run the following command in the PowerShell:

get-webglobalmodule

NOTE: The output must contain AspNetCoreModuleV2.

Resolution: Uninstall the hosting bundle and ensure that IIS is properly installed.
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Execution Policy when running PowerShell Script

Resolution: Run the following commands in the PowerShell:

 l PS C:\WINDOWS\system32> Set-ExecutionPolicy Unrestricted

 l PS C:\WINDOWS\system32> Set-ExecutionPolicy

Internet Explorer End-of-Use
When using ClickOnce, it must be invoked using Microsoft Edge. For more information, see 

ClickOnce in the Installation and Configuration Guide.

More details for IE end-of-use details are as follows:

As of July 2022, if you have an Internet Explorer ClickOnce shortcut to the OneStream Desktop 

Client application, it will not launch the application of any version when IE is disabled inside your 

organization. Starting with 7.0, newly created shortcuts will be created using Windows 

PresentationHost.exe. Upgrading to 7.0 will not automatically update existing shortcuts. You must 

manually create new ones or edit existing ones. To update an existing shortcut of any OneStream 

platform version, follow these steps:

 1. Right-click on the existing desktop shortcut and go to Properties.

 2. Copy and paste the text in the Target field into the notepad.

 3. Replace this section “C:\Program Files\Internet Explorer\iexplore.exe” with 

C:\Windows\System32\PresentationHost.exe-launchApplication (note that the “ “ are 

removed).

 4. Copy and paste the whole text into the target field inside the shortcut's properties, click 

Apply, then click OK.
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You will not be able to view embedded external web pages inside OneStream when IE is disabled 

inside your organization. Starting with 7.0, the external web pages will be embedded using the 

Microsoft Edge WebView2 runtime control. Microsoft automatically installs the WebView2 runtime 

on Windows 10 machines. You can verify if the component is installed on your machine through 

Add or Remove Programs. It can also be downloaded directly from Microsoft.

Once IE is disabled within your organization, embedded web pages will no longer render inside 

OneStream on versions 6.8 and older, even if you have WebView2 installed. If your application 

uses features that embed external web pages, usually through properties that allow pointing to a 

URL, an upgrade to 7.0+ will be required with the WebView2 runtime control. Key OneStream 

features that enable embedding external web pages:

 l Dashboard component Web Content

 l Dashboard component File Viewer

 l Dashboard component Button

 l A drill back Business Rule in Transformation Rules Connector
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