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About This Guide
This guide describes how to install and configure the platform. We suggest that these tasks are

performed by the Information Technology professional responsible for maintaining and supporting

your implementation.

This guide also:

l Identifies the best software configuration for an application’s particular requirements.

l Describes how to configure an external Identity Provider so you can use single sign on.

l Provides troubleshooting for common issues.

l Identifies considerations for enhancing performance.

About Upgrading
Refer to the Upgrade Guide for information about upgrading to the latest release, and to learn

about upgrade considerations, migration, and best practices.
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Infrastructure Requirements and
Preparation Checklist
The first step of your installation or upgrade is to contact OneStream Support by registering at:

https://www.onestream.com/support/. File a ticket for assistance. 

Use the checklist to prepare your environment before making an installation appointment.

l Hardware and software requirements, considerations, and configuration best practices for

the Web Server, Application Server, Data Server and Client Workstation.

l Minimum environment requirements and system infrastructure guidelines.

Web Server Requirements and
Considerations
Ensure that you have:

l Determined the number of web servers.

l Prepared for the Windows OS version that is installed with all updates.

l Enabled a High Performance Power Plan.

l OneStream Platform Release 8.2 or later requires Microsoft .NET 8.
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o App Server andWeb Servers

n Install the latest version of ASP.NET Core Runtime (Hosting Bundle)

(minimum v8.0.2).

n Install the latest version of .NET Desktop Runtime (x64) (minimum v8.0.2).

o Client

n Install the latest version of .NET Desktop Runtime (x64) (minimum v8.0.2).

l Configured load balancing.

l Disabled any Anti-Virus services. You can re-active anti virus after installation and exclude

the OneStream installation directory.

l A supported version of Internet Information Server (IIS).

l Discussed and planned for the size of each Web Server and implement the CPU and

Memory minimums.

l Enabled Network Discovery so all OneStream servers can communicate.

l Implemented the file sharing best practices.

l Emailed OneStream Support so you can download the installation package from the

OneStream Solutions portal on the Solution Exchange and put the installation package on

the desktop or a folder on each server.

l Windows Process Activation Service (WAS).

Installing and Setting up Internet Information Server

You must install a supported version of Internet Information Server (IIS).

NOTE: The .NET Framework and Environment versions in IIS may not match your

system versions. This does not affect the installation.
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After installing, enable the required server roles as follows:

l Go to Add roles and features.

l Select Next until you can selectWeb Server (IIS).
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l If the following windows appears during installation, click Add Features.

l Click Next and select all the latest .NET Framework features includingWCF Services
Features as shown.
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l Select all options underWindows Process Activation Services.

l Click Next and select these role services:

o Common HTTP Features: All except HTTP Redirection andWebDAV Publishing.

o HTTP Logging
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l Performance: Static Content Compression

o Security: Request Filtering

o ASP.NET

o ISAPI Extensions

o ISAPI Filters

o Management Tools: IIS Management Console

l Click Next to install the IIS Feature.

Application Server Requirements and
Considerations
Before installing the application server, perform these tasks and review these guidelines:
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l Determine the quality of the application server.

l AllowWindows to manage the page file, which may mean moving the page file to a

dedicated disk drive on the machine to accommodate growth.

l Ensure you meet the requirements for the Windows OS version that is automatically

installed with updates.

l Install the .NET.

l Disable any Anti-Virus service. This can be re-activated after installation and set to exclude

the installation directory.

l Discuss and plan for Application Server clustering. Do you know:

o Howmany General and Staging Application Servers will be deployed?

o Howmany Consolidation Application Servers will be deployed?

l Discuss and plan for Application Server types such as the following:

o General request Application Servers such as reporting, user navigation, and

workflow.

o Dedicated Data Load (Stage) Application Servers

o Dedicated Consolidation Application Servers

o Combination Application Servers (Data Management)

l Discuss and plan the sizing of each Application Server and you are aware of the CPU and

memory requirements.

l Ensure there is enough space on the temp drive for swapping or a temporary file I/O.

l Know which level of authentication you use such as Basic, Secure, SSL, or FastBind.

l Have the information in this string used to connect to your user directory:
CN=UserDirectoryName,DC=myCompany,DC=com
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l For the database server connection:

o Ensure that Application Servers can connect to Database Server.

o Have the information below required to connect the Application Server to the

Database.

Server:  Data Source=hostname\MSSQLServerDatabaseServerName

;Initial Catalog=OneStream_Framework;username=<OneStream

SQLAuthID>;password=???;Max Pool Size=3000;Connect Timeout=60

l Enable Network Discovery so My Company Name, LLCservers can communicate.

l Download the My Company Name, LLC Software installation package from OneStream

Solution Exchange and put it on the desktop or a folder on each server.

l Install and configure the following components for IIS:
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l Enable Application Initialization role on the Application Servers. 

l Install and enable Windows Process Activation Service (WAS) andWCF Services.
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Database Server Requirements and
Considerations

l Windows OS version installed with all updates.

l Proper version of 64-bit Microsoft SQL Server installed with all updates applied. SQL

Server Enterprise Edition or versions beyond SQL Server Standard 2017 are

recommended for larger, more complicated deployments due to support for table

partitioning.

o Required Components:

n Database Engine

n Management Tools

l High Performance Power Plan has been enabled.

l Verify that the Microsoft SQL Server Database Server has the recommended amount of

free disk space available and room to grow overtime.

l Update the SQL Server Database Transaction Log to grow by file size and not by

percentage.   OneStream recommends setting the growth to grow in 100 MB Increments.

l To enhance performance over time in the Application Databases, OneStream recommends

re-indexing the Application Databases periodically.

l Sizing is based on Customer Data Center Specs for CPU and Memory.

l Authentication and Rights
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o Windows Integrated vs. SQL Server Native:

n Use Native SQL Server Service Account instead of a Windows Integrated

Account for the database to ensure fast connection and reduce network traffic

for our hundreds of connections to the database.

n If using Windows Integrated Security for SQL, the service account used in IIS

will be the Database Account.

o The OneStream Database account needs admin rights to the Master database in

SQL Server in order for the administrator to be able to create new databases via the

OneStream Database Configuration Utility.

o The OneStream Database account should be given full user rights to Public and

Sysadmin under Roles in SQL server.

l Backup / Recovery

o All critical information is stored in the Framework and Application databases.

o Verify that the SQL Server Database for the OneStream Framework and Applications

are backed up per company backup policy.  OneStream recommends a minimum of

daily backups for the Application and Framework Databases.  This can be handled by

creating a SQL Server Maintenance Plan using the NewMaintenance Plan wizard in

SQL Server Management Studio. It is recommended to also backup Framework and

Application databases used for development and test purposes, especially during

initial build-out.

o Verify that the SQL Server Database Transaction Logs are backed up on a regular

basis in conjunction with the databases to avoid the Transaction Log growing to a full

state.
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Security Considerations
l Create IIS service accounts before installation.

o Can be separate accounts for Web and Application servers.

o The service account used to run the OneStreamWeb Server IIS Web Application

Pool requires file share privileges and the following Windows group access: IIS_

IUSRS

o The service account used to run the OneStream Application Server IIS Application

Pool requires file share privileges and the following Windows group access: IIS_

IUSRS, Performance Log Users, Performance Monitor Users.

o The service account used to run the OneStreamManagement Service IIS Application

Pool requires administrator privileges on the Application Server (OneStream

recommends using “LocalSystem”).

File Share Considerations
We suggest that you follow these best practices:

l Create a folder called OneStream on the network that is accessible and shared by each

OneStream server.

l Give the following Read & Execute permissions to the OneStream folders:

o Service Account running the OneStreamWeb Server IIS Web Application Pool

o Service Account running the OneStream Application Server IIS Application Pool.

l Create a folder called FileShare under the OneStream folder. Your OneStream IIS service

account (“NETWORK SERVICE”) must have full rights to this folder.
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l Create a folder under OneStream called Config where you can save and share the Web

and Application Server configuration files.

l Give the following Read/Write permissions to the OneStream Configuration folder:

o Service Account running the OneStreamWeb Server IIS Web Application Pool

o Service Account running the OneStream Application Server IIS Application Pool

l Ensure that applications servers have the File Share for application server workspace

(Logs, File Upload / Down Load).

l Ensure that each Web and Application Server can connect to the File Share.

l Regularly back up the OneStream Application Server andWeb Server Configuration Files

(such as XFAppServerConfig.xml and XFWebServerConfig.xml).

Firewall Considerations
l Web server requires port 50001 to be open as the web URL is accessed on port 50001.

l Application server uses standard web port, which is 50002 by default.

Virtualization Considerations
For Database Servers, Application Servers andWeb Servers:

l Use dedicated VM hosts.

l Sharing or over committing CPU’s with other virtual guests is not supported. If you over-

commit, performance impacts during processes like data load and consolidations may

occur.

l Directly assign dedicated, logical CPU’s to each OneStream VM guest.
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l Dynamic Memory Management by the VM Host is not recommended. Because RAM usage

increases quickly, VM guests without committed RAM immediately available may

experience performance impacts.

l Ensure you update to the latest Windows Server patch level.

Anti-Virus Considerations
Verify that:

l IIS is being excluded by any antivirus programs installed on OneStream Servers.

l The OneStream installation directory (C:\Program Files\OneStream Software\...) is being

excluded from any virus program live active scanning.
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About Installation and
Configuration
Existing customers should refer to the Upgrade Guide for information about installing the latest

release.

OneStream Component Technology

Client
Web

OneStreamMobile

Microsoft Office

OneStream Excel Add-in (optional)

Windows Client

OneStreamWindows App (including Spreadsheet and Text Editor features)

Administration

OneStream Server Configuration Utility for initial product configuration

OneStream Database Configuration Utility for initial product configuration

Installation and Configuration Guide 19

About Installation and Configuration



Web Server
l Microsoft Internet Information Services (IIS), Windows Process Activation Service (WAS)

and .NET using Windows Communication Foundation (WCF)

l OneStreamWeb Server software installation

Application Server
l Microsoft Internet Information Services (IIS), Windows Process Activation Service (WAS)

and .NET using Windows Communication Foundation (WCF)

l OneStream Application Server software installation.

Database Server
l Microsoft SQL Server

NOTE: Use Table Partitioning (requires SQL Server version that supports Table
Partitioning, such as Enterprise, Azure or SQL Standard version 2017 or higher)

l Transaction logs and data at a minimum should be stored on separate drives to spread I/O

across drives. For more advanced configurations and improved throughput, create

additional File Groups to spread I/O across devices.

Supported Authentication Providers

Customers in a self-hosted environment can configure an environment to use native

authentication, one external identity provider, or both native authentication and one external

identity provider.

The following external identity providers are supported:
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l Microsoft Active Directory (MSAD)

l Lightweight Directory Access Protocol (LDAP)

l Three OpenID Connect (OIDC) identity providers:

o Azure Active Directory (Azure AD [Microsoft Entra ID])

o Okta

o PingFederate

l SAML 2.0 identity providers (for example, Okta, PingFederate, Active Directory Federation

Services [ADFS], and Salesforce)

Customers in a OneStream-hosted environment can use OneStream IdentityServer for

authentication. OneStream IdentityServer supports combinations of most OIDC compliant and

SAML compliant external identity providers (IdPs) or native authentication coupled with external

IdPs. This enhances user authentication by supporting multiple providers in one environment.

See the Identity and Access Management Guidefor information about authentication with

OneStream IdentityServer.

Application Folder Permissions

User logs are stored in the My Company Name, LLC application folder directory, which also acts

as the Application Server’s workspace. Ensure that the Application Server identity specified in

Microsoft IIS has full access to this folder structure. 

About the Installation Packages
You install and deploy My Company Name, LLC using separate installation packages that contain

different components.  One of these packages contains the primary server components, which

also includes the web application. 
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The other packages contain supplemental client applications used for report design and Microsoft

Excel based analysis.

Installation Package Content

The lists below identify the contents of the installation packages. Each system component is

described in a later section.  All software can be downloaded from the Solution Exchange.

OneStream Servers Installation Package
l Application Server

l Web Server

l Server Configuration Utility

l Database Configuration Utility

l Upgrade Assistant Utility

OneStream Windows App Client Installation Package

OneStreamWindows App (optional installation package as an alternative to ClickOnce

deployment)

OneStream Excel Add-In Client Installation Package

OneStream Excel Add-In

Desktop Application Side-by-Side Installer
You can install the OneStream Desktop application in a side-by-side manner.
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Use the EXE installer to manually install the desktop application on your own computer, or if more

than one version of the desktop application needs to be installed on the same system. You do not

need to be a local administrator to perform a per-user installation, but you must be a local

administrator to perform per-machine installations.

Prerequisites

To install the desktop application, you must have the OneStream Desktop EXE installer file. This

file is located on the OneStream Solution Exchange where each of the platform installer packages

are located.

NOTE: Only administrators with access to the OneStream Solution Exchange can

download the package and distribute to their users.

To download the desktop application package:

1. Log into the OneStream Solution Exchange.

2. Go to Platform.

3. Select a platform version.

4. Click Download for either the Client Software or the On-Premise Full Package.

5. Unzip the files to the desired location.

Hardware and Software Requirements

Hardware and Software Requirements

Supported Operating Systems l Windows 10

l Windows 11
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Hardware and Software Requirements

Web Browser l Chrome or Microsoft Edge (needed only if

deploying OneStream Desktop to end-

users through the web)

Recommended Hardware l Exceed the minimum requirements for

Operating System, and browser.

l 64-bit Architecture

l 8 GB RAM or higher

Required Software l Microsoft .NET 8.0

l Microsoft EdgeWebView2 Runtime

Control (for features that embed external

web content inside the OneStream

Desktop application) *included with

Windows 11+ and Office 2019. Install

separately if using older Windows and

Office versions.

Recommended Software l 64-bit Windows OS

l 64-bit Microsoft Office version 2019 or

higher (for optional Excel Add-in)

Single Instance Installation

To install a single instance of the OneStream Desktop application:
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1. Double-click theOneStream Desktop EXE installer file to launch the wizard, then click

Next.

2. Accept the terms of the license agreement, and then click Next.

3. Change the folder path if needed, and then click Next.

4. Click Install.

You can now log in and use the application.

Multiple Instance Installation

The most common scenario for needing more than one version of OneStream Desktop installed

on the same computer is that your company has setup a test environment with a newer version in

order to perform testing prior to upgrading production servers. To test the new version and

maintain access to the current version, you might need to install an additional instance of the

Desktop application on your computer.

You can install up to eight instances of the desktop application on a single computer. Each

installation instance has a specific named instance embedded in the installer: 0, I2, I3, I4, I5, I6,

I7, I8.

Each instance also has a corresponding name in the installation folder and shortcut. The default

instance is named 0 and does not have a corresponding change to the installation folder or

shortcut. For example, I2 has a shortcut name of OneStream Desktop (2).

NOTE: More than one user can have the same named instance.

NOTE:With a per machine installation, you must use a named instance that is unique

across all users on a machine. It is possible that all eight instances may already be

claimed, in which case the installation attempt fails.

To install additional desktop application instances:
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1. Double-click the OneStream Desktop EXE installer file to launch the wizard, and then click

Next.

2. Select one of the following:

l Install a new side side by side instance for just me: installs the application for
the current user.

l Install a new side side by side instance for all users: installs the application for
all users on the computer.

3. NOTE: You must be a local administrator to see both options. Otherwise, you can
only install a single instance.

4. Click Next.

5. Click Next to begin the installation of the new instance. The instance number is indicated in

the title.

6. Accept the terms of the license agreement, then click Next.

7. Change the folder path if needed, then click Next.

8. Click Install.

9. Click Finish to complete the installation.

You can now log in and use the application.

Configuring System Components
The following sections describe how to configure OneStream to run in a specific network

infrastructure.  The topics are presented in a logical order that ensures the prerequisites of each

step have been accomplished.
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1. OneStream’s Configuration Files and Tools

2. Creating the Application Server File Share Root Folder

3. Creating Service Accounts and Permissions

4. Creating Database Connections and Schemas

5. Configuring Application Servers

6. Configuring Web Servers

OneStream’s Configuration Files and Tools

OneStream utilizes three types of XML files to store its configuration information.  Two of the

configuration files are OneStream specific configuration files (XFWebServerConfig.xml &

XFAppServerConfig.xml) and one of the files is a generic Microsoft ASP.net configuration file

(Web.Config).  

The generic Web.Config file is optionally used to store an alternate path to the OneStream

specific configuration files.  For example, if multiple web servers want to share a common

XFWebServerConfig.xml file, the common path should be set in the Web.config file of the

OneStream web site on each web server.  The same process applies to application servers that

need to share a common XFAppServerConfig.xml file.
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XFWebServerConfig.xml

This file is a proprietary OneStream xml file that contains configuration information specific to

OneStream web servers.  It should also be noted, that the web server configuration file defines the

application server pool that is used by one or more web servers.  This file can be accessed and

maintained using the Server Configuration Tool.

File Contents

l Specifies application server pool

l Defines application server usage

Stage

Performs data loading and transformation services only
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Consolidation

Performs consolidations and calculation services only

General

Performs all services

Data Management

Performs data-related functions that can be very hardware-intensive. 

Default Location

During the web server installation, the OneStream server installation package creates an empty

version of the XFWebServerConfig.xml file in the App Data folder in the virtual directory created

for the OneStream web server application.

Default Web Server XFWebServerConfig.xml Path

C:\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb\App_

Data\XFWebServerConfig.xml

XFAppServerConfig.xml

This file is a proprietary OneStream xml file that contains configuration information specific to

OneStream application servers.  This file can be accessed and maintained using the OneStream

Server Configuration Tool.

File Contents

l Database server connection information (Optionally Encrypted)

l File share directory location

l Application server threshold/limit settings
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l Application server threading model settings

l System culture settings

l Environment settings

l Monitoring settings

l Task Load Balancing settings

l Azure subscription settings

l Azure EDU level settings

l Server Sets settings

Default Location

During the application server installation, an empty version of the XFAppServerConfig.xml file is

created in the App Data folder in the virtual directory created for the OneStream application server

application.

Default Application Server XFAppServerConfig.xml Path

C:\Program Files\OneStream Software\OneStreamAppRoot\OneStreamApp\App_

Data\XFAppServerConfig.xml

Web.Config

This file is a standard Microsoft ASP.Net configuration file that exists on the web and application

server. This file specifies settings that control how a Microsoft ASP.Net web site behaves. 

However, application specific information can be stored in this file to allow products running in an

ASP.Net/IIS web site to store configuration information. 
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File Contents

OneStream optionally uses this file, on both the web and application servers, to store an

alternative folder path for the OneStream specific configuration files.  This setting allows web

and/or application servers to create a shared folder for configuration files that can be used to

share configuration files between servers.  This file can be accessed and maintained using the

Server Configuration Tool.

Default Location

During the web server and Application server installation process, the OneStream server

installation package will create OneStreamWeb or OneStreamApp ASP.net virtual directory.  The

Web.Config file exists at the root of this virtual directory. 

Default web server Web.Config path

C:\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb\Web.Config

Web Server Security Hardening

TheWeb.config file is typically reviewed during server security scans by IT security teams and

auditors.  Numerous security scanning tools may be used during these audits.  OneStream

recommends making the changes identified in Appendix 7: Web.config Hardening Process

Overview for optimal security and consistent scanning results.

[Encrypted Database Connections].xml

OneStream allows for optional separation of duties between application server administrators and

database server administrators.  Database connection information can be protected limiting the

use of the OneStream Database Configuration Utility to database administrators. 
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This utility enables database administrators to create and maintain connections and schemas in

the relational database system and simply provide an xml file containing encrypted database

connection information to application server administrator.  The application server administrator

can simply import the contents of the encrypted database connection xml file into the

XFAppServerConfig.xml file using the OneStream Server Configuration Tool.

Creating the Application Server Share Root Folder

Application servers require a shared folder that they can use as a file system workspace. 

Application servers need this workspace to provide a place for users to upload and download

documents, store batch processing files, and write system logs.  This information is temporary in

nature and not critical to application function.  The application servers rely on its presence, but

from a backup and recovery perspective this information is not critical.  All critical information is

stored in the OneStream relational databases.

This file folder should be created on a file share that all application servers should reference.  The

path to this folder will be referenced during the application server configuration process. 

Creating Service Accounts and Permissions

OneStream uses a minimum of three server processes that require service accounts for system

communication.  The following information defines the required account permissions by server

and serves as a guide to help configure OneStream’s service accounts in accordance with a

company’s network and data center policies. By default, the IIS application pools created for the

OneStream web and application servers run under the NT AUTHORITY\NETWORK SERVICE

account.  For information on creating and managing service accounts see this Microsoft TechNet

article.
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OneStream server components communicate using the Windows Communication Foundation

(WCF).  This makes inter server communications simple and flexible.  Configuring the product to

work within firewall constraints is more straight forward than legacy DCOM based applications. 

Web Server Account

The service account used to run the OneStream web server IIS App Pool requires minimal

privileges.  The default NT AUTHORITY\NETWORK SERVICE has sufficient permissions to run

the OneStream web server.  If you cannot use NT AUTHORITY\NETWORK SERVICE, use a

limited permission domain account, other managed service accounts and virtual accounts such as

IIS AppPool\OneStreamWeb instead. This account should be created in the same domain as that

of the OneStreamWeb Server.

Application Server Account

The service account used to run the OneStream application server IIS App Pool requires

database access privileges and file share privileges.   OneStream recommends that a dedicated

service account be created to run the OneStream application server IIS application pool.  This

dedicated service account should be created in the same domain as that of the OneStream

Application Server. Adding privileges to the default NT AUTHORITY\NETWORK SERVICE

account may create a security risk because other services using this account will also gain these

privileges.

Database Logon Permissions

The account that OneStream uses to access SQL Server should be granted the Public and

Sysadmin privileges.  These privileges are required to allow the OneStream server process to

create and maintain application database schemas.  Each OneStream application is contained in

its own database schema.
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Depending on how SQL Server security has been configured these privileges will either need to

be assigned to the service account being used to run the OneStream application server, (If

database uses Windows integrated security) or to a standalone SQL Server account if (If

database does NOT useWindows integrated security).

Database Access Permission Note

SQL Server privileges may be reduced to a more restrictive level based on the organizations

database security policies.  At a minimum the account used to access SQL Server must be able to

Insert, Update, Delete, Create / Drop tables, and execute a bulk insert via ADO.Net bulk copy

libraries.

OneStream can prevent application databases being created in the product, ensuring control by a

corporate database management team.

Minimum SQL Server Account Permissions

App Databases

DBOwner and Public

Framework

DBOwner and Public

Master

DBOwner and Public

File Share Permissions

The OneStream application server IIS App Pool account must have Full Control privileges to the

application server file share root folder. The application server uses location to create and delete

files and folders for common task such as uploads, downloads, batch processing, and logging.
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Creating Database Connections and Schemas

OneStream uses three database schema types, Framework, Application and State.  The sections

below describe the two schema types in detail and provide instructions on how to use the

OneStream Database Configuration Tool to create connections and schemas.

NOTE:When upgrading, Database Schema updates may need to be implemented as

part of the upgrade. Full Database Backups are required for any databases you will be

updating (Framework and any Application databases).

SQL Database Considerations

To create an Azure ready database, the Use File Groups property must be unchecked when

creating the Application Database Tables.  Doing this will create a log file and a database file and

ensure that Azure can be supported at any time.  This option applies to SQL 2017 and higher.  A

new application database will need to be created to utilize Azure in the future.
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Microsoft does offer a utility to migrate from a classic SQL Enterprise database using File Groups

to a non-File Group. The information can be found here.

Framework Database

Framework can be thought of as the system database.  This database contains system level

information and servers as a controlling database or gateway to accessing application data. 

OneStream always connects to just one Framework database which is specified during the

application server configuration process.  The Framework database maintains the list of

application databases that are associated with the OneStream instance.

The Framework Database contains the following data elements:

l Users

l Groups

l System Roles

l Environment Metrics

l Task Activity Log

l Error Log

l Application Definitions

l System Level Report and Dashboard Definitions

Creating a Framework Database

To create a new Framework database schema, launch the OneStream Database Configuration

Tool on a machine that can connect to the SQL Server instance that will host the database.  Next,

follow the steps listed below:
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1. Select the top item titled Databases in the left tree control.

2. Right-click the node to show the context menu.

3. Select Create New Empty Database from the menu.

4. Use the standard database creation dialog to specify the Database Server Name,

Authentication Method, and the Database Name.

5. Click Advanced and set the Connect Timeout to 60 and the Max Pool Size to 5000.

6. ClickOK.

7. Select the newly created database in the left tree control.

8. Right-click the selected item to show the context menu.

9. Select Create Framework Database Tables from the menu.

Installation and Configuration Guide 37

About Installation and Configuration



10. Choose Use File Groups and/or Use Table Partitioning and click Create Tables. These are
selected by default.

11. Select this database in the list under Databases.

12. Right-click and select Apply OneStream License.

13. Paste your OneStream license key that was sent to your company in this field and click

Save.

14. Restart IIS to accept the license key.

The new Framework database is ready for use.

Application Databases

Application can be thought of as a data content database.  Each OneStream instance can access

many Application databases.  An Application database contains information specific to a set of

Financial Models and the Workflows used to manage the models.  The system can be configured

so that users can create new Application databases in the product or this task can be restricted,

so that a database administrator must use the OneStream Database Configuration Tool to create

new Application database schemas which are then attached to the Framework database.

An Application database contains the following data elements:

l Application Roles

l Cube and Dimension Definitions

l Workflow Definitions

l Data Transformation Definitions

l Data Quality and Certification Definitions

l Staged Data
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l Cube Data

l Certification and Sign-Off Data

Creating an Application Database

Application databases can be created directly in OneStream or by using the OneStream

Database Configuration tool.

First, launch the Database Configuration Tool on a machine that can connect to the SQL Server

instance that will host the database.

Next, follow the steps listed below:

1. Select the top item titled Databases in the left tree control.

2. Right-click the node to show the context menu.

3. Select Create New Empty Database from the menu.

4. Use the standard database creation dialog to specify the Database Server Name,

Authentication Method, and the Database Name.
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5. Select the newly created database in the left tree control.

6. Right-click the selected item to show the context menu.

7. Select Create Application Database Tables from the menu.

8. This launches the following dialog.
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9. Specify the Application Name and Description.

10. Select Use File Groups and/or Use Table Partitioning. These are selected by default.

11. Click the ellipsis to select a pre-configured Time Dimension xml file

If a Time Dimension Definition is not specified, the application database will default to the

Standard Time Dimension Type.  This creates a Monthly Time Dimension and stores the

data by month in the data tables.  All applications created prior to Version 4.1.0 are using

this Time Dimension Type.  Refer to Time Dimensions in the Design and Reference Guide

for more details.

12. Click Create Tables.

13. (Optional) Rename Application: If the new Database Connection is a copy of an existing

OneStream Application database accessed in the same OneStream environment, you

must give this application a new name. Right-click this database and select Rename

Application. Type a unique Application Name. The Application Description field is optional

and leave Create New Application Unique ID as checked. Click Rename.
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State Database

State can be thought of as a temporary database. OneStream uses the State database to store

temporary report state information.  This schema can be deleted and recreated at any point

because the information contained in the database is only relevant to a user’s current session.

Creating a State Database

To create a new State database schema, launch the OneStream Database Configuration Tool on

a machine that can connect to the SQL Server instance that will host the database.  Next, follow

the steps listed below:

1. Select the top item titled Databases in the left tree control.

2. Right-click the node to show the context menu.

3. Select Create New Empty Database option from the menu.

4. Use the standard database creation dialog to specify the Database Server Name,

Authentication Method, and the Database Name.

5. The tables for this database are created on demand by OneStream.

The new State database is ready for use.

Exporting Database Connections

OneStream uses the Database Configuration Tool to manage and create database connections

in isolation from the server configuration process.   Once a database or database connection has

been created in the OneStream Database Configuration Tool, a file can be exported from the tool

containing a list of encrypted database connections.

Each OneStream application server configuration file stores a database connection string

pointing to the host SQL Server.  This connection is then used in combination with Framework and

Application database names to establish connection to databases.
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To make process of assigning a database connection to an application server, the exported

database connection file can be imported into the OneStream Server Configuration Tool.

Managing Data Record Storage

OneStream applications can have a monthly or weekly Time Dimension.  The pre-fixed Time

Dimension Types determine if a particular application is monthly or weekly and the type of

calendar used (e.g., 445, 454, etc.)  A Custom Time Dimension Type allows users to specify the

number of months in a quarter and the number of weeks in a month and can only be applied to

new applications.  All applications created prior to Version 4.1.0 are using the Standard Time

Dimension Type which creates a Monthly Time Dimension and stores the data by month in the

data tables.  Standard monthly applications can be converted into a weekly application by copying

the application’s data into binary data storage. 

The implications of this action are very serious because of the effect this can have on existing

reports, objects using specific time logic and how data is processed going forward.  OneStream

requires an application review before any existing application converts from standard to binary. 

Contact OneStream Support to further discuss this process. 

Configuring Application Servers

Configuring application servers requires that the following be stored in XFAppServerConfig.xml:

l The path to the file share root folder that will serve as a workspace for the application

server. 

l The pool of database server connections, schema names and server connections for the

Framework and State databases.  

All other configuration values can use standard default values.
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Using the Server Configuration Tool

1. Open the OneStream Server Configuration Tool. 

2. Select File > Open Application Server Configuration File and browse to the default
XFAppServerConfig.xml in the application server’s virtual directory.

TIP: Create a central location accessible for all server configurations in which to
house this file. For example, C:\OneStreamShare\Config

3. When the file is open, define the following settings to configure the application server:
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Application Server Configuration Settings
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Remote Editing

Remote Editing allows adjusting Application Server Configuration setting access for

Administrators and advanced IT persona. It is enabled by default but can be adjusted by

Customer Support in the following manners:

l Disable Full Feature by XML/App Config

l Disable sections by XML/App Config

l Disable property changes

l Number of Days to Retain System Config History: Set the number of days to retain the
system config history.

l Can Edit selections: When True, users can make changes to the settings in the application.

When False, modifying settings will no longer be available in the UI.

l Use Edited selections: When True, the user-defined settings apply. When False, the

default settings from the configuration file apply.
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l Can Add Database Server Connections: When True, users can add Custom Database

Server Connections. When False, users are cannot add Custom Database Server

Connections.

OneStream Environment

Define the following settings to customize your environment.

l Environment Name and Color:Enter the name to be displayed (in white) for the
environment.  You can enter up to 150 characters.  Specify a provided environment color or

enter a hex value to display the name on a colored background. For example:
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l Can Use Client Updater:True enables the Client updater to upgrade a user’s version of
Excel Add-In. False disables upgrades to Excel using the Client update. If disabled, users
get a message indicating functionality was disabled by their System Administrator.

l Can Use Administrator User: True activates the generic Administrator user account. 
False disables the Administrator logon. If the other Admin accounts were deleted, set this
to True to support logon.

l Use Detailed Logging: False omits internal error language and information from the error

log.

l Enable Help:Select True to display a help icon that launches the official documentation
set. Select False to not display a help button.

l Enable File Share Uploads:True enables authorized users to upload or edit files or
folders in the File Share using the OneStream File Explorer. When False, users and
Administrators can only browse, and not upload or edit files and folders. Users get a

security error when writing or editing files or folders using API or another method.

Logon Agreement Type and Message:To display a specific message after a user logs on,
selectCustomand enter the message text.

Environment Monitoring

Use Environment Monitoring settings to define the real time update frequency, and the KPIs and

metrics to monitor. These metric categories help you manage and optimize applications and the

application environment:

l Environment

l Application server

l Database server

l Server set
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Use the Environment page to evaluate and monitor the environment, isolate bottlenecks, look at

properties and configuration changes, and scale in/out application servers and database

resources.

This section is used to specify how often metrics are collected and what metric types are

collected:

URL for the Automatic Recycle Service
Used to specify the address of the recycle management service. The protocol for the address

should be set to however the service is deployed (https or http) and the port (default is 50002).

The asterisk will force the service to use the fully qualified domain name of the executing server.

Number of Running Hours Before Automatic Recycle
Default is 24, which means once a day, the server will recycle. Automatic Recycling allows

Application Servers a chance to recycle, which is a recommended practice. These first four

settings control this behavior.
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Start Hour for Automatic Recycle (0 to 24 UTC)
Default is 5, which means 05:00 UTC time. This is the earliest time in a day when a server can

automatically recycle. It is best to set this and the End Hour to be a range of time with the lowest

amount of Application Server activity.

End Hour for Automatic Recycle (0 to 24 UTC)
Default is 7, which means 07:00 UTC time. This is the latest time in a day when a server can

automatically recycle.

Maximum Number of Minutes to Pause Before Automatic Recycle
Default is 30. This means that when it is time to recycle a server automatically, it will first pause

from accepting more server tasks, but allow for existing assigned tasks to complete processing for

30 minutes before recycling. If there are no active tasks for this server, it will recycle when the time

comes.

Active Check Update Interval (seconds)
The system is designed to be pro-active and to check for any internal issues.  This setting

determines how often the system will check for table fragmentation and database deadlocks.

Metric Update Interval (seconds)
The Metrics are collected on a timer using this setting. To minimize database access and to

maximize performance, some metrics are collected on every iteration and some will skip one or

more iteration based on the metric collection iteration count settings that have been assigned to

each metric.  For example, if this property is set to 30 (seconds) and the “Collect Environment

CPUMetrics” is set to “Every2Iterations” then the system will collect metrics every 60 seconds. If

the property is set to “Always” the system will collect at every iteration, “Never” will never collect,

“Once” will only collect upon server initiation. Also, the user can minimize database writes by

using the global settings in the Application Server in the OneStream Server Configuration Utility.

Server Heartbeat Update Interval (seconds)
Used to specify how often each server updates its record that it is alive and responding to user

input.
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Collect Environment CPU Metrics
How often to collect environment CPUmetrics.

Collect Environment Task Metrics
How often to collect environment task metrics (i.e; running tasks, Queued Tasks…).

Collect Environment Login Metrics
How often to collect environment user login metrics.

Collect Server Set CPU Metrics
How often to collect Server Set CPUmetrics.

Collect Server Set Task Metrics
How often to collect Server Set task metrics (i.e; running tasks, Queued Tasks…).

Collect Server Disk Metrics
How often to collect server disk metrics (i.e; Average Disk read/write per sec…).

Collect Server Memory Metrics
How often to collect server memory metrics (i.e; Available mbytes…).

Collect Server Network Card Metrics
How often to collect server network card metrics.

Collect SQL CPU Metrics
How often to collect SQL Server CPUmetrics.

Collect SQL Page Metrics
How often to collect SQL Server Page caching metrics (i.e; Page Life Expectancy…).

Collect SQL Memory Metrics
How often to collect SQL Server CPUmetrics.

Collect SQL Connection Metrics
How often to collect SQL Server connection metrics (i.e; Number of connections…).
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Collect SQL Query Metrics
How often to collect SQL Server Query metrics (i.e; Number of Deletes/Inserts…).

Collect SQL File Metrics
How often to collect SQL Server File growth metrics.

Collect SQL Elastic Pool CPU Metrics - Azure SQL
How often to collect SQL Server Elastic Pool CPUmetrics (i.e; Number of connections…).

Collect SQL Elastic Pool DTU Metrics - Azure SQL
How often to collect SQL Server Elastic Pool DTUmetrics (i.e; Number of connections…).

Collect SQL Elastic Pool Storage Metrics – Azure SQL
How often to collect SQL Server Elastic Pool Storage metrics (i.e; disk storage usage…).

Collect SQL Elastic Pool Workload Metrics - Azure SQL
How often to collect SQL Server Elastic Pool Workload metrics.

SQL Blocking Timeout Interval (Minutes)
Checks the SQL Blocked Items Timestamp. If the Timestamp is greater than “SQL Blocking

Timeout Interval (minutes), ” a warning is logged.

Fragmentation Iteration Count
Default is 600 (minutes). Used for fragmentation check, every 10 hours if this field is set to 600.

This is used to determine how often the database tables are fragmented.

Fragmentation Percent Threshold
Default is 90. Used for fragmentation threshold check in percent.

Detailed Logging
If true, then log whenever we enter and exit the metric collection and the Active System check.

Number Hours to Retain Offline Servers
Default is 1. Remove offline servers from the heartbeat table after certain number of hours.
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Task Load Balancing

Default settings for Task Load Balancing for larger jobs like consolidation and data management.

Application servers utilize queuing and smart load balancing to run that task on the appropriate

application server. Task queueing and smart load balancing will prevent more than one

processor-intensive task from running on the same server at the same time. When an

asynchronous task is started (i.e., a task that uses the progress bar), it can be initialized in a

Queued state before it starts its work in its Running state. The queued state takes very little

application server resources. The algorithm keeps the task in the Queued state until all other

queueable tasks have completed on that application server or until the CPU is low enough to run

the task. There are also settings that can be configured to cause queued tasks to be automatically

run if too much time elapses.

Maximum Queue Processing Interval (seconds)
Default is 10. Used to specify how often the queue will look for new jobs to execute.

Maximum Average CPU Utilization
Default is 70. Used to specify the maximum CPU utilization before a task is queued to a server but

not executed till the CPU drops below that maximum.

Maximum Queue Time (minutes)
Default is 30. Used to specify the max queued time before a job is executed.

Installation and Configuration Guide 53

About Installation and Configuration



Number of Past Metric Readings for Average CPU
Default is 2. Used to specify the number of past metric reading used to calculate the average CPU

utilization.

File Share Root Folder
To set the file share root folder property, type in the path to the file share folder, or copy and paste

the path fromWindows Explorer.

NOTE: File Share Root Folder might have a default directory defined as
C:\OneStream\File Share\.  This directory is not created.  Please define the File Share

Root Folder directory.  Grant the system user NT AUTHORITY\NETWORK SERVICE

full access to this folder.

File Share Batch Harvest Root Folder
Used to define a separate folder path for the Batch Harvest folder.  Azure users who do not have

access to the Azure folder can use this field to identify a folder where they can place their files for

batch harvest. 

NOTE: If you specify a separate path, the default folder will not be used.

Business Rules Assembly Folder
Used by Application Servers to reference the location of DLL files stored in a common Network

Share Folder.

Business Rules Default Access Group
Default is Administrators. The access group for new Business Rules.

Business Rules Default Maintenance Group
Default is Administrators. The maintenance group for new Business Rules.
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User Inactivity Timeout in Minutes
Used to identify the number of minutes a user has before their OneStream session times out while

they are on a page in XF, or in Excel, without taking action.

Task Inactivity Timeout in Minutes
Used to identify the number of minutes a task in user cancelled status, or sitting in the queue

waiting to be processed, has before being timed out.

Specify Log Retention Information
To set the log retention properties in days, type the number of days that the organization wishes to

ensure logs are retained.  If the delete activity or error logs buttons are used in OneStream, the

logs will be cleared with the exception of the current number of days specified.

Log Retry Errors
If an application server has a transient issue trying to access the database, it will retry the

database query. If LogRetryErrors is set to True (the default), an item will be added to the error log

to indicate that a retry was needed. If an implementation is seeing a lot of database retries in the

error log, they should review their database installation to make sure it is operating correctly.

PDF Embedded Fonts to Remove
Embedding fonts in a PDF Report Book significantly increases the size of the PDF file.  Use this

property to specify the fonts to not embed to reduce the size of PDF files and control the resolution

during Report Book PDF generation.  For multiple fonts, use a semicolon separated list.

The default setting is: Arial; Calibri; Segoe UI; Tahoma; Times New Roman; Verdana.

NOTE: This is for Report Books only. 
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Security

The Security section includes settings for Security, External Identity Providers, and Native

Authentication.

Security

Whitelisted Domains: The Whitelisted Domains setting gives you the option to control the URLs

and domains allowed to be referenced. You can update this setting with the following options:

l AllowAll (default): This option will allow all http and https formatted domains.

l DenyAll: This option will deny all URLs and domains. This option is recommended if there
are concerns about the security of platform download features.

l Enter specific domains, URLs, or wildcard matches to accept.

If the Whitelisted Domains field is empty (displays Collection) or displays Default, it will default to

AllowAll. If the OneStream Application Server Configuration file is manually updated to remove

the Whitelisted Domains field, it will default to AllowAll.

IMPORTANT: Regardless of the option selected, only http and https formatted domains
can be referenced. References to non-http and non-https file schemes are not allowed.

To add an option for Whitelisted Domains:
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1. In the Application Server Configuration file, click the ellipsis to the right of Security.

2. In the Security dialog box, click the ellipsis to the right ofWhitelisted Domains.

3. In theWhitelisted Domains dialog box, click the + icon.

4. Update the Domain field with the selected approach:

l Type AllowAll to allow all http and https formatted domains.

l Type DenyAll to deny all URLs and domains.
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l Or, enter an absolute domain, an absolute URL, or a wildcard match using an * (for

example, https://*.onestream.com or https://*.onestream.com/api/*) to allow specific

URLs and domains.

IMPORTANT: If you add specific URLs or domains, only those identified
URLs or domains will be allowed. All others will be denied.

5. Click theOK button.

NOTE: If you are adding specific domains, URLs, or wildcard matches to accept,
follow this process to add as many as needed.

6. Save changes and reset IIS.

To remove an option for Whitelisted Domains:

1. In the Application Server Configuration file, click the ellipsis to the right of Security.

2. In the Security dialog box, click the ellipsis to the right ofWhitelisted Domains.

3. In theWhitelisted Domains dialog box, select the option from the list on the left and click

the - icon.

4. Click theOK button.

5. Save changes and reset IIS.
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External Authentication Providers

You can configure authentication with external identity providers. To configure, click the ellipsis to

the right of External Authentication Providers.

NOTE:When upgrading OneStream from a version prior version, note that the Windows

Section of the external authentication provider may have been enhanced to support SSL

enabled MSAD. As part of this change, any prior MSAD authentication providers will

need to be transferred to the updated Windows Section of the external authentication

provider entry. The Domain Name should be verified and entered in the Name of

Account Store field and the appropriate binding options and type of account store should

be specified.

In the External Authentication Providers dialog box, click +.

Create a name for the provider and complete the information based on the installation. The final

configuration is then performed in the security section of the individual user profile. See

Authentication.

NOTE: Comma-separated values (group names) can be entered in the Security Group
Names field.  A user must belong to any of the groups listed before OneStream will

authenticate the user with MSAD. Security groups are also still needed in OneStream.

NOTE:Windows Authentication mechanism has been enhanced to support SSL

enabled MSAD. See below for an example of default configuration values.
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Name of Account Store: The domain or server name for domain context types, the machine
name for machine context types, or the name of the server and port hosting

the ApplicationDirectory instance.

Name of Account Store Container:The container on the store to use as the root of the context.
All queries are performed under this root.

Server Binding Options: A combination of one or more ContextOptions values specifying the

options used to bind to the server. Use one of the options from the drop-down menu or, if

UseCombinedContextOptions is specified, enter multiple comma-separated values in the

Combined Multiple Server Binding Options field. For a detailed description of these options, see

Appendix: Context Option Values To UseWith Active Directory + SSL.

Type of Account Store: Specifies the type of store to which the principal (user) belongs.
Possible values are ApplicationDirectory (represents the AD LDS store), Domain (represents AD

DS store), and Machine (represents SAM store). Defaults value is Domain.
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NOTE: OneStream’s implementation of MSAD and LDAP authentication allows for the

use of a single username and password when prompted to log into OneStream.

Native Authentication

See Authentication for information about setting up native authentication.

Control the standards for creating and updating passwords by defining the minimum and

maximum character length, variety of characters, expiration dates, and maximum invalid logon

attempts. If a positive number is provided for the Maximum Invalid Logon Attempts field and a

user exceeds the number, their account will be disabled. After an administrator re-enables their

account, the user will be required to change their password. 

NOTE: Similarly, the administrator’s account can also be disabled if the maximum
invalid logon attempts value is exceeded. 
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Azure Configurations (Azure-only or if Elastic Pool Being
Used)

Azure Subscription Settings

The Azure subscription settings must be filled in, as they are used for login and retrieve Azure

settings and data. In version 5.0 this is used to retrieve Elastic Pool metrics.

Cache
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Reserved Memory (GB)
The reserve memory must be large enough to hold all non-analytic cached items, such as

metadata, workflow, stage processing. If total systemmemory usage is consistently high and gets

above 90%, reserve memory should be increased because non-analytic memory consumption is

larger than the reserve and virtual memory pressure grow. This property is a string that contains a

number for GB or a percentage of total RAM. If a percentage is specified, and after it is converted,

the minimum is 4GB and the maximum is 256 GB. If a number is specified, the minimum is 0GB

and the maximum is 256 GB.

Databases
Specify Database Information For the application server to connect to a database server, define

one or more database connections to which the server can connect. Database connections can

be imported from an xml file containing encrypted connection strings created using OneStream

Database Configuration Tool or connection strings can be created directly in the OneStream

Server Configuration Tool.

Importing Encrypted Database Connections
To import connections produced by the OneStream Database Configuration Tool, open the

OneStream Server Configuration Tool and click the Tools menu and select the Import Database

Server Connections option. Now browse for the encrypted database connections xml file

produced using the OneStream Database Configuration Tool. After the connections have been

imported, be sure to name each connection so that it can be referenced in the configuration

process.

Database Server Connection Settings
Changes need to be made to the Database Server Connections for users to create and change

data in additional database tables. These settings are used by some of the OneStream Solutions

such as Specialty Planning and Reconciliation Control Manager.
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Select the Database Server Connections field and click the ellipsis to launch these settings.

Azure Database Connection Settings

Azure Elastic Pool Max DTU Setting
This is a fail-safe setting that the user can’t set the DTU setting above this point.

Azure Elastic Pool Min DTU Setting
This is a fail-safe setting that the user can’t set the DTU setting below this point.

Elastic Pool Name
The name of the elastic pool used with this database connection.

Azure Resource Group
The resource group name that the elastic pool is in.

Azure Service Level Objective
The service level used.  This setting is used to create application on Azure.

Azure SQL Edition
The Azure SQL Server edition used.
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Azure SQL Scaling Type
This feature will be available in a future release.

Manual, Business Rule, and ManualAndBusinessRule.  The type of scaling that is used to scale

in/out the SQL Server eDTUs.

Azure SQL Server Name
The name of the SQL Server database.  This setting is used to create application on Azure.

Azure SQL Storage Max Size
This is used to specify the database storage size when creating a database on Azure.

Azure SQL System Business Rule Name
This feature will be available in a future release.

If SQL Scaling Type is set to Business Rule, this setting must be set to a Business Rule that is

used to Scale Out and Scale In.  The Environment metrics and the database metrics are passed

to this rule to properly determine the eDTU scaling. See System Extender Business Rules in the

Design and Reference Guide.
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Access Group for Ancillary Tables
This should be set to a group who will edit records.

Maintenance Group for Ancillary Tables
This should be set to a group who will create the tables.

Other settings highlighted need to be set to True in order to execute table creation via the

OneStream Solution Exchange dashboards.

Defining Database Connections Manually
Database server connections are defined and named using the Database Server Connection

Collection Editor which is opened by clicking the button in the right column of the Database Server

Connections property.
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The Database Server Connection Collection Editor allows database connections to be added or

removed and the creation of meaningful names for the connections.   The name of the connection

is important because it acts as an abstraction layer to which the application server can interact. 

This allows the database administrator to change the connection string for a name database

server connection without affecting the application server or any other component that may rely

on the named connection. 

In addition, name database connections can help organize development, test, and production

environments because relevant names can be assigned to a database connection based on its

environment.   Named connections appear as a list in the OneStream user interface during the

process of creating new applications.  This feature allows OneStream administrators to simply

pick database connections to use for the new application database.  If the Allow Database

Creation Via UI property in the Application Server Configuration is set to False, this means none

of the attached database servers are setup to allow new application creation which will then

disable the Create New Application Database icon.
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Enabling Remote Editing

Enable your database server connections for remote editing from the configuration file.

l Enable Remote Editing: When True, users can make changes to the settings in the

application. When False, modifying Enable Remote Editing settings will no longer be

available in the UI.

l Use Remote Editing Settings: When True, the user-defined settings apply. When False,

the default settings from the configuration file apply.
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Specify Database Connections and Schemas
Once database connections have been imported or defined manually, they can be used in

conjunction with the schema name to define full connection information for the Framework and

State databases.

Define Framework Database Connection
In order to define the Framework database connection, specify the database server connection

name that contains the Framework database, and then specify the name of the Framework

database schema on the server.

Server Sets

NOTE: A server should only be in one server set.

A server set should contain all servers, which will perform that set’s unique combination of

behaviours.

Used to create Server Sets for server grouping.
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Azure - This feature will be available in a future release.

These settings apply only when running in OneStream Cloud.

Azure Resource Group Name
This feature will be available in a future release.

The Azure resource group name for the Server Set.

Azure Scale Set Name
This feature will be available in a future release.

The Azure scale set name in the resource group.

Can Stop or Start Servers
This feature will be available in a future release.

If true, then the user can stop and start the server from the Environment page.
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Maximum Capacity
This feature will be available in a future release.

A failsafe setting specifying the maximum number of servers that can be scaled up to.

Minimum Capacity
This feature will be available in a future release.

A failsafe setting specifying the minimum number of servers that can be scaled down to.

Scaling Type
This feature will be available in a future release.

Specify whether this Scale Set is scaling at all or doing so manually, using a Business Rule,

Automatically or both manually and a Business Rule. If Business Rule-based, see next property.

System Business Rule Name
This feature will be available in a future release.

If Scale Set is scaling using a Business Rule, then the Business Rule name needs to be specified.

See System Extender Business Rules in the Design and Reference Guide.

Behaviors

Process Queued Consolidation Tasks
If set to true, then this server can process Consolidation tasks.

Process Queued Data Management Tasks
If set to true, then this server can process Data Management tasks.

Process Queued Stage Tasks
If set to true, then this server can process Stage tasks.

Queued Tasks Require Named Application Server
If set to True, this server will only run tasks that are assigned to it. If set to False, server names
will be ignored so jobs will run on an available server.
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NOTE: This behavior only applies to customers in an on-premises environment with a
server name that is known.

General

Name
Server Set name.

Server Name for Standard Server Sets (Supports *? Wildcards)
Specify the Server names if we are using the Standard Server Set Provider type. See next

property.

Sever Set Provider
Specify whether we are using the “Standard”, “Azure”, or “External” provider type.

Processing

Can Change Queueing Options on Servers
Specify whether the queueing options of a specific server can be changed. If the Value is set to

True, it will allow the administrator to change the queueing behavior of a specific server as it

relates to queueing Stage, Consolidation and Data Management tasks.

Can Pause or Resume Servers
If set to true, then the user can pause and/or resume the server from the Environment page.

Can Recycle App Pool on Severs
If set to true, then the user can recycle the app pool from the Environment page via the Reset IIS

button.
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Integration Settings

These properties enable the modification of the Stage Summary Rows and Stage Load Values.

These settings allow optimization and tuning of the Workflow Import behavior related to the

summarization of records for the StageSummaryTargetData table to be performed on the

application or database server. The summarization method of using the Application Server is

determined by the calculated Summarized Row Ratio (SRR). The Summarized Row Ratio

configuration property sets the threshold for the calculated SSR. Having less than 100k records,

or high summarization, which is a calculated SRR less than the property, or default .65, will utilize

the Application server. All Append, use of multiple Source ID's or a calculated SRR greater than

the property value, or default .65, will use the Database server. The calculated SSR is done on

subsequent Stage Import loads and stored in the Framework MetricsValue table.

Minimum Data Record Count
The default is 100,000. This determines the minimum data record count to trigger Database

Server Processing. This threshold determines the use of the Application or Database server.

Summarized Row Ratio
The default is Greater than .65. This is the ratio of Total Summarized Rows/Total Number of Rows

Imported. Subsequent loads generate a new Summarized Row Ratio. This threshold is used to

evaluate the calculated SSR for the Application or Database servers.
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Always Use Database Server
The default is “False”. When set to “True”, the feature that allows for Application Server

Processing in Stage Import and Load during the Workflow processing is turned off. This disables

the summarization of the Application server, Minimum Data Record Count and Summarized Row

Ratio no longer apply.

Task Activity

Task Activity is used to capture log information for Books and Quick Views to analyze data

analysis performance.

Log Books
When set to True (default), a log is created in Task Manager when the items are included as Task

Activity steps for that specific book. The intention of this feature is to verify entries in the Task

Activity grid and the settings in the configuration file work as expected.

Log Cube Views
When set to True, a log is created in Task Manager when a Cube View is opened, a report is run

or an export to Excel is completed in the data explorer. The intention of this feature is to analyze

data analysis performance.

Log Quick Views
When set to True, a log is created in task manager when a new Quick View is created or when

rows/columns are shifted/moved around. The intention of this feature is to analyze data analysis

performance.
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IMPORTANT: Quick Views exceeding 5000 cells will be logged in Task Activity even if
Log Quick Views setting is set to False, enabling you to cancel the task if needed.

Threshold for Logging Get Data Cells (count)
This logs the calls to GetDataCells and GetDataCellsUsingScript.  It includes context information

such as the Excel file name or the Cube View name.  It only creates logs if the number of Data

Cells being requested is equal to or greater than the value provided in this field.

Zip File Protection

Maximum Zip Archive Entry Threshold: Set the maximum number of files that can be included

in a zip file. The default value is 1,000.

Maximum Zip File Extraction Size (MB): Set the maximum extraction size in MB (sum of all

files) allowed in a zipped file. The default is 2,000.

Maximum Zip File Compression Ratio (N:1): Set the ratio between the uncompressed and
compressed size (zip file size divided by packed size). The default is 800.

Sharing One Configuration File for All Application Servers

All OneStream application servers can share a single configuration file if desired.  This makes

controlling server behavior more centralized and reduces configuration time. 
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Sharing a configuration file is a simple process.  Follow the standard application server

configuration process on one server and then copy the configuration file to a file share that all

application servers can read.  This shared folder will then need to be referenced by each

application server in its ASP.Net Web.Config file.

Setting a Reference for the Configuration File Share Folder

Open the OneStream Server Configuration Tool on each application server, click the File menu,

and select Open ASP.Net Configuration File.  Next, open to the Web.Config for the application

server.  This file is located in application server’s virtual directory root folder (C:\Program

Files\OneStream Software\OneStreamAppRoot\OneStreamApp\Web.Config). 

Once the file is open, set the Configuration Folder property value equal to the configuration file

share folder, save the configuration file and restart IIS.

Configuring Web Servers

Configuring OneStream web servers requires one or more application servers to be defined for

the web to connect to it.  The web server configuration file not only defines the URL connection

information required for a web server to communicate with an application server, but it also

defines the processing capabilities of the application server. 

Using the Server Configuration Tool

1. To begin the application server configuration process, open the OneStream Server

Configuration Tool. 

2. Go to File > Open Web Server Configuration File. 

3. Browse for the default XFWebServerConfig.xml located in web server’s virtual directory

(C:\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb\App_
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Data\XFWebServerConfig.xml). 

4. Once it is open, begin the configuration process.

SSO Logging

Logging is used to collect data to support troubleshooting issues. The following image shows the

default logging settings.

To update the logging settings, you must perform these steps for each service you want to log on

each server that is running.

1. Go to the file location:

l <installdrive>Program Files >OneStream Software >OneStreamWebRoot >
OneStreamWeb

l <installdrive>Program Files >OneStream Software >OneStreamAppRoot >
OneStreamApp

l <installdrive>Program Files >OneStream Software >OneStreamWebApiRoot
>OneStreamWebApi

NOTE: The location of the logs directory may vary depending on deployment and
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logging configuration, so log files may reside on each server.

2. Right-click the appsettings.json file and select the preferred text file editor.

You can update the following settings:

l Default: This value identifies the type of entries to be captured in the logs. It can be updated
with the following values:

o Verbose: The noisiest level, rarely enabled for a production application.

o Debug: Used for internal system events that are not necessarily observable from the

outside. It is useful when determining how something happened.

o Information: Describes things happening in the system that correspond to its

responsibilities and function. Generally, these are observable actions the system can

perform.

o Warning: Used when service is degraded, endangered, or may be behaving outside
of its expected parameters.

o Error: Used when functionality is unavailable or expectations are broken.

o Fatal: The most critical level. Fatal events demand immediate attention.

l Override: Logging can be customized as needed by adding override levels (for example,
SsoLogonService, Rsk.Saml, and Microsoft.AspNetCore.Authentication).

There are some values that are not included by default, but you can add them.

l Name: This value specifies which method should be used to write the audit data. Enter File
to write the audit data to a file in the specified location indicated by the value entered in the

path.

l path: This value specifies where the audit data is written (for example, C:\Logs).
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l rollingInterval: This value indicates the time period in which the logs should be generated.
All audit data will be captured and saved on a time interval as indicated in this field. You can

update it with the following values: Year,Month, Day, Hour, orMinute.

The following image shows the logging settings updated to include the Name, path, and

rollingInterval values.

Creating Application Server Definitions

Application server connections are defined and named using the Web Server App Server

Collection Editor which is opened by clicking the button in the right column of the Application

Servers property. 
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Application Server Properties

Pause or Resume setting will determine if the Pause and Resume button will be displayed in the

Web To App Connections. If set to True the buttons will be displayed and will allow the user to

pause and then resume a specific connection to an application server. If this option is set to False

the buttons will not be displayed.

TheWeb Server App Server Collection Editor allows application server definitions to be added or

removed and the creation of meaningful names for each server, the processing capabilities of the

server, and the WCF Address (URL of the application server).

Application Server Processing Capabilities

Application servers can be designated to perform specific processing tasks or all processing

tasks.

Consolidation
Consolidation application servers are limited to performing consolidation related

functions which can be very hardware-intensive. 

Data Management application servers are limited to performing data related

functions which can be very hardware-intensive. 
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Data

Management

General

Access

General Access application servers can perform all processing tasks, including

consolidations and stage loads.

Stage Load
Stage Load application servers are limited to performing Staging (Load &

Transform) related functions which can be very hardware-intensive. 

Application Server WCF Address

OneStream application servers uses the Windows Communication Foundation (WCF) for inter

server communications.  In order for a web server to locate and communicate with an application

server, specify the application server’s URL. 

OneStream uses standard ports for its web and application servers.  Sample URL’s with the

standard ports numbers are listed in the table below.

Web Server Sample URL: http://<Servername>:50001/OneStreamWeb/OneStreamXF.aspx

Application Sever Sample

URL:
http://<Servername>:50002/OneStreamApp

Sharing One Configuration File for All Web Servers

All OneStream web servers can share a single configuration file if desired.  This makes controlling

server behavior more centralized and reduces configuration time. 
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Sharing a configuration file is a simple process.  Follow the standard web server configuration

process on one server and then copy the configuration file to a file share that all web servers can

read.  This shared folder will then need to be referenced by each web server in its ASP.Net

Web.Config file.

Setting a Reference for the Configuration File Share Folder

Open the OneStream Server Configuration Tool on each application server, click the File menu,

and select Open ASP.Net Configuration File.  Next, open to the Web.Config for the web server. 

This file is located in web server’s virtual directory root folder (C:\Program Files\OneStream

Software\OneStreamWebRoot\OneStreamWeb\Web.Config). Once the file is open, set the

Configuration Folder property value equal to the configuration file share folder, save the

configuration file and restart IIS.

Application Validation

After the installation and configuration is complete, test the application. Once the login page

loads, make sure it paints correctly. For the very first login use the following username and

password:

User Name Administrator

Password OneStream

NOTE: This will require a password reset after the first login.

Configuring Secure Sockets Layer (SSL)
The following steps outline how to configure a OneStreamWeb Server for Secure Sockets Layer

(SSL) encryption, so https is used instead of http. 
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Pre-Configuration

Configure the application servers and web servers for normal unencrypted http access.

Create a Server Certificate
1. Start IIS Manager and select the desired server in the left-hand Connections tree. Then

double-click the Server Certificates icon.

2. Select the appropriate option in the right-hand pane to create a test certificate, or to request

an official certificate from an authority.

3. To create a test certificate, select Create Self-Signed Certificate.  Then specify a name
and select the Personal certificate store. 

4. ClickOK.

Create Web Server HTTPS Binding

NOTE: Configure web server(s), not application server(s) for SSL. 

Configuring the web servers will cause the internet traffic between end-users and the web server

to be encrypted.  Since the web servers and application servers are physically co-located in the

same server room, it is not usually necessary to pay the performance penalty for encrypting that

link.

1. In IIS, select theOneStream Web Server Site, right-click, and select Edit Bindings. By
default, the web server will initially have only one binding (for http), add a binding for https.

2. In the Site Bindings dialog, select Add.  Then select https, All Unassigned, and use the
default SSL port (443) if appropriate.

3. Leave Hostname empty and leave Require server name indication unchecked.
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4. In the SSL certificate combo box, select the certificate that was created above.

5. ClickOK.

Configuring SSL On the Application Server Tier

Configuring SSL on the Application Server Tier in the environment will require the use of a local

account for the IIS Application Pools (OneStreamAppAppPool) rather than a domain level service

account.  This can be achieved using either:

1. A Microsoft Azure Storage Account in a Azure deployment of OneStream.

Configuring the application servers will cause the internet traffic between the web server

and application server to be encrypted.

2. In IIS, select the Application Pools node and right-click onOneStreamAppAppPool.
Click Advanced Settings.

3. Click on the Identity field and click the… icon to update the identify for the application pool.

4. Choose the Custom Account radio button and click Set.

5. Enter the local account username and corresponding password and confirm the password

and clickOK to save andOK to confirm.

6. ClickOK to close the application pool Advanced Settings Dialog.

7. Recycle IIS for the changes to take effect.

Perform this process on each OneStream Application Server in the environment.
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Test SSL Address
1. Restart IIS. 

2. Open a browser and navigate to the OneStream site using https instead of http.

For example, the URL for the encrypted (SSL) connection could be:

https://[SeverName]:[SSLPortNumber]/OneStreamWeb/OneStreamXF.aspx

3. If a test certificate was used instead of an officially signed certificate, the browser displays a

warning indicating a problem with the security certificate. Click Continue to this website.

4. Log onto OneStream to ensure that the client can communicate with the web server.

Disable Unencrypted HTTP Access

Even if an SSL connection is fully configured, users can access the web server using the URL for

the unencrypted HTTP connection. Disable that access as follows to ensure users only use SSL

(HTTPS).

1. In IIS, select theOneStream Web Server Site and then double-click the SSL Settings.

2. Select Require SSL and clickOK.

3. Restart IIS.

4. Test both URLs in a browser to confirm that:

l The HTTPS URL works.

l The HTTP URL displays an error.
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Authentication
This section provides an overview for OneStream authentication for customers in a self-hosted

environment.

For customers in a OneStream-hosted environment, see the Identity and Access Management

Guide for information about authentication with OneStream IdentityServer.

When users sign in to a OneStream application, they go through an authentication process where

they are required to confirm their identity. This is typically done by entering a user ID and

password in the OneStream application. The user ID and password could be through an external

authentication that is Cloud-based in which OneStream is not storing a user password or through

OneStream native users in which this password is stored in the OneStream Framework.

How Does Single Sign-on Work?
l The OneStream administrator must provision a user to OneStream in the System tab. The

Authentication properties of the user indicate whether OneStream should use native

authentication or an external single sign-on (SSO) to authenticate the user.

l Federated single sign-on enables applications to redirect to Azure AD (Microsoft Entra ID),

Okta, PingFederate, or your SAML 2.0 provider for user authentication.

l The user experience during the authentication process is dependent on the configuration of

your identity provider. The default experience presents the user with a dialog box to enter

the single user ID and password previously configured in an external provider that they may

then use to sign in to other corporate applications, hence a single sign-on.
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l Most external authentication providers allow for control over the user experience using

techniques such as Integrated Windows Authentication (IWA) or a variant that can

eliminate or reduce the need to enter a user ID and password multiple times throughout the

day. Consult with your identity provider for information on how to configure this experience. 

o For Azure AD (Microsoft Entra ID), this is referred to as “Pass-Through

Authentication.”

o For Okta, this is referred to as “Okta IWAWeb App.”

o For PingFederate, this is referred to as “PingFederate IWA Integration Kit.”

The steps in this section provide information on configuring OneStream for external authentication

with Transport Layer Security (TLS) encryption (access to the Web Server using https versus

http). For a point of reference, these steps were performed in IIS running on aWindows Server

2016 operating system. 

Modern Browser Experience Configuration

If you use the Modern Browser Experience, you must enter a REST API key in both the

OneStream Application Server Configuration andWeb Server Configuration to enter OneStream

and browser clients.

Application Server Configuration

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of Security.
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4. In the Key for Encrypting Rest Api Calls field, enter a unique value. It is recommended to
enter a value with at least 30 characters that are alphanumeric and have both mixed case

and symbols.

5. Click theOK button.

6. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Web Server Configuration

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.
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3. In the Authentication section, click the ellipsis to the right of Security.

4. In the Key for Encrypting Rest Api Calls field, enter the same value from the Key for

Encrypting Rest Api Calls field in the Application Server Configuration. See Application

Server Configuration step 4.

NOTE: It is recommended to enter a value with at least 30 characters that are
alphanumeric and have both mixed case and symbols.

5. Click theOK button.

6. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Authentication Configurations

OneStream supports native authentication, authentication with one external identity provider, or

both native authentication and one external identity provider.

OneStream supports the following external identity providers:
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l Microsoft Active Directory (MSAD)

l Lightweight Directory Access Protocol (LDAP)

l Three OpenID Connect (OIDC) identity providers:

o Azure Active Directory (Azure AD [Microsoft Entra ID])

o Okta

o PingFederate

l SAML 2.0 identity providers (for example, Okta, PingFederate, Active Directory Federation

Services [ADFS], and Salesforce)

Set up authentication in the Application Server Configuration andWeb Server Configuration in

OneStream. This section includes instructions to set up for the following configurations:

l Native authentication only

l Single sign-on with an external identity provider only

l Native authentication and single sign-on with an external identity provider

Set Up for Native Authentication
1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of Native Authentication.
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4. In the Enable Native Authentication drop-down menu, select True.

IMPORTANT: If Enable Native Authentication is set to False, the user will
receive an error when attempting to log in to OneStream using native

authentication.

5. Click theOK button and save changes.

6. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

7. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.
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8. In theGeneral section, in the SSO Identity Provider Type drop-down menu, select
NotUsed and then click theOK button.

9. In the Authentication section, click the ellipsis to the right of Security.

10. In the Display Native Logon with SSO Enabled drop-down menu, select False.
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11. Click theOK button.

12. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up for Single Sign-on with an External Identity
Provider

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of Native Authentication.

4. In the Enable Native Authentication drop-down menu, select False.
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5. Click theOK button and save changes.

6. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

7. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

8. In theGeneral section, in the SSO Identity Provider Type drop-down menu, select the
type of external identity provider: Azure, Okta, PingFederate, Saml, or OpenId. Click the

OK button.

9. In the Authentication section, click the ellipsis to the right of Security.
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10. In the Display Native Logon with SSO Enabled drop-down menu, select False.

11. Click theOK button.

12. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

We strongly recommend you configure single sign-on with an external identity provider with one of

the following options:

l For OIDC and SAML 2.0 identity providers, enable a time-based one-time password

(TOTP), which requires users to enter a one-time verification code for authentication. See

Verification Code.

l For OIDC identity providers only, run a local loopback with a local redirect port. See OIDC

Local Redirect Port.
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Set Up for Native Authentication and Single Sign-on
with an External Identity Provider

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of Native Authentication.

4. In the Enable Native Authentication drop-down menu, select True.

IMPORTANT: If Enable Native Authentication is set to False, the user will receive
an error when attempting to log in to OneStream using native authentication.

5. Click theOK button and save changes.
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6. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

7. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

8. In theGeneral section, in the SSO Identity Provider Type drop-down menu, select the
type of external identity provider: Azure, Okta, PingFederate, Saml, or OpenId. Click the

OK button.

9. In the Authentication section, click the ellipsis to the right of Security.

10. In the Display Native Logon with SSO Enabled drop-down menu, select True.
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11. Click theOK button.

12. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

We strongly recommend you configure single sign-on with an external identity provider with one of

the following options:

l For OIDC and SAML 2.0 identity providers, enable a time-based one-time password

(TOTP), which requires users to enter a one-time verification code for authentication. See

Verification Code.

l For OIDC identity providers only, run a local loopback with a local redirect port. See OIDC

Local Redirect Port.

This section includes instructions for configuring the following types of authentication:

l Native Authentication Configuration

l MSAD Configuration

l LDAP Configuration

l Microsoft Azure AD (Microsoft Entra ID) Configuration (OIDC)

l Okta Configuration (OIDC)

l PingFederate Configuration (OIDC)
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l SAML 2.0 Configuration with Okta

l SAML 2.0 Configuration with PingFederate

l SAML 2.0 Configuration with ADFS

l SAML 2.0 Configuration with Salesforce

Native Authentication Configuration

To enable native authentication, follow these steps:

1. Set Up for Native Authentication or Set Up for Native Authentication and Single Sign-on

with an External Identity Provider.

2. Set Up OneStream Login with Native Authentication.

3. Log in to OneStream with Native Authentication.

Set Up OneStream Login with Native Authentication

1. In the OneStream desktop application, go to System > Security > Users > <user>.

2. In the Authentication section, complete the following fields for native authentication.

l External Authentication Provider: In the drop-down menu, select (Not Used).

l External Provider User Name: Leave this field blank.

l Internal Provider Password: Enter a password.

3. Click the Save icon.

Log in to OneStream with Native Authentication

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:
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1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Enter your user profile name and internal provider password.

4. Click the Logon button.

5. Select an application from the drop-down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

MSAD Configuration

To enable single sign-on with MSAD, follow these steps:

1. Set Up for Native Authentication or Set Up for Native Authentication and Single Sign-on

with an External Identity Provider.

2. Set Up the Application Server Configuration in OneStream.

3. Set Up the Web Server Configuration in OneStream.

4. Set Up OneStream Login with MSAD.

5. Log in to OneStream with MSAD.
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Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.

4. Click the + icon to add an item. 

5. In theGeneral andWindows sections, complete the following fields:

l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: SelectWindows in the drop-down menu.

l Name of Account Store: Enter the domain name of the active directory.

TIP: In Active Directory Users and Computers, you can view the domain

name of the active directory.

l Name of Account Store Container: Enter the name of the domain controller (DC).
Leave the other values as default.
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TIP: In Active Directory Users and Computers, under the active
directory, click Domain Controllers to view the name of the domain

controller.

l Type of Account Store: Select Domain in the drop-down menu.

See External Authentication Providers.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.
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3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

4. In the SSO Identity Provider Type drop-down menu, select NotUsed.

5. Click theOK button.

6. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.
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Set Up OneStream Login with MSAD

1. In the desktop application, go to System > Security > Users > <user>.

2. In theGeneral and Authentication properties, complete the following fields for MSAD
authentication.

l Name: Enter the user logon name listed in active directory.

TIP: In Active Directory Users and Computers, under the active
directory, click Users to view the list of users. Select the user. Click the

Account tab to view the user logon name.

l External Authentication Provider: In the drop-down menu, select the MSAD
configuration.

l External Provider User Name: Leave this field blank.

3. Click the Save icon.

Log in to OneStream with MSAD

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Enter your user name and password set up in MSAD.

4. Click the Logon button.
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5. Select an application from the drop-down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

LDAP Configuration

To enable single sign-on with LDAP, follow these steps:

1. Set Up for Native Authentication or Set Up for Native Authentication and Single Sign-on

with an External Identity Provider.

2. Set Up the Application Server Configuration in OneStream.

3. Set Up the Web Server Configuration in OneStream.

4. Set Up OneStream Login with LDAP.

5. Log in to OneStream with LDAP.

Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.
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4. Click the + icon to add an item. 

5. In theGeneral and LDAP sections, complete the following fields:

l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: Select LDAP in the drop-down menu.

l LDAP Authentication Type: Select Basic in the drop-down menu.

l LDAP Base DN: Enter the distinguished name (DN) of the container or
organizational unit where your OneStream users' accounts are located. 

TIP: The base DN is the full path to the location of the user accounts in the

authentication hierarchy. LDAP will look for user accounts in this location. If

needed, contact your IT Support for this information.

l LDAP Server or Domain: Enter the fully qualified domain name (FQDN) of your
active directory domain or domain controller.

Installation and Configuration Guide 106

About Installation and Configuration



See External Authentication Providers.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.
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4. In the SSO Identity Provider Type drop-down menu, select NotUsed.

5. Click theOK button.

6. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up OneStream Login with LDAP

1. In the desktop application, go to System > Security > Users > <user>.

2. In theGeneral and Authentication properties, complete the following fields for LDAP
authentication:
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l Name: Enter the user logon name listed in active directory.

TIP: In Active Directory Users and Computers, under the active
directory, click Users to view the list of users. Select the user. Click the

Account tab to view the user logon name.

l External Authentication Provider: In the drop-down menu, select the LDAP
configuration.

l External Provider User Name: Enter the display name listed in the active directory.

TIP: In Active Directory Users and Computers, under the active
directory, click Users to view the list of users. Select the user. Click the

General tab to view the display name.

3. Click the Save icon.

Log in to OneStream with LDAP

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Enter your user name (user logon name) and password set up in the active directory.

4. Click the Logon button.

5. Select an application from the drop-down menu.

6. Click theOpen Application button.

Installation and Configuration Guide 109

About Installation and Configuration



NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

Microsoft Azure AD (Microsoft Entra ID) Configuration

To enable single sign-on with Azure AD (Microsoft Entra ID) using OIDC protocol, follow these

steps:

1. Set Up for Single Sign-on with an External Identity Provider or Set Up for Native

Authentication and Single Sign-on with an External Identity Provider.

2. Set Up the Applications in Azure AD (Microsoft Entra ID).

3. Set Up the Application Server Configuration in OneStream.

4. Set Up the Web Server Configuration in OneStream.

5. Set Up OneStream Login with Azure AD (Microsoft Entra ID).

6. Log in to OneStream with Azure AD (Microsoft Entra ID).

To configure OneStream REST API to support Azure AD (Microsoft Entra ID) authentication, see

the REST API Implementation Guide.

Set Up the Applications in Azure AD (Microsoft Entra ID)

Set up the applications in Azure AD (Microsoft Entra ID) for the browser and desktop application.

Modern Browser Experience

To set up the application in Azure AD (Microsoft Entra ID) for the browser, you must complete

these steps:
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l Enter the redirect URI in Azure AD (Microsoft Entra ID) in this format:

https://<domainname>/signin-oidc

l Copy the client secret from Azure AD (Microsoft Entra ID) and paste it into the Application

Server Configuration andWeb Server Configuration in OneStream.

l Copy the application (client) ID and tenant ID (directory ID) from Azure AD (Microsoft Entra

ID) and paste them into the Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your Azure AD account.

2. On the Home screen, click the App registrations icon.

3. On the App registrations page, click the + New registration tab.

4. On the Register an application page, complete the following fields:

a. Enter a name for the application.

b. For Supported account types, select Accounts in this organizational directory
only.

c. For Redirect URI, selectWeb.

5. Click the Register button.

6. On the page for the application, click Add a Redirect URI.

7. On the Authentication page, click the + Add a platform button.

8. In the Configure platforms section to the right, select theWeb icon.

9. In the Redirect URIs field, enter the redirect URI in this format:
https://<domainname>/signin-oidc

10. For Implicit grant and hybrid flows, select ID tokens.
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11. Click the Configure button.

12. On the page for the application, click Add a certificate or secret.

13. On the Certificates & secrets page, click the + New client secret button.

14. In the Add a client secret section to the right, enter a description and select an expiration
time in the drop-down menu.

15. Click the Add button.

16. Copy the value for the client secret. You will need to paste it in the Web Server

Configuration in OneStream.

IMPORTANT: The client secret value may only be available to copy for a limited
time, so copy it immediately after it is created.

TIP: Return to the App registrations page in Azure AD and then select the

application to access information needed for the Web Server Configuration in

OneStream: application (client) ID, directory (tenant) ID, and redirect URI.

Desktop Application

To set up the application in Azure AD (Microsoft Entra ID) for the desktop application, which

includes the Windows Client application and the Excel Add-In, you must complete these steps:

l Enter the redirect URI in Azure AD (Microsoft Entra ID) in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

l Copy the application (client) ID and tenant ID (directory ID) from Azure AD (Microsoft Entra

ID) and paste them into the Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.
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1. Log in to your Azure AD account.

2. On the Home screen, click the App registrations icon.

3. On the App registrations page, click the + New registration tab.

4. On the Register an application page, complete the following fields:

a. Enter a name for the application.

b. For Supported account types, select Accounts in this organizational directory
only.

c. For Redirect URI, select Public client/native.

5. Click the Register button.

6. On the page for the application, click Add a Redirect URI.

7. On the Authentication page, click the + Add a platform button.

8. In the Configure platforms section to the right, select theMobile and desktop
applications icon.

9. In the Custom redirect URIs field, enter the redirect URI in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

10. Click the Configure button.

TIP: Return to the App registrations page in Azure AD and then select the

application to access information needed for the Web Server Configuration in

OneStream: application (client) ID, directory (tenant) ID, and redirect URI.
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Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.

4. Click the + icon to add an item.

5. In theGeneral and External Provider Single Sign On sections, complete the following
fields:

l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: Select AzureSSO in the drop-down menu.

l External Provider Web SSO Secret Key: Enter the client secret from Azure AD.

See Modern Browser Experience step 16. This key is used in the OneStream

Application Server Configuration and the OneStreamWeb Server Configuration. It

enables your application server to communicate with the web server.
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6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

4. Click the ellipsis to the right of Azure Identity Provider.
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5. In the Azure Identity Provider dialog box, complete the following fields:

General

l Azure AD Tenant Id: Enter the directory (tenant) ID from Azure AD. The directory

(tenant) ID in Azure AD should be the same value for the browser and desktop

application.

TIP: To view the directory (tenant) ID in Azure AD, go to the page for the

application and selectOverview in the list on the left.

l Azure OpenID Connect Scopes: Enter scopes, or leave as default (openid email
profile).

Browser UX Settings
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l OneStream Web App Client ID: Enter the application (client) ID from Azure AD.

See Modern Browser Experience step 16.

l OneStream Web App Client Secret Key: Enter the same value from the External

Provider Web SSO Secret Key field in the Application Server Configuration. Enter the

client secret from Azure AD. See Modern Browser Experience step 16.

l Open Id Redirect Url: Enter the value you entered in Azure AD as the redirect URI.

See Modern Browser Experience step 9. Use this format:

https://<domainname>/signin-oidc

IMPORTANT: The redirect URI entered in Azure AD and in the Open Id

Redirect Url field must match exactly, including capitalization.

IMPORTANT: The value entered in Browser UX Settings > Open Id
Redirect Url must be different from the value entered in Windows Desktop

Client Settings > OneStreamWindows App Redirect Url in order to route to

the correct client.

Windows Desktop Client Settings

l OneStream Windows App Client ID: Enter the application (client) ID from Azure

AD. See Desktop Application step 10.

l OneStream Windows App Redirect Url: Enter the value you entered in Azure AD
as the redirect URI. See Desktop Application step 10. Use this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

IMPORTANT: The redirect URI entered in Azure AD and in the OneStream

Windows App Redirect Url field must match exactly, including capitalization.
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IMPORTANT: The value entered in Windows Desktop Client Settings >

OneStreamWindows App Redirect Url must be different from the value

entered in Browser UX Settings > Open Id Redirect Url in order to route to

the correct client.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

We strongly recommend you configure your environment for OIDC authentication to run a local

loopback with a local redirect port. See OIDC Local Redirect Port.

Set Up OneStream Login with Azure AD (Microsoft Entra ID)

1. In the desktop application, go to System > Security > Users > <user>.

2. In the Authentication properties, complete the following fields for authentication through
Azure AD.
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l External Authentication Provider: In the drop-down menu, select the Azure AD
configuration.

l External Provider User Name: Enter the username configured in Azure AD. This
name must match the username set up in Azure AD and be used by only one user.

3. Click the Save icon.

Log in to OneStream with Azure AD (Microsoft Entra ID)

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Click the External Provider Sign In button.

4. Enter your Azure AD login credentials.

NOTE: If the Require Verification Code setting in the Web Server Configuration

File is enabled, you will be provided with a one-time verification code to enter in

the application. See Verification Code.

5. Select an application from the drop-down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.
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Okta Configuration

To enable single sign-on with Okta using OIDC protocol, follow these steps:

1. Set Up for Single Sign-on with an External Identity Provider or Set Up for Native

Authentication and Single Sign-on with an External Identity Provider.

2. Set Up the Application Server Configuration in OneStream.

3. Set Up the Applications in Okta.

4. Set Up the Web Server Configuration in OneStream.

5. Set Up OneStream Login with Okta.

6. Log in to OneStream with Okta.

To configure OneStream REST API to support Okta authentication, see the REST

API Implementation Guide.

Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.
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4. Click the + icon to add an item.

5. In theGeneral and External Provider Single Sign On sections, complete the following
fields:

l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: SelectOkta SSO in the drop-down menu.

l External Provider Web SSO Secret Key: Enter a unique value. This key is used in
the OneStream Application Server Configuration and the OneStreamWeb Server

Configuration. It enables your application server to communicate with the web server.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up the Applications in Okta

Set up the applications in Okta for the browser and desktop application.

Modern Browser Experience

To set up the application in Okta for the browser, you must complete these steps:
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l Enter the redirect URI in Okta in this format: https://<domainname>/signin-oidc

l Copy the client ID from Okta and paste it into the Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your Okta account.

2. In the Applications list on the left, select Applications.

3. Click Create App Integration.

4. In the Create a new app integration dialog box, for Sign-in method, selectOIDC -
OpenID Connect.

5. For Application type, select Single-Page Application.

6. Click the Next button.

7. On the New Single-Page App Integration page, complete the following fields:

l App integration name: Enter the name of the application in Okta.

l Grant type: Select Authorization Code and Refresh Token.

l Sign-in redirect URIs: Enter the sign-in redirect URI in this format:
https://<domainname>/signin-oidc

l Sign-out redirect URIs: Click X to clear the field.

l Controlled access: Select the access option for the application.

8. Click the Save button.

9. Copy the client ID. You will paste this into the Web Server Configuration in OneStream.
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Desktop Application

To set up the application in Okta for the desktop application, which includes the Windows Client

application and the Excel Add-In, you must complete these steps:

l Enter the redirect URI in Okta in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

l Copy the client ID from Okta and paste it into the Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you need to complete might be different.

1. Log in to your Okta account.

2. In the Applications list on the left, select Applications.

3. Click Create App Integration.

4. In the Create a new app integration dialog box, for Sign-in method, selectOIDC -
OpenID Connect.

5. For Application type, select Native Application.

6. Click the Next button.

7. On the New Native App Integration page, complete the following fields:

l App integration name: Enter the name of the application in Okta.

l Grant type: Select Authorization Code and Refresh Token.

l Sign-in redirect URIs: Enter the sign-in redirect URI in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

l Sign-out redirect URIs: Click X to clear the field.

l Controlled access: Select the access option for the application.
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8. Click the Save button.

9. Copy the client ID. You will need to paste this into the Web Server Configuration in

OneStream.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

4. Click the ellipsis to the right ofOkta Identity Provider.
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5. In theOkta Identity Provider dialog box, complete the following fields:

General

l Okta Domain: Enter the domain from the Okta page URL.

l Okta Scopes: Enter scopes, or leave as default (openid email phone address
profile).

l Okta Authorization Server ID: Leave as default (blank).

Browser UX Settings

l OneStream Web App Client ID: Enter the client ID from the Okta application. See

Modern Browser Experience step 9.

l Okta Web App Client Secret Key: Enter the same value from the External Provider

Web SSO Secret Key field in the Application Server Configuration. See Set Up the

Application Server Configuration in OneStream step 5.
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l Open Id Redirect Url: Enter the value you entered in Okta as the redirect URI. See
Modern Browser Experience step 7. Use this format: https://<domainname>/signin-

oidc

IMPORTANT: The redirect URI entered in Okta and in the Open Id Redirect
Url field must match exactly, including capitalization.

IMPORTANT: The value entered in Browser UX Settings > Open Id

Redirect Url must be different from the value entered in Windows Desktop

Client Settings > OneStreamWindows App Redirect Url in order to route to

the correct client.

Windows Desktop Client Settings

l OneStream Windows App Client ID: Enter the client ID from the Okta application.

See Desktop Application step 9.

l OneStream Windows App Redirect Url: Enter the value you entered in Okta as the
sign-in redirect URI. See Desktop Application step 7. Use this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

IMPORTANT: The sign-in redirect URI entered in Okta and in the
OneStreamWindows App Redirect Url field must match exactly, including

capitalization.

IMPORTANT: The value entered in Windows Desktop Client Settings >

OneStreamWindows App Redirect Url must be different from the value

entered in Browser UX Settings > Open Id Redirect Url in order to route to

the correct client.
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6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

We strongly recommend you configure your environment for OIDC authentication to run a local

loopback with a local redirect port. See OIDC Local Redirect Port.

Set Up OneStream Login with Okta

1. In the desktop application, go to System > Security > Users > <user>.

2. In the Authentication properties, configure the user to authenticate through Okta.

l External Authentication Provider: In the drop-down menu, select the Okta
configuration.

l External Provider User Name: Enter the username configured in Okta. This name
must match the username set up in Okta and be used by only one user.

3. Click the Save icon.
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Log in to OneStream with Okta

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Click the External Provider Sign In button.

4. Enter your Okta login credentials.

NOTE: If the Require Verification Code setting in the Web Server Configuration

File is enabled, you will be provided with a one-time verification code to enter in

the application. See Verification Code.

5. Select an application from the drop-down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

PingFederate Configuration

First, install and configure PingFederate. See Appendix: Installing and Configuring PingFederate.

To enable single sign-on with PingFederate using OIDC protocol, follow these steps:

1. Set Up for Single Sign-on with an External Identity Provider or Set Up for Native

Authentication and Single Sign-on with an External Identity Provider.

2. Set Up the Applications in PingFederate.
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3. Set Up the Application Server Configuration in OneStream.

4. Set Up the Web Server Configuration in OneStream.

5. Set Up OneStream Login with PingFederate.

6. Log in to OneStream with PingFederate.

To configure OneStream REST API to support PingFederate authentication, see the REST

API Implementation Guide.

Set Up the Applications in PingFederate

Set up the applications in PingFederate for the browser and desktop application.

Modern Browser Experience

To set up the application in PingFederate for the browser, you must complete these steps:

l Enter the same client ID in PingFederate and the Web Server Configuration in OneStream.

l Enter the redirect URI in PingFederate in this format: https://<domainname>/signin-oidc

l Copy the client secret from PingFederate and paste it into the Application Server

Configuration andWeb Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your PingFederate account.

2. In the menu on the left, clickOAuth Server.

3. Under the CLIENTS list, click the Create New button.

4. On the Client page, complete the following fields:
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l CLIENT ID: Enter a client ID, which is a unique name or identifier for the application
registration.

l NAME: Enter the name of the client.

l CLIENT AUTHENTICATION: Select CLIENT SECRET.

l CLIENT SECRET: Select CHANGE SECRET and then click theGenerate Secret
button.

IMPORTANT: The client secret value may only be available to copy for a
limited time, so copy it immediately after it is created.

l REDIRECT URIS: Enter the redirect URI in this format:
https://<domainname>/signin-oidc and then click the Add button.

l ALLOWED GRANT TYPES: Select Authorization Code and Refresh Token.

l REQUIRE PROOF KEY FOR CODE EXCHANGE (PKCE): Select this option.

5. Click the Save button.

Desktop Application

To set up the application in PingFederate for the desktop application, which includes the Windows

Client application and the Excel Add-In, you must complete these steps:

l Enter the same client ID in PingFederate and the Web Server Configuration in OneStream.

l Enter the redirect URI in PingFederate in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.
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1. Log in to your PingFederate account.

2. In the menu on the left, clickOAuth Server.

3. Under the CLIENTS list, click the Create New button.

4. On the Client page, complete the following fields:

l CLIENT ID: Enter a client ID, which is a unique name or identifier for the application
registration.

l NAME: Enter the name of the client.

l REDIRECT URIS: Enter the redirect URI in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx and then

click the Add button.

l ALLOWED GRANT TYPES: Select Authorization Code and Refresh Token.

l REQUIRE PROOF KEY FOR CODE EXCHANGE (PKCE): Select this option.

5. Click the Save button.

Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.
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4. Click the + icon to add an item.

5. In theGeneral and External Provider Single Sign On sections, complete the following
fields:

l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: Select PingFederateSSO in the drop-down menu.

l External Provider Web SSO Secret Key: Enter the client secret from
PingFederate. See Browser Experience Application step 4. This key is used in the

OneStream Application Server Configuration and the OneStreamWeb Server

Configuration. It enables your application server to communicate with the web server.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.
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Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

4. Click the ellipsis to the right of PingFederate Identity Provider.

Installation and Configuration Guide 133

About Installation and Configuration



5. In the PingFederate Identity Provider dialog box, complete the following fields:

General

l PingFederate Domain: Enter the PingFederate domain. If needed, request this
value from your IT Support.

l PingFederate Scopes: Enter scopes, or leave as default (openid email phone
address profile).

Browser UX Settings

l OneStream Web App Client ID: Enter the client ID you entered in PingFederate.
See Modern Browser Experience step 4.

l OneStream Web App Client Secret Key: Enter the client secret from
PingFederate. See Modern Browser Experience step 4.

l Open Id Redirect Url: Enter the value you entered in PingFederate as the redirect
URI. See Modern Browser Experience step 4. Use this format:

https://<domainname>/signin-oidc

IMPORTANT: The redirect URI entered in PingFederate and in the Open Id
Redirect Url field must match exactly, including capitalization.

IMPORTANT: The value entered in Browser UX Settings > Open Id

Redirect Url must be different from the value entered in Windows Desktop

Client Settings > OneStreamWindows App Redirect Url in order to route to

the correct client.

Windows Desktop Client Settings

Installation and Configuration Guide 134

About Installation and Configuration



l OneStream Windows App Client ID: Enter the client ID you entered in
PingFederate. See Desktop Application step 4.

l OneStream Windows App Redirect Url: Enter the value you entered in
PingFederate as the redirect URI. See Desktop Application step 4. Use this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx

IMPORTANT: The redirect URI entered in PingFederate and in the
OneStreamWindows App Redirect Url field must match exactly, including

capitalization.

IMPORTANT: The value entered in Windows Desktop Client Settings >

OneStreamWindows App Redirect Url must be different from the value

entered in Browser UX Settings > Open Id Redirect Url in order to route to

the correct client.

6. Click theOK button.

7. Save changes and reset IIS.
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NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

We strongly recommend you configure your environment for OIDC authentication to run a local

loopback with a local redirect port. See OIDC Local Redirect Port.

Set Up OneStream Login with PingFederate

1. In the desktop application, go to System > Security > Users > <user>.

2. In the Authentication properties, configure the user to authenticate through PingFederate.

l External Authentication Provider: In the drop-down menu, select the
PingFederate configuration.

l External Provider User Name: Enter the username configured in PingFederate.
This name must match the username set up in PingFederate and be used by only

one user.

3. Click the Save icon.

Log in to OneStream with PingFederate

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Click the External Provider Sign In button.

4. Enter your PingFederate login credentials.
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NOTE: If the Require Verification Code setting in the Web Server Configuration

File is enabled, you will be provided with a one-time verification code to enter in

the application. See Verification Code.

5. Select an application from the drop-down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

SAML 2.0 Configuration with Okta

To enable single sign-on with Okta using SAML protocol, follow these steps:

1. Set Up for Single Sign-on with an External Identity Provider or Set Up for Native

Authentication and Single Sign-on with an External Identity Provider.

2. Set Up the Application Server Configuration in OneStream.

3. Set Up the Applications in Okta.

4. Set Up the Web Server Configuration in OneStream.

5. Set Up OneStream Login with Okta.

6. Log in to OneStream with Okta.

Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

Installation and Configuration Guide 137

About Installation and Configuration



3. In the Security section, click the ellipsis to the right of External Authentication Providers.

4. Click the + icon to add an item.

5. In theGeneral and External Provider Single Sign On sections, complete the following
fields:

l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: Select SamlSSO in the drop-down menu.

l External Provider Web SSO Secret Key: Enter a unique value. This key is used in
the OneStream Application Server Configuration and the OneStreamWeb Server

Configuration. It enables your application server to communicate with the web server.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.
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Set Up the Applications in Okta

Set up the applications in Okta for the browser and desktop application.

Modern Browser Experience

To set up the application in Okta for the browser, you must complete these steps:

l Enter the single sign-on URL and audience URI in Okta in this format:

https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the single sign-on URL and audience

URI exactly when you enter them in Okta. They must be an identical match.

l Copy the single sign on (ACS) URL and metadata URL from Okta and paste them into the

Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your Okta account.

2. In the Applications list on the left, select Applications.

3. Click Create App Integration.

4. In the Create a new app integration dialog box, for Sign-in method, select SAML 2.0.

5. Click the Next button.

6. On the Create SAML Integration page, on theGeneral Settings tab, in the App name
field, enter the name of the application in Okta.

7. Click the Next button.
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8. On the Create SAML Integration page, on the Configure SAML tab, complete the
following fields:

l Single sign-on URL: Enter the single sign-on URL in this format:
https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the single sign-on URL exactly

when you enter it in Okta. It must be an identical match.

l Audience URI (SP Entity ID): Enter the audience URI in this format:
https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the audience URI exactly when

you enter it in Okta. It must be an identical match.

9. Click the Next button.

10. On the Create SAML Integration page, on the Feedback tab, for Are you a customer or
partner?, select I'm an Okta customer adding an internal app.

11. Click the Finish button.

12. Copy the following information. You will need to paste this into the Web Server

Configuration in OneStream.

a. In theGeneral tab, copy the single sign on URL.

b. In the Sign on tab, copy the metadata URL.

NOTE: On the Assignments tab, you can assign users to the application.

Desktop Application

To set up the application in Okta for the desktop application, which includes the Windows Client

application and the Excel Add-In, you must complete these steps:
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l Copy the single sign on (ACS) URL and metadata URL from Okta and paste them into the

Web Server Configuration in OneStream.

l Enter the single sign-on URL and audience URI in Okta in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the single sign-on URL and audience

URI exactly when you enter them in Okta. They must be an identical match.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you need to complete might be different.

1. Log in to your Okta account.

2. In the Applications list on the left, select Applications.

3. Click Create App Integration.

4. In the Create a new app integration dialog box, for Sign-in method, select SAML 2.0.

5. Click the Next button.

6. On the Create SAML Integration page, on theGeneral Settings tab, in the App name
field, enter the name of the application in Okta.

7. Click the Next button.

8. On the Create SAML Integration page, on the Configure SAML tab, complete the
following fields:

l Single sign-on URL: Enter the single sign-on URL in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the single sign-on URL exactly

when you enter it in Okta. It must be an identical match.
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l Audience URI (SP Entity ID): Enter the audience URI in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the audience URI exactly when

you enter it in Okta. It must be an identical match.

9. Click the Next button.

10. On the Create SAML Integration page, on the Feedback tab, for Are you a customer or
partner?, select I'm an Okta customer adding an internal app.

11. Click the Finish button.

12. Copy the following information. You will need to paste this into the Web Server

Configuration in OneStream.

a. In theGeneral tab, copy the single sign on URL.

b. In the Sign on tab, copy the metadata URL.

NOTE: On the Assignments tab, you can assign users to the application.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.
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4. Click the ellipsis to the right of SAML 2.0 Identity Provider.

5. In the SAML 2.0 Identity Provider dialog box, complete the following fields:

General

l Application Server Pre-Shared Key: Enter the same value from the External

Provider Web SSO Secret Key field in the Application Server Configuration. See Set

Up the Application Server Configuration in OneStream step 5.

Browser UX Settings
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l ACS URL for Browser UX: Enter the single sign on URL from Okta. See Modern

Browser Experience step 12. Use this format: https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the single sign-on URL exactly

when you enter it in the Web Server Configuration File. It must be an

identical match.

l Metadata Content for Browser UX: Enter the metadata URL from Okta. See

Modern Browser Experience step 12.

NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.

Windows Desktop Client Settings

l ACS URL for Windows Application: Enter the single sign on URL from Okta. See

Desktop Application step 12. Use this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the single sign-on URL exactly

when you enter it in the Web Server Configuration File. It must be an

identical match.

l Metadata Content For Native Application: Enter the metadata URL from Okta.

See Desktop Application step 12.

NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.
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6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up OneStream Login with Okta

1. In the desktop application, go to System > Security > Users > <user>.

2. In the Authentication properties, configure the user to authenticate through Okta.

l External Authentication Provider: In the drop-down menu, select the Okta
configuration.

l External Provider User Name: Enter the username configured in Okta. This name
must match the username set up in Okta and be used by only one user.

3. Click the Save icon.
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Log in to OneStream with Okta

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Click the External Provider Sign In button.

4. Enter your Okta login credentials.

NOTE: If the Require Verification Code setting in the Web Server Configuration

File is enabled, you will be provided with a one-time verification code to enter in

the application. See Verification Code.

5. On the OneStream desktop application Logon screen, select an application from the drop-

down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

SAML 2.0 Configuration with PingFederate

First, install and configure PingFederate. See Appendix: Installing and Configuring PingFederate.

To enable single sign-on with PingFederate using SAML protocol, follow these steps:
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1. Set Up for Single Sign-on with an External Identity Provider or Set Up for Native

Authentication and Single Sign-on with an External Identity Provider.

2. Set Up the Application Server Configuration in OneStream.

3. Set Up the Applications in PingFederate.

4. Set Up the Web Server Configuration in OneStream.

5. Set Up OneStream Login with PingFederate.

6. Log in to OneStream with PingFederate.

Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.

4. Click the + icon to add an item.

5. In theGeneral and External Provider Single Sign On sections, complete the following
fields:
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l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: Select SamlSSO in the drop-down menu.

l External Provider Web SSO Secret Key: Enter a unique value. This key is used in
the OneStream Application Server Configuration and the OneStreamWeb Server

Configuration. It enables your application server to communicate with the web server.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up the Applications in PingFederate

Set up the applications in PingFederate for the browser and desktop application.

Modern Browser Experience

To set up the application in PingFederate for the browser, you must complete these steps:
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l Enter the entity ID and assertion consumer service (ACS) URL in PingFederate in this

format: https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the entity ID and ACS URL exactly

when you enter them in PingFederate. They must be an identical match.

l Export the metadata from PingFederate and then copy the URL, entity ID, and single sign-

on from the metadata and paste them into the Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your PingFederate account.

2. In the menu on the left, click Identity Provider.

3. Under the SP CONNECTIONS list, click the Create New button.

4. On the SP Connection page, in the Connection Template tab, select
DO NOT USE A TEMPLATE FOR THIS CONNECTION, and click the Next button.

5. In the Connection Type tab, select BROWSER SSO PROFILES, and click the Next
button.

6. In the Connection Options tab, click the Next button.

7. In the Import Metadata tab, click the Next button.

8. In theGeneral Info tab, complete the following fields:

l PARTNER'S ENTITY ID (CONNECTION ID): Enter the entity ID in this format:

https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the entity ID exactly when you
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enter it in PingFederate. It must be an identical match.

l CONNECTION NAME: Enter the name of the connection.

9. Click the Next button.

10. In the Browser SSO tab, click the Configure Browser SSO button.

a. In the SAML Profiles tab, in the Single Sign-On (SSO) Profiles list, select SP-
INITIATED SSO. Click the Next button.

b. In the Assertion Lifetime tab, click the Next button.

c. In the Assertion Creation tab, click the Configure Assertion Creation button.

i. In the Identity Mapping tab, click the Next button.

ii. In the Attribute Contract tab, click the Next button.

iii. In the Authentication Source Mapping tab, click theMap New Adapter
Instance button.

i. In the Adapter Instance tab, for ADAPTER INSTANCE, select
HTML Form Adapter from the drop-down menu. Click the Next button.

ii. In theMapping Method tab, click the Next button.

iii. In the Attribute Contract Fulfillment tab, for SAML_SUBJECT, in the
Source drop-down menu, select Adapter. In the Value drop-down
menu, select username. Click the Next button.

iv. In the Insurance Criteria tab, click the Next button.

v. In the Summary tab, click the Done button.

iv. In the Summary tab, click the Next button and then the Done button.

d. In the Assertion Creation tab, click the Next button.
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e. In the Protocol Settings tab, click the Configure Protocol Settings button.

i. In the Assertion Consumer Service URL tab, In the Binding drop-down
menu, select POST. Enter the Endpoint URL in this format:
https://<domainname>/saml/sso and click the Add button. Click the Next
button.

IMPORTANT: Follow the format listed for the ACS URL exactly when

you enter it in PingFederate. It must be an identical match.

ii. In the Allowable SAML Bindings tab, clear the checkboxes for
ARTIFACT and SOAP. Select only POST and REDIRECT, and click the Next
button.

iii. In the Signature Policy tab, click the Next button.

iv. In the Encryption Policy tab, click the Next button.

v. In the Summary tab, click the Done button.

f. In the Summary tab, click the Next button and then the Done button.

11. In the Browser SSO tab, click the Next button.

12. In the Credentials tab, click the Configure Credentials button.

a. In the Digital Signature Settings tab, in the SIGNING CERTIFICATE drop-down
menu, select the certificate. Click the Next button.

b. In the Summary tab, click the Done button.

13. In the Activation & Summary tab, click the Next button and then the Save button.

14. Export the metadata to add to the Web Server Configuration File.
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a. In PingFederate, in the menu on the left, click Identity Provider.

b. Under the SP CONNECTIONS list, click theManage All button.

c. On the SP Connections page, in the row for the connection, in the Action column,
click Select Action to view the drop-down menu options.

d. Select Export Metadata.

e. Select the signing certificate from the drop-down menu, and click the Next button.

f. Click the Export button.

Desktop Application

To set up the application in PingFederate for the desktop application, which includes the Windows

Client application and the Excel Add-In, you must complete these steps:

l Enter the entity ID and assertion consumer service (ACS) URL in PingFederate in this

format: https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the entity ID and ACS URL exactly

when you enter them in PingFederate. They must be an identical match.

l Export the metadata from PingFederate and then copy the URL, entity ID, and single sign-

on from the metadata and paste them into the Web Server Configuration in OneStream

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your PingFederate account.

2. In the menu on the left, click Identity Provider.

3. Under the SP CONNECTIONS list, click the Create New button.

Installation and Configuration Guide 152

About Installation and Configuration



4. On the SP Connection page, in the Connection Template tab, select
DO NOT USE A TEMPLATE FOR THIS CONNECTION, and click the Next button.

5. In the Connection Type tab, select BROWSER SSO PROFILES, and click the Next
button.

6. In the Connection Options tab, click the Next button.

7. In the Import Metadata tab, click the Next button.

8. In theGeneral Info tab, complete the following fields:

l PARTNER'S ENTITY ID (CONNECTION ID): Enter the entity ID in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the entity ID exactly when you

enter it in PingFederate. It must be an identical match.

l CONNECTION NAME: Enter the name of the connection.

9. Click the Next button.

10. In the Browser SSO tab, click the Configure Browser SSO button.

a. In the SAML Profiles tab, in the Single Sign-On (SSO) Profiles list, select SP-
INITIATED SSO. Click the Next button.

b. In the Assertion Lifetime tab, click the Next button.

c. In the Assertion Creation tab, click the Configure Assertion Creation button.

i. In the Identity Mapping tab, click the Next button.

ii. In the Attribute Contract tab, click the Next button.

iii. In the Authentication Source Mapping tab, click theMap New Adapter
Instance button.
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i. In the Adapter Instance tab, for ADAPTER INSTANCE, select
HTML Form Adapter from the drop-down menu. Click the Next button.

ii. In theMapping Method tab, click the Next button.

iii. In the Attribute Contract Fulfillment tab, for SAML_SUBJECT, in the
Source drop-down menu, select Adapter. In the Value drop-down
menu, select username. Click the Next button.

iv. In the Insurance Criteria tab, click the Next button.

v. In the Summary tab, click the Done button.

iv. In the Summary tab, click the Next button and then the Done button.

d. In the Assertion Creation tab, click the Next button.

e. In the Protocol Settings tab, click the Configure Protocol Settings button.

i. In the Assertion Consumer Service URL tab, In the Binding drop-down
menu, select POST. Enter the Endpoint URL in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/ and

click the Add button. Click the Next button.

IMPORTANT: Follow the format listed for the ACS URL exactly when

you enter it in PingFederate. It must be an identical match.

ii. In the Allowable SAML Bindings tab, clear the checkboxes for
ARTIFACT and SOAP. Select only POST and REDIRECT, and click the Next
button.

iii. In the Signature Policy tab, click the Next button.

iv. In the Encryption Policy tab, click the Next button.

v. In the Summary tab, click the Done button.
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f. In the Summary tab, click the Next button and then the Done button.

11. In the Browser SSO tab, click the Next button.

12. In the Credentials tab, click the Configure Credentials button.

a. In the Digital Signature Settings tab, in the SIGNING CERTIFICATE drop-down
menu, select the certificate. Click the Next button.

b. In the Summary tab, click the Done button.

13. In the Activation & Summary tab, click the Next button and then the Save button.

14. Export the metadata to add to the Web Server Configuration File.

a. In PingFederate, in the menu on the left, click Identity Provider.

b. Under the SP CONNECTIONS list, click theManage All button.

c. On the SP Connections page, in the row for the connection, in the Action column,
click Select Action to view the drop-down menu options.

d. Select Export Metadata.

e. Select the signing certificate from the drop-down menu, and click the Next button.

f. Click the Export button.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.
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4. Click the ellipsis to the right of SAML 2.0 Identity Provider.

5. In the SAML 2.0 Identity Provider dialog box, complete the following fields:

General

l Application Server Pre-Shared Key: Enter the same value from the External

Provider Web SSO Secret Key field in the Application Server Configuration. See Set

Up the Application Server Configuration in OneStream step 5.

Browser UX Settings
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l ACS URL for Browser UX: Enter the assertion consumer service (ACS) URL from
PingFederate. See Modern Browser Experience step 10. Use this format:

https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the ACS URL exactly when you

enter it in the Web Server Configuration File. It must be an identical match.

l Metadata Content for Browser UX: Enter the metadata URL from PingFederate.

See Modern Browser Experience step 14.

l IdP Entity ID for Browser UX: Enter the entity ID from the metadata. See Modern

Browser Experience step 14.

l IdP Single Sign-On URL for Browser UX: Enter the single sign-on from the

metadata. See Modern Browser Experience step 14.

NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.

Windows Desktop Client Settings

l ACS URL for Windows Application: Enter the assertion consumer service (ACS)
URL from PingFederate. See Desktop Application step 10. Use this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the ACS URL exactly when you

enter it in the Web Server Configuration File. It must be an identical match.

l Metadata Content For Native Application: Enter the metadata URL from
PingFederate. See Desktop Application step 14.
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l IdP Entity ID for Native Applications: Enter the entity ID from the metadata. See

Desktop Application step 14.

l IdP Single Sign-On URL for Native Applications: Enter the single sign-on from
the metadata. See Desktop Application step 14.

NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.
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Set Up OneStream Login with PingFederate

1. In the desktop application, go to System > Security > Users > <user>.

2. In the Authentication properties, configure the user to authenticate through PingFederate.

l External Authentication Provider: In the drop-down menu, select the
PingFederate configuration.

l External Provider User Name: Enter the username configured in PingFederate.
This name must match the username set in PingFederate and be used by only one

user.

3. Click the Save icon.

Log in to OneStream with PingFederate

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Click the External Provider Sign In button.

4. Enter your PingFederate login credentials.

NOTE: If the Require Verification Code setting in the Web Server Configuration

File is enabled, you will be provided with a one-time verification code to enter in

the application. See Verification Code.

5. On the OneStream desktop application Logon screen, select an application from the drop-
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down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End
Sessionbutton.

SAML 2.0 Configuration with ADFS

To enable single sign-on with ADFS using SAML protocol, follow these steps:

1. Set Up for Single Sign-on with an External Identity Provider or Set Up for Native

Authentication and Single Sign-on with an External Identity Provider.

2. Set Up the Application Server Configuration in OneStream.

3. Set Up the Applications in ADFS.

4. Set Up the Web Server Configuration in OneStream.

5. Set Up OneStream Login with ADFS.

6. Log in to OneStream with ADFS.

Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.
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4. Click the + icon to add an item.

5. In theGeneral and External Provider Single Sign On sections, complete the following
fields:

l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: Select SamlSSO in the drop-down menu.

l External Provider Web SSO Secret Key: Enter a unique value. This key is used in
the OneStream Application Server Configuration and the OneStreamWeb Server

Configuration. It enables your application server to communicate with the web server.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.
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Set Up the Applications in ADFS

Set up the applications in ADFS for the browser and desktop application.

Modern Browser Experience

To set up the application in ADFS for the browser, you must complete these steps:

l Enter the relying party SAML 2.0 SSO service URL and relying party trust identifier in ADFS

in this format: https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the relying party SAML 2.0 SSO service

URL and relying party trust identifier exactly when you enter them in ADFS. They

must be an identical match.

l Copy the ACS URL and metadata URL from ADFS and paste them into the Web Server

Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your ADFS account.

2. On the left of the screen, open the AD FS folder, and then open the Relying Party Trusts
folder.

3. In the Actions pane on the right, in the Relying Party Trustsmenu, select Add Relying
Party Trust.

4. In the Add Relying Party Trust Wizard dialog box, on theWelcome screen, select
Claims Aware and click the Start button.

5. On the Select Data Source screen, select Enter data about the relying party manually
and click the Next button.
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6. On the Specify Display Name screen, enter a name for the application and click the Next
button.

7. On the Configure Certificate screen, click the Next button.

8. On the Configure URL screen:

a. Select Enable support for the SAML 2.0 WebSSO protocol.

b. Enter the relying party SAML 2.0 SSO service URL in this format:

https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the relying party SAML 2.0

SSO service URL exactly when you enter it in ADFS. It must be an identical

match.

c. Click the Next button.

9. On the Configure Identifiers screen:

a. Enter the relying party trust identifier in this format: https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the relying party trust identifier

exactly when you enter it in ADFS. It must be an identical match.

b. Click the Next button.

10. On the Choose Access Control Policy screen, select an option and click the Next button.

11. On the Ready to Add Trust screen, click the Next button.

12. On the Finish screen, click the Close button.

13. In the Relying Party Trusts list, right-click on the item you created, and click Edit Claim
Issuance Policy.

14. In the Edit Claims Issuance Policy dialog box, click the Add Rule button.
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15. In the Add Transform Claim Rule Wizard dialog box, on the Select Rule Template
screen, in the Claim rule template drop-down menu, select Send LDAP Attributes as
Claims and click the Next button.

16. On the Configure Rule screen, in the Claim rule name field, type Attributes. In the
Attribute store drop-down menu, select Active Directory. In the Mapping of
LDAP attributes to outgoing claim types table of drop-down menus, select these options:

a. LDAP Attribute:Given-Name andOutgoing Claim Type:Given Name

b. LDAP Attribute: Surname andOutgoing Claim Type: Surname

c. LDAP Attribute: E-Mail-Addresses andOutgoing Claim Type: E-Mail Address

17. Click the Finish button.

18. In the Edit Claims Issuance Policy dialog box, click the Add Rule button.

19. In the Add Transform Claim Rule Wizard dialog box, on the Select Rule Template
screen, in the Claim rule template drop-down menu, select Send LDAP Attributes as
Claims and click the Next button.

20. On the Configure Rule screen, in the Claim rule name field, typeWindows Account
Name. In the Attribute store drop-down menu, select Active Directory. In the Mapping of
LDAP attributes to outgoing claim types table of drop-down menus, select these options:

a. LDAP Attribute: SAM-Account-Name andOutgoing Claim Type: Name ID

21. Click the Finish button.

22. In the Edit Claims Issuance Policy dialog box, click the Add Rule button.

23. In the Add Transform Claim Rule Wizard dialog box, on the Select Rule Template
screen, in the Claim rule template drop-down menu, select Send LDAP Attributes as
Claims and click the Next button.

Installation and Configuration Guide 164

About Installation and Configuration



24. On the Configure Rule screen, in the Claim rule name field, type UpnToAppId. In the
Attribute store drop-down menu, select Active Directory. In the Mapping of
LDAP attributes to outgoing claim types table of drop-down menus, select these options:

a. LDAP Attribute: User-Principal-Name andOutgoing Claim Type: Application
Identifier

25. Click the Finish button.

26. In the Edit Claims Issuance Policy dialog box, click theOK button.

Desktop Application

To set up the application in ADFS for the desktop application, which includes the Windows Client

application and the Excel Add-In, you must complete these steps:

l Enter the relying party SAML 2.0 SSO service URL and relying party trust identifier in ADFS

in this format: https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the relying party SAML 2.0 SSO service

URL and relying party trust identifier exactly when you enter them in ADFS. They

must be an identical match.

l Copy the ACS URL and metadata URL from ADFS and paste them into the Web Server

Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your ADFS account.

2. On the left of the screen, open the AD FS folder, and then open the Relying Party Trusts
folder.
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3. In the Actions pane on the right, in the Relying Party Trustsmenu, select Add Relying
Party Trust.

4. In the Add Relying Party Trust Wizard dialog box, on theWelcome screen, select
Claims Aware and click the Start button.

5. On the Select Data Source screen, select Enter data about the relying party manually
and click the Next button.

6. On the Specify Display Name screen, enter a name for the application and click the Next
button.

7. On the Configure Certificate screen, click the Next button.

8. On the Configure URL screen:

a. Select Enable support for the SAML 2.0 WebSSO protocol.

b. Enter the relying party SAML 2.0 SSO service URL in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the relying party SAML 2.0

SSO service URL exactly when you enter it in ADFS. It must be an identical

match.

c. Click the Next button.

9. On the Configure Identifiers screen:

a. Enter the relying party trust identifier in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the relying party trust identifier

exactly when you enter it in ADFS. It must be an identical match.

b. Click the Next button.
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10. On the Choose Access Control Policy screen, select an option and click the Next button.

11. On the Ready to Add Trust screen, click the Next button.

12. On the Finish screen, click the Close button.

13. In the Relying Party Trusts list, right-click on the item you created, and click Edit Claim
Issuance Policy.

14. In the Edit Claims Issuance Policy dialog box, click the Add Rule button.

15. In the Add Transform Claim Rule Wizard dialog box, on the Select Rule Template
screen, in the Claim rule template drop-down menu, select Send LDAP Attributes as
Claims and click the Next button.

16. On the Configure Rule screen, in the Claim rule name field, type Attributes. In the
Attribute store drop-down menu, select Active Directory. In the Mapping of
LDAP attributes to outgoing claim types table of drop-down menus, select these options:

a. LDAP Attribute:Given-Name andOutgoing Claim Type:Given Name

b. LDAP Attribute: Surname andOutgoing Claim Type: Surname

c. LDAP Attribute: E-Mail-Addresses andOutgoing Claim Type: E-Mail Address

17. Click the Finish button.

18. In the Edit Claims Issuance Policy dialog box, click the Add Rule button.

19. In the Add Transform Claim Rule Wizard dialog box, on the Select Rule Template
screen, in the Claim rule template drop-down menu, select Send LDAP Attributes as
Claims and click the Next button.

20. On the Configure Rule screen, in the Claim rule name field, typeWindows Account
Name. In the Attribute store drop-down menu, select Active Directory. In the Mapping of
LDAP attributes to outgoing claim types table of drop-down menus, select these options:
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a. LDAP Attribute: SAM-Account-Name andOutgoing Claim Type: Name ID

21. Click the Finish button.

22. In the Edit Claims Issuance Policy dialog box, click the Add Rule button.

23. In the Add Transform Claim Rule Wizard dialog box, on the Select Rule Template
screen, in the Claim rule template drop-down menu, select Send LDAP Attributes as
Claims and click the Next button.

24. On the Configure Rule screen, in the Claim rule name field, type UpnToAppId. In the
Attribute store drop-down menu, select Active Directory. In the Mapping of
LDAP attributes to outgoing claim types table of drop-down menus, select these options:

a. LDAP Attribute: User-Principal-Name andOutgoing Claim Type: Application
Identifier

25. Click the Finish button.

26. In the Edit Claims Issuance Policy dialog box, click theOK button.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.
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4. Click the ellipsis to the right of SAML 2.0 Identity Provider.

5. In the SAML 2.0 Identity Provider dialog box, in theGeneral andWindows Desktop
Client Settings sections, complete the following fields:

General

l Application Server Pre-Shared Key: Enter the same value from the External

Provider Web SSO Secret Key field in the Application Server Configuration. See Set

Up the Application Server Configuration in OneStream step 5.

Browser UX Settings
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l ACS URL for Browser UX: Enter the relying party SAML 2.0 SSO service URL and
relying party trust identifier in ADFS. See Modern Browser Experience step 9. Use

this format: https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the relying party SAML 2.0

SSO service URL exactly when you enter it in the Web Server Configuration

File. It must be an identical match.

l Metadata Content for Browser UX: Enter the metadata URL from ADFS. To find

the metadata URL, in ADFS, go to AD FS > Service > Endpoints >Metadata. Copy
the URL path for the Federation Metadata. Paste that URL path to the end of the

URL to the ADFS VM.

NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.

Windows Desktop Client Settings

l ACS URL for Windows Application: Enter the relying party SAML 2.0 SSO service
URL from ADFS. See Desktop Application step 9. Use this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the relying party SAML 2.0

SSO service URL exactly when you enter it in the Web Server Configuration

File. It must be an identical match.

l Metadata Content For Native Application: Enter the metadata URL from ADFS.

To find the metadata URL, in ADFS, go to AD FS > Service > Endpoints >
Metadata. Copy the URL path for the Federation Metadata. Paste that URL path to
the end of the URL to the ADFS VM.
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NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up OneStream Login with ADFS

1. In the desktop application, go to System > Security > Users > <user>.

2. In the Authentication properties, configure the user to authenticate through ADFS.

l External Authentication Provider: In the drop-down menu, select the ADFS
configuration.

l External Provider User Name: Enter the username configured in ADFS. This name
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must match the username set up in ADFS and be used by only one user.

3. Click the Save icon.

Log in to OneStream with ADFS

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Click the External Provider Sign In button.

4. Enter your ADFS login credentials.

NOTE: If the Require Verification Code setting in the Web Server Configuration

File is enabled, you will be provided with a one-time verification code to enter in

the application. See Verification Code.

5. On the OneStream desktop application Logon screen, select an application from the drop-

down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

SAML 2.0 Configuration with Salesforce

To enable single sign-on with Salesforce using SAML protocol, follow these steps:
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1. Set Up for Single Sign-on with an External Identity Provider or Set Up for Native

Authentication and Single Sign-on with an External Identity Provider.

2. Set Up the Application Server Configuration in OneStream.

3. Set Up the Applications in Salesforce.

4. Set Up the Web Server Configuration in OneStream.

5. Set Up OneStream Login with Salesforce.

6. Log in to OneStream with Salesforce.

Set Up the Application Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Application Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In the Security section, click the ellipsis to the right of External Authentication Providers.

4. Click the + icon to add an item.

5. In theGeneral and External Provider Single Sign On sections, complete the following
fields:
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l Name: Enter the name of the identity provider. This name will display when
configuring users to their external SSO.

l Authentication Provider Type: Select SamlSSO in the drop-down menu.

l External Provider Web SSO Secret Key: Enter a unique value. This key is used in
the OneStream Application Server Configuration and the OneStreamWeb Server

Configuration. It enables your application server to communicate with the web server.

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up the Applications in Salesforce

Set up the applications in Salesforce for the browser and desktop application.

Modern Browser Experience

To set up the application in Salesforce for the browser, you must complete these steps:
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l Enter the Entity Id and ACS URL in Salesforce in this format:

https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the Entity Id and ACS URL exactly

when you enter them in Salesforce. They must be an identical match.

l Copy the ACS URL and metadata discovery endpoint from Salesforce and paste them into

the Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your Salesforce account.

2. On the left of the screen, under PLATFORM TOOLS, in the Apps list, select App
Manager.

3. Click the New Connected App button.

4. On the New Connected App page, in the Basic Information andWeb App Settings
sections, complete the following fields:

l Connected App Name: Enter a name for the application.

l API Name: Enter an API name.

l Contact Email: Enter an email address.

l Enable SAML: Select this option.

l Entity Id: Enter Entity Id in this format: https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the Entity Id exactly when you

enter it in Salesforce. It must be an identical match.

l ACS URL: Enter the ACS URL in this format: https://<domainname>/saml/sso

Installation and Configuration Guide 175

About Installation and Configuration



IMPORTANT: Follow the format listed for the ACS URL exactly when you

enter it in Salesforce. It must be an identical match.

5. Click the Save button.

NOTE: On the left of the screen, go to PLATFORM TOOLS > Apps > Connected
Apps >Manage Connected Apps to view the Entity ID and ACS URL.

Desktop Application

To set up the application in Salesforce for the desktop application, which includes the Windows

Client application and the Excel Add-In, you must complete these steps:

l Enter the Entity Id and ACS URL in Salesforce in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the Entity Id and ACS URL exactly

when you enter them in Salesforce. They must be an identical match.

l Copy the ACS URL and metadata discovery endpoint from Salesforce and paste them into

the Web Server Configuration in OneStream.

Follow these detailed instructions. Depending on the identity provider version you use, the steps

you must complete might be different.

1. Log in to your Salesforce account.

2. On the left of the screen, under PLATFORM TOOLS, in the Apps list, select App
Manager.

3. Click the New Connected App button.
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4. On the New Connected App page, in the Basic Information andWeb App Settings
sections, complete the following fields:

l Connected App Name: Enter a name for the application.

l API Name: Enter an API name.

l Contact Email: Enter an email address.

l Enable SAML: Select this option.

l Entity Id: Enter Entity Id in this format:
https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the Entity Id exactly when you

enter it in Salesforce. It must be an identical match.

l ACS URL: Enter the ACS URL in this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/

IMPORTANT: Follow the format listed for the ACS URL exactly when you

enter it in Salesforce. It must be an identical match.

5. Click the Save button.

NOTE: On the left of the screen, go to PLATFORM TOOLS > Apps > Connected
Apps >Manage Connected Apps to view the Entity ID and ACS URL.

Set Up the Web Server Configuration in OneStream

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.
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3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

4. Click the ellipsis to the right of SAML 2.0 Identity Provider.

5. In the SAML 2.0 Identity Provider dialog box, complete the following fields:

General
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l Application Server Pre-Shared Key: Enter the same value from the External

Provider Web SSO Secret Key field in the Application Server Configuration. See Set

Up the Application Server Configuration in OneStream step 5.

Browser UX Settings

l ACS URL for Browser UX: Enter the ACS URL from Salesforce. See Modern

Browser Experience step 4. Use this format: https://<domainname>/saml/sso

IMPORTANT: Follow the format listed for the ACS URL exactly when you

enter it in the Web Server Configuration File. It must be an identical match.

TIP: In Salesforce, on the left of the screen, go to PLATFORM TOOLS >

Apps > Connected Apps >Manage Connected Apps to view the

ACS URL.

l Metadata Content for Browser UX: Enter the metadata discovery endpoint from
Salesforce.

TIP: In Salesforce, on the left of the screen, go to PLATFORM TOOLS >

Apps > Connected Apps >Manage Connected Apps to view the

metadata discovery endpoint.

NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.

Windows Desktop Client Settings

l ACS URL for Windows Application: Enter the ACS URL from Salesforce. See

Desktop Application step 4. Use this format:

https://<domainname>/OneStreamWeb/OneStreamLogonCallback.aspx/
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IMPORTANT: Follow the format listed for the ACS URL exactly when you

enter it in the Web Server Configuration File. It must be an identical match.

TIP: In Salesforce, on the left of the screen, go to PLATFORM TOOLS >

Apps > Connected Apps >Manage Connected Apps to view the

ACS URL.

l Metadata Content For Native Application: Enter the metadata discovery endpoint
from Salesforce.

TIP: In Salesforce, on the left of the screen, go to PLATFORM TOOLS >

Apps > Connected Apps >Manage Connected Apps to view the

metadata discovery endpoint.

NOTE: You can add the entity ID and single sign-on URL, but they are not needed

if you entered the metadata URL from the identity provider.

6. Click theOK button.
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7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Application Server
Configuration or Web Server Configuration.

Set Up OneStream Login with Salesforce

1. In the desktop application, go to System > Security > Users > <user>.

2. In the Authentication properties, configure the user to authenticate through Salesforce.

l External Authentication Provider: In the drop-down menu, select the Salesforce
configuration.

l External Provider User Name: Enter the username configured in Salesforce. This
name must match the username set up in Salesforce and be used by only one user.

3. Click the Save icon.

Log in to OneStream with Salesforce

To log in with the browser, see theModern Browser Experience Guide. To log in with the desktop

application, follow these steps:

1. On the desktop application Logon screen, for Server Address, specify the URL or a client
connection.

2. Click the Connect button.

3. Click the External Provider Sign In button.

4. Enter your Salesforce login credentials.
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NOTE: If the Require Verification Code setting in the Web Server Configuration

File is enabled, you will be provided with a one-time verification code to enter in

the application. See Verification Code.

5. On the OneStream desktop application Logon screen, select an application from the drop-

down menu.

6. Click theOpen Application button.

NOTE: To log off, on any screen, click the Logoff icon and then click the End Session
button.

Security for Single Sign-on with External Identity
Providers

To increase security against vulnerabilities, we strongly recommend you configure single sign-on

with an external identity provider with one of the following options:

l For OpenID Connect (OIDC) and SAML 2.0 identity providers, enable a time-based one-

time password (TOTP), which requires users to enter a one-time verification code for

authentication. See Verification Code.

l For OIDC identity providers only, run a local loopback with a local redirect port. See OIDC

Local Redirect Port.

If both of these options are enabled, the local loopback will run with the designated port. The one-

time verification code will not display for users when they log in.
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Verification Code

When enabled, users are provided with a one-time verification code to enter in the application

after they have successfully authenticated with the configured identity provider. The verification

code is only valid for 30 seconds.

NOTE: If the OIDC local redirect port is also enabled, the one-time verification code will

not display for users when they log in. See OIDC Local Redirect Port.

The verification code can be enabled for the following external identity providers:

l Three OIDC identity providers:

o Azure Active Directory (Azure AD [Microsoft Entra ID])

o Okta

o PingFederate

l SAML 2.0 identity providers (for example, Okta, PingFederate, Active Directory Federation

Services [ADFS], and Salesforce)

This section includes instructions for how to configure the verification code and a description of

the login flow with a verification code.

Configure the Verification Code

By default, the Require Verification Code setting is False. To enable a one-time verification code,

update the setting to True.

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.
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3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

4. In theGeneral section, in the Require Verification Code drop-down menu, select True.

5. Click theOK button.

6. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Web Server Configuration.
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Login Flow with a Verification Code

1. On the OneStream Desktop Application Logon screen, for Server Address, specify the
URL or a client connection.

2. Click the Connect button.

NOTE: The Logon screen will look different depending on how your environment

is configured (external identity provider or both native authentication and an

external identity provider).

3. Click the External Provider Sign In button.

4. Enter your login credentials.

5. After successful authentication with the external identity provider, a one-time verification

code is provided. Copy this code.
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IMPORTANT: The verification code is only valid for 30 seconds. If the code
expires, you will need to log in again to generate a new code.

NOTE: If the OIDC local redirect port is enabled, the one-time verification code

will not display for users when they log in. See OIDC Local Redirect Port.

6. On the OneStream Desktop Application Logon screen, enter the verification code in the

field, and click the Verify button.

7. Select an application from the drop-down menu.

8. Click theOpen Application button.
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OIDC Local Redirect Port

We strongly recommend enabling a local redirect port when configuring your environment for

OIDC authentication. When enabled, a local loopback will run with the designated port.

NOTE: If the verification code is also enabled, the local loopback will run with the
designated port. The one-time verification code will not display for users when they log

in. See Verification Code.

The OIDC local redirect port can be enabled for the following external OIDC identity providers:

l Azure Active Directory (Azure AD [Microsoft Entra ID])

IMPORTANT: For Azure AD (Microsoft Entra ID) identity providers, you must

configure the app registration to issue access tokens. See Configure the

OIDC Local Redirect Port steps 9–11.

l Okta

l PingFederate

IMPORTANT: For PingFederate identity providers, you must add the OneStream
Windows App JWKS Path. See Configure the OIDC Local Redirect Port step 5.

By default, the OIDC Local Redirect Port setting is disabled (-1). You can update the field to

enable the setting and use a dynamic or specific port.

Identity
Provider

Enable OIDC Local Redirect Port

Azure AD

(Microsoft

Entra ID)

You can enter 0 for a dynamic port assignment or any number from 1024 through

65535 to specify the port. A dynamic port helps to prevent the risk of port conflicts

if multiple sources attempt to use the same port at the same time.
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Identity
Provider

Enable OIDC Local Redirect Port

Okta You must specify the port. Enter any number from 1024 through 65535.

PingFederate You must specify the port. Enter any number from 1024 through 65535.

Configure the OIDC Local Redirect Port

1. Open theOneStream Server Configuration Utility application.

2. Go to File > New Web Server Configuration File.

NOTE: Alternatively, you can open an existing file to edit it.

3. In theWeb Server Configuration Settings section, click the ellipsis to the right of Single
Sign On Identity Provider.

4. In theOIDC Compliant Provider Settings section, next toOIDC Local Redirect Port,
enter the value to use a dynamic port (0), specify a port (1024–65535), or disable the

feature (-1).
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5. For a PingFederate identity provider, enter theOneStream Windows App JWKS Path.
For Azure AD (Microsoft Entra ID) and Okta identity providers, go to step 6.

a. In the Identity Provider Specific Settings section, click the ellipsis to the right of
PingFederate Identity Provider.
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b. In theWindows Desktop Client Settings section, in theOneStream Windows
App JWKS Path field, enter the JWKS endpoint path from PingFederate, which is

the path on the PingFederate server that publishes a JSON Web Key Set.

Example: OneStreamWindows App JWKS Path:

/ext/oauth/jwks

6. Click theOK button.

7. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Web Server Configuration.

8. Update the redirect URI on your identity provider to reference the value for the OIDC local

redirect port entered in step 4.

Example: If you entered 0 for dynamic port assignment,
the redirect URI would be: http://localhost/callback
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Example: If you entered 12345 for a specific port, the
redirect URI would be: http://localhost:12345/callback

9. For Azure AD (Microsoft Entra ID) identity providers, in the identity provider app registration

for the Windows application:

a. Select Access tokens (used for implicit flow) to enable the identity provider to
issue access tokens.

b. Add a custom scope for the app registration.

10. For Azure AD (Microsoft Entra ID) identity providers:

a. In theOneStream Server Configuration Utility application, go to File >Web
Server Configuration File > Single Sign On Identity Provider > Azure Identity
Provider.

b. In theGeneral section, in the Azure OpenID Connect Scopes field, add the custom
scope from the app registration created in step 9b.

IMPORTANT: Add the custom scope from the app registration to the Azure

OpenID Connect Scopes field. Do not replace existing scopes. See the

following image for example.
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c. Click theOK button.

d. Save changes and reset IIS.

NOTE: Reset IIS after you save any changes to the Web Server

Configuration.

11. For Azure AD (Microsoft Entra ID) identity providers:

a. In the identity provider app registration for the Windows application, inManifest, find
accessTokenAcceptedVersion.

b. Set the value to 2 and save.
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Installation Overview
The following sections identify the basic tasks you will perform to install the product.

Step 1: Install the Application Servers

1. New installations: Review the requirements.

2. Install the My Company Name, LLC Servers Installation Package on each application

server. Perform a Custom Install and clear theWeb Server optional component.

Step 2: Install the Web Servers

1. Install the My Company Name, LLC Servers Installation Package on each application

server.

2. Select Custom Install and clear the App Server & Database Configuration Utility
optional components.

Step 3: Create Database Schemas and Connection Strings

1. As an Administrator, run the Database Configuration Utility on one of the application

servers.

2. Create the database schemas:

a. Create an empty Framework database and its tables.

b. Create an empty Application database and its tables.

c. Create an empty State database (tables are created by the application).
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3. Configure and export connection strings:

a. Modify the Framework connection string (Advanced Options). Set Pooling, Max Pool,

and Connection timeout values.

b. Click Tools to export the encrypted connection string to an XML file. This file is
imported to application server configuration file.

Step 4: Configure the Application Servers

1. As an Administrator, run the Server Configuration Utility on one of the application servers.

2. Create an application server configuration file (XFAppServerConfig.xml) in the file share in

a folder called ConfigurationtFiles.

3. Import the encrypted database connection string file you created in step 3.

4. Follow the application server configuration process.

Step 5: Configure the Web Servers

1. As an Administrator, run the Server Configuration Utility on one of the web servers.

2. Create a Web Server Configuration file (XFWebServerConfig.xml) in the file share under a

folder called ConfigurationFiles.

3. Follow the web server configuration process.

Step 6: Test

1. Make sure that any firewalls are OFF or that exceptions were added for My Company

Name, LLC port traffic.

2. Launch the web server: 

http://<Servername>:50001/OneStreamWeb/OneStreamXF.aspx.
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Step 7: Log onto the Framework Database (System
Administration)

Username: Administrator

Password: OneStream

Step 8: Add Application References

Select Applications and create a reference to the application database created in Step 3 "Create
Database Schemas...".
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Installing Server and System
Components

Installing the OneStream Servers Package
This is the primary OneStream installation package.  This is a wizard-based package used to

install a Complete server setup that includes the web server, application server and all utilities. A

Custom install allows the appropriate components to be selected for the server type being built. 

Building an All-In-One Server (Combined Web and
Application Server)

To build an All-In-One Server, follow the installation wizard prompts and select the Complete

installation option.  This will instruct the wizard to install all server components required for a

server to function as both a web and application server.

Building an Application Server

To build an Application Server, follow the installation wizard prompts and select the Custom

installation option. 

Next, only select the following installation options:

Application Server

Server Configuration Utility
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This will instruct the wizard to install all server components required for a server to function as an

Application Server.

Building a Web Server

To build a Web Server, follow the installation wizard prompts and select the Custom installation

option.

Next, only select the following installation options:

Web Server

Server Configuration Utility

Rest API (optional)

This will instruct the wizard to install all server components required for a server to function as a

Web Server.

Database Configuration Utility

The Database Configuration Utility is a component that can be installed on any server and is used

to access and configure the SQL Server database server used to host the OneStream system

databases.

This utility was purposely kept separate from the Server Configuration Utility to allow for

separation of duties between IT resources.  The Database Configuration Utility can be installed for

database administrator personnel only if desired and the resulting database connecting

information can be delivered to the application server administrator personnel via an XML file

containing encrypted database connection string information.  For more details on this utility, see

Configuring System Components. 
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Uninstalling the OneStream Servers
Package

1. Click Control Panel > Programs > Uninstall a Program and search for the OneStream

items to remove.

2. Right-click items and select Uninstall.

Uninstall and Re-install on Another Drive
1. Confirm the configuration in a few additional areas in IIS. Once the new drive is installed, go

into Internet Information Services (IIS) Manager:

2. Click the OneStream App Server Site and choose Advanced Settings on the right side. In
the pop-up window, confirm the Physical Path is correct and, if not, update it accordingly.

3. ClickOneStreamApp and choose Advanced Settings on the right side. Confirm the

physical path is correct or update it.
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4. Recycle the App Pool, recycle IIS and test.

Installing the Application Server
NOTE: Refer to the Configuring System Components in the Installation and

Configuration Guide before proceeding with this section.

1. Launch OneStream Server Setup.msi by right-clicking and choosing Install.
This launches the Installation Wizard Welcome Screen.

2. Click Next to continue the installation operation.
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3. Select the Custom setup type and click Next.

4. Install the Application Server only, click Application Server and chooseWill be installed on

local hard drive. Repeate for Server Configuration Utility. Click Next.
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NOTE: (Optional) We recommend that the Database Configuration Utility be

installed on the Application Server.
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6. If needed, change the folder path and click Next.

7. Click Install to begin the installation.
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8. Click Finish to complete the installation.

Configuring the Application Server
For more information regarding configuration, refer to the Configuration section of this guide.

TIP: Create a central location, C:\OneStreamShare\Config for example, accessible for
all server configurations. Save the XFAppServerConfig.xml and
XFWebServerConfig.xml there.

1. Launch the OneStream Server Configuration Utility using Run As Administrator.

Go to Start > OneStream Software > OneStream Server Configuration Utility. Right-
click and choose Run as Administrator.

2. Update the OneStream Application Server ASP.NET configuration file to point to the

location of the OneStream Application Server Configuration File in the environment.
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a. Choose File > Open ASP.NET Configuration File.

b. Browse to the following location: <installdrive>\Program Files\OneStream

Software\OneStreamAppRoot\OneStreamApp, select the appsettings.json file and
clickOpen

.
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c. Update the path to the file location of the shared OneStream Application Server

Configuration File (XFAppServerConfig.xml). For example,

C:\OneStreamShare\Config.

d. Enable HTTP and/or HTTPS as needed

e. Save the configuration file.
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Update the Application Server IIS Settings using
Configure IIS Tool

1. Choose Tools > Configure IIS.

2. Enter the following values:

l Web Site Name: OneStream App Server Site

l Application Pool Name: OneStreamAppAppPool
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3. Check Update IIS Default Settings.

4. Select Use App Server Settings.

5. Check Update IIS Identity.

6. Set the User Account Type to the proper value from the drop down list. (It should be

“Custom Account” if using a domain service account.)

a. UserName: Enter the OneStream Service Account as (Domain\UserName).

b. Password: Enter the Password.

7. Click Update IIS Settings to set the IIS Application Pool settings and clickOK.

8. Click Reset IIS to recycle IIS.

NOTE: You can also recycle IIS by stopping and restarting the web server in IIS,

or by using an IISRESET Command via an administrator command prompt.

NOTE: If users do not use the “Configure IIS” utility to set the settings for the OneStream
App Server, they will need to make sure that they:
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l Manually update the username in IIS.

l Set Ping Enabled to False.

l Set the following settings for the application server Website and AppAppPool:

Start Mode: Always Running

PreLoad Enabled: True on the OneStream App Server Site
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Preload Enabled True on the OneStreamApp registration:
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Installing the Web Server
NOTE: See Configuring System Components on in the Installation and Configuration

Guide before proceeding with this section.

1. Launch OneStream Server Setup.msi by right-clicking and choosing Install.
This launches the Installation Wizard Welcome Screen.

2. Click Next to continue with the installation operation.

3. Select Custom as the setup type.
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4. To install the Web Server only, clickWeb Server and chooseWill be installed on local
hard drive. Repeat for Server Configuration Utility. Click Next.
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6. Change the folder path, if needed, and click Next.

NOTE: The default installation path is C:\Program Files\OneStream Software.

Select Change to change the drive for the installation. For example, D:\Program

Files\OneStream Software.

7. Click Install to start.
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8. Click Finish to complete the installation.
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Configuring the OneStream Web Server
Update the OneStreamWeb Server IIS Settings using Configure IIS Tool

1. Choose Tools > Configure IIS.
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2. Enter the following values:

a. Web Site Name: OneStreamWeb Server Site

b. Application Pool Name: OneStreamWebAppPool

3. Check Update IIS Default Settings.

4. Select Use Web Server Settings.

5. Check Update IIS Identity.

6. Set the User Account Type to the proper value from the drop down list. (It should be

“Custom Account” if using a domain service account.)

a. UserName: Enter the OneStream Service Account as (Domain\UserName).

b. Password: Enter the Password.

7. Click Update IIS Settings to set the IIS Application Pool settings and clickOK.

8. Logon to each OneStreamWeb Server in the environment.

9. Browse to C:\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb

10. Locate the OneStreamWeb.runtimeconfig.json file and open this file in a text editor.

11. Update the Config Properties section with the following line:

"System.Threading.ThreadPool.MinThreads": 128

"configProperties": {
      "System.GC.Server": true,
      "System.Reflection.Metadata.MetadataUpdater.IsSupported": false,
      "System.Runtime.Serialization.EnableUnsafeBinaryFormatterSerialization": false,
      "System.Threading.ThreadPool.MinThreads": 128
    } 

NOTE: Be sure to place a comma ahead of the previous line as shown above.
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12. Save the file for the change to take effect

13. Click Reset IIS to recycle IIS.

NOTE: You can also recycle IIS by stopping and restarting the web server in IIS,

or by using an IISRESET Command via an administrator command prompt.
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Client Options and Installation
Guide
This section provides an overview of OneStream's client options and the required installation

process, while giving guidance in choosing the proper software configuration and requirements

for deployment.

Overview
The Client Installation and Configuration guide provides an overview of the OneStream client

applications and the installation process. It also provides guidance in choosing the proper

software configuration along with requirements for deployment. Information technology

professionals who are responsible for installing, maintaining, and supporting the OneStream

platform will find this guide especially useful.

Client Software
You can install OneStream client applications onWindows PCs. After the installation is complete,

you can log into the application with your related credentials.

OneStream for Desktop

OneStream for Desktop is a standalone browser-less application for administrators and end-users

to access OneStream. The application includes a spreadsheet feature with the potential to

eliminate the need for an Excel Add-in which requires administrative rights to install on your

desktop.
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OneStream Excel Add-In

The OneStream Excel Add-In provides ad hoc querying and reporting, data analysis, data entry,

and formatted reports inside of Microsoft Excel. The Excel Add-In lets you perform Excel-based

analysis on OneStream data.
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Planning the Installation
This section describes requirements and configurations for the client workstations.

Hardware and Software Requirements
The following table presents a list of hardware and software requirements.

NOTE: The Modern Browser Experience is Generally Available on OneStream Platform

Version 8.4 or later.

Application Server

Software Supported

Operating Systems Windows Server 2022, v10.0

Windows Server 2019, v7.0

Internet Information Server (IIS) Windows Server 2022 - IIS 10.0

Windows Server 2019 - IIS 7.0

.NET .NET 8 Desktop Runtime 8.0.2 or greater

.NET 8 Hosting Bundle 8.0.2 or greater

Database Server
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Software Supported

Operating Systems Windows Server 2022 (Recommended)

Windows Server 2019

Additional Software SQL Server 2017

SQL Server 2019

SQL Server 2022

Client Workstation

Software Supported

Operating Systems Windows 11, 22H2+, 64-bit

Windows 10, 20H2+, 64 bit

.NET .NET 8 Desktop Runtime 8.0.2 or greater

MS Office Office 365 64-bit

Office 2019 (or higher) 64-bit

Web Browser Microsoft Edge v126+ (when using ClickOnce)

Google Chrome v126+

Apple Safari v17.5+
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Hardware Recommended

Screen Resolution 1920 x 1080 (Recommended minimum)

Devices Supported

Tablet iPadOS, v16.x

Android, v13

Phone iOS, v16.x

Android, v13

Workstations macOS, Big Sur

NOTE: These are the additional devices that the Modern Browser Experience supports.

Smart Integration Connector Local Gateway Server

Software Supported

Operating Systems Windows Server 2022 (Recommended)

Windows Server 2019

.NET .NET 8.0

Typical workloads are managed by a Server/VM with 8-16G RAM and 2 newer CPUs
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Display Settings
OneStream Platform and Solutions frequently require the display of multiple data elements for

proper data entry and analysis. Therefore, the recommended screen resolution is a minimum of

1920 x 1080 for optimal rendering of forms and reports.

Additionally, you should adjust the Windows System Display text setting to 100%. Do not apply

any Custom Scaling options.

Installation Packages
The Client Software zip package that contains client installers can be downloaded from the

OneStream Solution Exchange. Select your platform version, download the Client Software

package, and unzip the files to your desired directory using a zip file extraction program.
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OneStream for Desktop
There are different considerations to think about when installing the OneStream Desktop

application. This section will cover those considerations as well as installation and deployment

procedures, upgrading, and uninstalling.

Considerations
You can deploy OneStream for Desktop using two different methods: ClickOnce and traditional

installation using an Installer file. Both methods are outlined in the table below. Organizations can

choose their preferred method to distribute the application to end-users and their machines.

ClickOnce Installer

End-User Deployment Web page Manual

distribution of

the installer file

or remote

installation by

an admin.
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ClickOnce Installer

Type of install Temporary installation. The

applicationdoes not appear in the Start

menu or Add or Remove programs, but

you can create a web shortcut on the

desktop for easy access.

Traditional

installation.

The application

appears in

Start menu and

Add or Remove

programs.

Package size ~220MB with 325 files ~220MB with

325 files

Requires local administrator No No for per-user

installs. Yes for

per-machine

installs.

Upgrades Auto-upgrades on launch. Manual

upgrade with

installer file.

Use multiple versions on the

same machine

No; possible only if the other version is a

traditionalinstall.

Yes

Connect to different servers

from a single installed

instance

No Yes
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Deployment using ClickOnce
Use ClickOnce deployment to download and start the OneStream Desktop application from a web

page using a Windows shortcut. When you deploy through ClickOnce, the client automatically

downloads and starts a OneStream Desktop application version that matches the version of the

OneStream server software.

The ClickOnce deployment method is ideal for customers and users who:

l Want easier deployment and automatic upgrades.

l Can use the ClickOnce technology in their organization or industry.

l Would like to limit IT’s involvement in deploying and upgrading the application.

l Do not have to connect to multiple versions of the application at the same time.

Considerations
When using ClickOnce deployment, consider the following:

l Every client machine running ClickOnce must have .NET 8 Desktop Runtime Installed.

l The client is deployed to the AppData folder located in your profile
C:/Users/<username>/AppData/Local/Apps/2.0/<Windows Assigned

GUID>. The location is controlled by Windows and .NET. Deploying to the local profile lets

users who are not local administrators download and start the application.

l ClickOnce does not work with Citrix. The workaround for this is a traditional installation.

Contact your IT support or add OneStream's URLs as trusted sites in Cisco Umbrella, Z

Scaler, or proxy.
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Create a ClickOnce Shortcut
To create a ClickOnce shortcut on your desktop:

1. In the Microsoft Edge browser, go to the company's specific OneStream URL to open the

OneStream Desktop application.

Example:
https://<customer>.onestreamcloud.com/OneStreamWe

b/OneStreamWindowsApp.aspx

2. ClickOpen. You are automatically redirected to the URL of the launching server which
opens the OneStream Desktop application.

3. In the OneStream Desktop application., click Create Windows Shortcut. A shortcut to the

application is saved on your desktop.
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Open the Desktop Application with a
ClickOnce Shortcut

To open the OneStream Desktop application without going to the website, double-click the

ClickOnce shortcut.

NOTE: ClickOnce shortcuts created using OneStream version 8.5 and earlier may not

show the OneStream logo on the shortcut. This may be caused by updated group policy

settings on the computer. For additional information, refer to KB0012987.

Installation Using the Installer
OneStream for Desktop is offered as two different downloadable installers: EXE and MSI.

EXE Installer MSI Installer

User without

local admin

rights

Yes, a per-user

installation

Yes, a per-user installation.

User with

local admin

rights

Yes, a per-

machine or per-

user installation

Yes, when using elevated Command Prompt or

PowerShell. Installs a per-user installation if the MSI

file is opened directly.

Install

multiple

versions

Yes Yes, when using Command Prompt or PowerShell.
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A per-user installation allows only the user who installs it to run OneStream Desktop on the

computer on which it is installed. A per-machine installation allows any user to run the application.

The default installation location for a per-user installation is

C:\Users\<userid>\AppData\Roaming\Apps\OneStream Software. The default installation

location for a per-user installation is C:\Program Files (x86)\OneStream Software.

This deployment strategy is preferred by customers and users who:

l Cannot use the ClickOnce technology in their organization or industry.

l Have to connect to multiple versions of the application at the same time.

l Frequently have to connect to different environments of the same version.

Install OneStream Desktop Using the Install Wizard
1. Double-click the OneStream Desktop MSI or EXE installer file to launch the wizard.

2. Click Next.

3. Accept the terms of the license agreement and click Next.

4. If necessary, change the folder path, then click Next.

5. Click Install.

Install Multiple Desktop Versions
A common scenario that requires more than a single version of OneStream Desktop installed on

the same computer is when your company has set up a testing environment with a new version of

the application prior to upgrading production servers. You might need to install an additional

instance of OneStream Desktop on your computer to test the new version and still maintain

access to the current version.
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You can install up to eight instances of the desktop application on a single computer. Each

installation instance has a specific named instance embedded in the installer: 0, I2, I3, I4, I5, I6,

I7, I8.

Each instance also has a corresponding name in the installation folder and shortcut. The default

instance is named 0 and does not have a corresponding change to the installation folder or

shortcut. For example, I2 has a shortcut name of OneStream Desktop (2).

NOTE: More than one user can have the same named instance installed. But with a per-
machine installation, you must use a named instance that is unique among all users on a

machine. The installation attempt will fail if all eight instances are already claimed.

Install Additional Desktop Application Instances
1. Double-click the OneStream Desktop EXE installer file to launch the wizard.

2. Click Next.

3. Select one of the following:

l Install for all users: installs the application for all users on the computer

l Install for just me: installs the application only for the current user

4. Click Next.

5. Click Next again to begin the installation. The instance number is indicated in the title.

6. Accept the terms of the license agreement and click Next.

7. If necessary, change the folder path, then click Next.

8. Click Install.

9. Click Finish to complete the installation.
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Upgrade OneStream for Desktop
To upgrade to a new version of the application:

1. Double-click the newer version of the OneStream Desktop installer EXE file.

2. Click Next. The installer recognizes that a prior version already exists and informs you that
an upgrade will be performed.

3. Click Upgrade.

Uninstall OneStream for Desktop
If you are not a local administrator, you can only uninstall your own per-user installation. If you are

a local administrator, you can uninstall per-machine installations.

To uninstall the application:

1. Close the OneStream Desktop application.

2. Open Add or Remove Programs.

3. From the list of installed applications and features, selectOneStream Desktop.

4. Click Uninstall and follow the onscreen instructions.

Use the Command Line
If you are an IT administrator, you can install, upgrade, or uninstall the application using the

installer file via the command line.

To run the MSI file via the command-line, use the following steps as a guide:
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1. Locate the MSI installer file.

2. Press and hold SHIFT, right-click on the file, and select copy to copy its path.

3. From the Start menu, right-click on the command prompt or Windows PowerShell and

select Run as Administrator.

4. In the command prompt or Windows PowerShell, use standard MSI command line

parameters, along with the file path, to customize the installation as needed.

The following table shows examples of the most useful command line options.

Purpose Syntax Example

Normal installation

or upgrade

process using the

full install wizard

msiexec /i "C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi"

Perform a silent

install or upgrade,

no user interaction

required

msiexec /i "C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi" /quiet

Perform an

unattended install

or upgrade, the

installation only

shows a progress

bar

msiexec /i "C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi” /passive
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Purpose Syntax Example

Uninstall the

package

msiexec /x "C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi"
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Excel Add-In
The OneStream application is integrated with Microsoft Excel, which can be used for ad hoc

querying/reporting, analysis, data entry, and formatted reports. Excel can also be used with Cube

Views. See Excel Add-In.

Considerations
Refer to the following table for guidance to consider when installing the Excel Add-In.

Installer Deploment

Operating system Windows

Type of install Traditional installation. The application appears

in the Start menu and Add or Remove programs.

End-User Deployment Manual distribution of the installer file or remote

installation by an administrator.

Requires local administrator Yes

Version upgrade Manual upgrade with installer file, or via

OneStream Desktops Client Updater.

Use multiple version on the same

machine

No
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Installer Deploment

Connect to different servers from single

installed instance

Yes

Changes are required to the Windows registry to properly install the OneStream Excel Add-In.

You must have permissions to update the registry when performing installations. Changes that

are made to the Windows registry are made only for the person who is performing the installation.

For example, if an IT professional is logged into your machine to perform the installation, you will

not be able to access the OneStream Excel Add-In. The registration process of the Excel Add-In

requires certain Microsoft .NET Framework rights to execute a program in the

C:\Windows\Microsoft.NET\Framework folder (or Framework64 if you are running the 64-bit

version of Excel).

If you have Excel 2003 or another prior version installed before Excel 2010 or greater, and you

have uninstalled the older version of Excel, the newer version of Excel and the OneStream Excel

Add-In will need to be uninstalled and then reinstalled.

Other Office Add-Ins may conflict with the Excel Add-In. Therefore, discuss this and other

installation issues with OneStream support.

Install the Excel Add-In
Install the Excel Add-In using the standard install wizard:

1. Double-click the Excel Add-In installer file.

2. Click Next.

3. Accept the terms of the license agreement and click Next.
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4. If necessary, change the folder path, then click Next.

NOTE: The default installation path is C:\Program Files\OneStream Software. If

you need to change the drive path, click Change. For example, D:\Program
Files\OneStream Software.

5. Click Install.

6. Click Finish to complete the installation.

Upgrade the Excel Add-In
You can upgrade the Excel Add-In client in either of two methods: using the installer wizard or

using the Desktop Client Updater.

Installer Wizard

Upgrade to a new version using the standard install wizard:

1. Double-click the newer version of the Excel Add-In installer MSI file.

2. Click Next.

The installer recognizes that a prior version already exists and informs you that an upgrade

will be performed.

3. Click Upgrade.

OneStream for Desktop Client Updater

You can use the Client Updater, located on the Administrator tab of the OneStream application, to

upgrade the Excel Add-In. It retrieves updated software from the OneStream server when

versions do not match the current version of OneStream found on the server.
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There are a few prerequisites necessary prior to upgrading:

l You need write access to the installation folder.

l The Client Updater functionality must be enabled in the application server. Set the following

to True: Application Server Configuration >OneStream Environment > Can Use
Client Updater.

l You need to be assigned to the ClientUpdaterPage security role.

Upgrade the Excel Add-In:

1. Close all instances of Excel.

2. Launch OneStream for Desktop and log in.

3. On the Application tab, click Client Updater.

If the server version is different from the currently installed Excel Add-In, you will see a

message that an update is available.

4. Click Update.

When the server version and the Excel Add-In version match, you will see a message that

your Excel Add-In is up to date.

NOTE: A backup folder with files for the outdated version is automatically created

and saved as part of the update process. It can be found in the same location as

the newly updated version folder.

Troubleshooting

If you are attempting to update the Excel Add-In, you might receive the following error message:

"The Client Updater has been disabled by your System Administrator. Please use OneStream’s

full client installation program, or see your System Administrator."
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This indicates that the Client Updater is disabled. The system administrator must enable the

Client Updater, or you must use the Excel Add-In MSI installer file instead.

Uninstall the Excel Add-In
NOTE: Only local administrators can uninstall the Excel Add-In.

1. Save any open workbooks and close Excel.

2. Open Add or Remove Programs.

3. In the list of Apps and Features, selectOneStream ExcelAddIn.

4. Click Uninstall and follow the onscreen instructions.
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Use the Command Line
If you are an IT administrator, you can install, upgrade, or uninstall the application using the

installer file via the command line.

To run the MSI file via the command-line, use the following steps as a guide:

1. Locate the MSI installer file.

2. Press and hold SHIFT, right-click on the file, and select copy to copy its path.

3. From the Start menu, right-click on the command prompt or Windows PowerShell and

select Run as Administrator.

4. In the command prompt or Windows PowerShell, use standard MSI command line

parameters, along with the file path, to customize the installation as needed.

The following table shows examples of the most useful command line options.

Purpose Syntax Example

Normal installation or

upgrade process using the

full install wizard

msiexec /i

"C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi"

Perform a silent install or

upgrade, no user

interaction required

msiexec /i

"C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi" /quiet
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Purpose Syntax Example

Perform an unattended

install or upgrade, the

installation only shows a

progress bar

msiexec /i

"C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi” /passive

Uninstall the package msiexec /x

"C:\Users\UserName\Downloads\OneStream_Client_

7.0.1\OneStreamDesktop\en-us\Setup.msi"

Installation and Configuration Guide 241

Use the Command Line



Side by Side Install
With OneStream Desktop 7.0.0, you can install the application alongside previous versions of the

software.

There are several circumstances when you may need to use more than one version of the

application. The most common scenario is that your company is planning to upgrade to a newer

version, so a test environment is created with the new version to verify migration. To test this new

version and maintain access to the current version, you need to install another instance of the

application.

The application can only communicate with the back-end servers of the same version. This

ensures that all the features of the application have been properly tested, and that unsupported

scenarios cannot be introduced by upgrading only a portion of the system.

The new MSI based installer does not recognize or interact with the previous InstallShield based

installer. All versions of OneStream Desktop prior to 7.0.0 must be handled independently.

OneStreamDesktop 7.0.0 may be installed while previous versions remain on the machine.

Installation Scope
OneStream Desktop can be installed for the current user only (per user), or for all users on the

machine (per machine). Installing per machine requires administrative privileges and makes the

application available to all users on the machine. Installing per user can be done by any user, and

will not affect any other user of the machine.
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Named Instances
The application installer, setup.msi, can be installed up to eight times on a single machine. Each

installation instance has a specific name embedded in the installer. These names are:

l 0

l I2

l I3

l I4

l I5

l I6

l I7

l I8

Each instance has a corresponding name in the installation folder and shortcut. For example, I2

has a shortcut name of OneStream Desktop (2). The default instance is named 0 and does not

have a corresponding change to the installation folder or shortcut.

NOTE: More than one user can have the same named instance installed.

NOTE:With a per machine installation, you must use a named instance that is unique

across all users on a machine. It is possible that all eight instances may already be

claimed and the installation attempt fails.
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Installation
Installing multiple instances of OneStream Desktop on a machine requires understanding both

the impact of the different installation scopes, and a knowledge of what has already been installed

on the machine, including what per user instances have been installed by other users. To simplify

the process, there is a PowerShell script provided (setup.ps1) that can handle gathering all of

the necessary information and execute the installer with the correct configuration.

To execute a per machine installation, you must open an elevated (admin) PowerShell. Executing

the script in a non-elevated PowerShell will execute a per user installation.

If there are no existing installations when you execute the script, no message is displayed and the

installer is immediately launched with the default named instance. If there are one or more

installations already on the machine, the script provides a series of prompts to guide you through

the installation process.

The following examples provide further information to help understand how to use the script in

different scenarios.

Non-Elevated, Per Machine Only

In this example, the script is running in a non-elevated PowerShell (per user). There is one

existing per machine installation.
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First, all existing instances are listed. The list of known installations is the combination of all per

machine installs, plus all per user installs for this user. The asterisk (*) signifies that the installation

is a per machine install, and that it cannot be modified because that would require running in an

elevated PowerShell.

The only operation that you can perform is to install a new instance of OneStream Desktop, so

that is the prompt.

Non-Elevated, Complex

In this example, the script is running in a non-elevated PowerShell. There are a combination of

both per machine and per user installs already on the machine.
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There are four existing installations of OneStream Desktop. The first and fourth installs are per

machine, and therefore cannot be modified in a non-elevated PowerShell. The second (I2) and

third (I3) instances are per user, and can be modified in the current PowerShell. Typing ‘m’ and

pressing Enter to maintain an instance will prompt you to select which installation to modify. Only
modifiable instances have a number at the beginning of the list to choose. Typing ‘1’ and pressing

Enter will launch the installer for the selected instance.

If you want to install a new instance, type 'i' at the first prompt and press Enter to launch a new per

user installation.

Elevated, Per Machine Only

This example is the same as the Non-Elevated, Per Machine Only example from an elevated

PowerShell.
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Because the PowerShell is elevated, the existing install can be maintained. Selecting ‘i’ from the

first prompt will install a new per machine instance, while selecting ‘m’ will prompt you for which

instance to maintain, which will then launch the installer for that instance.

Elevated, Complex

This is the same as the Non-Elevated, Complex example.
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All instances are numbered, meaning in this elevated PowerShell, any of the installs can be

modified. The per machine installs are still marked with an asterisk (*).

Advanced Installation
The OneStream Desktop installer is a standard MSI file, and common command-line attributes

are available. You can perform advanced installations using the msiexec.exe tool that is deployed

with Windows operating systems.

To perform a silent installation, use the /qn command-line parameter. This triggers an install that

does not show a user interface, and installs using defaults.

To install a specific named instance you must set two properties. MSINEWINSTANCE=1 is always

required, regardless of which named instance is installed. The second property is

TRANSFORMS=":<instance name>", where <instance name> is I2-I8.

Installation and Configuration Guide 248

Side by Side Install



There are a number of command parameters that can be used, followed by the name of the MSI

file. The /i command is to install, and the /x command is to remove.

The /l parameter, followed by a log file name, enables logging. There are various levels of

verbosity, which you can find in the msiexec documentation. The most verbose option would be

/l*v <file.log>.

The following example would launch the installer with the full user experience, and log everything

to a file:

msiexec.exe /i setup.msi /l*v setup.log

This example performs a silent install of the 3rd named instance (or maintains it if already

installed):

msiexec.exe /i setup.msi MSINEWINSTANCE=1 TRANSFORMS=":I3" /qn

NOTE: Don’t forget the colon in the TRANSFORMS property.

NOTE: If you are using PowerShell and press the Tab key to autocomplete the name of
the MSI, it will insert ‘.\’ in front of your MSI file name. This will not work and those

characters must be removed.

NOTE: Installation scope is still relevant when performing an advanced installation. To
install per machine, the advanced command-line must be performed in an elevated

context.
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Silent Install
To silently install from the command prompt:

For Excel Add-In enter:

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamExcelAddin\en-us\Setup.msi" /qn

For Excel Add In with a log file:

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamExcelAddin\en-us\Setup.msi" /l*v C:\Temp\msilog.txt /qn

For Desktop Application:
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C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" /qn

For Desktop Application with a log file:

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" /l*v C:\Temp\msilog.txt /qn

For more than one Desktop Application or side-by-side up to eight instances:

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" MSINEWINSTANCE=1 TRANSFORMS=":I2"

/l*v C:\Temp\msilog.txt /qn

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" MSINEWINSTANCE=1 TRANSFORMS=":I3"

/l*v C:\Temp\msilog.txt /qn

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" MSINEWINSTANCE=1 TRANSFORMS=":I4"

/l*v C:\Temp\msilog.txt /qn

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" MSINEWINSTANCE=1 TRANSFORMS=":I5"

/l*v C:\Temp\msilog.txt /qn

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" MSINEWINSTANCE=1 TRANSFORMS=":I6"

/l*v C:\Temp\msilog.txt /qn

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" MSINEWINSTANCE=1 TRANSFORMS=":I7"

/l*v C:\Temp\msilog.txt /qn

C:\>msiexec /i "C:\OneStreamVersions\12345\Release

7.0.0\OneStreamDesktop\en-us\Setup.msi" MSINEWINSTANCE=1 TRANSFORMS=":I8"

/l*v C:\Temp\msilog.txt /qn

NOTE: The default instance is 0, and the subsequent installs are I2, I3, I4, I5, I6, I7, I8
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Silent Uninstall
To silently uninstall from the command prompt:

C:\>msiexec /x "C:\OneStreamVersions\12345\Release 7.0.0\OneStreamExcelAddin\en-us\Setup.msi" /qn
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Appendix: Configuration Checklist

Prepare the Service Accounts
1. Create the IIS Application Pool Service Account used for inter-server communication.

Ensure full access to the application server file share.

2. Create the SQL Server Native User Account (Preferred), enabling the Public and DBOwner

roles required for databases.

3. Enable the Public and DBOwner server roles required for the SQL Server Master Database.

OneStream uses partitioning with other advanced SQL Server features which require SQL Server

to make updates to the Master Database during the schema creation process.

SQL Server Database Connection String

Use Pooling

True

Connection Pool Limit

3000

Connection Timeout

60

Installation and Configuration Guide 253

Appendix: Configuration Checklist



Application Server(s)

1. IIS Application Pool Advanced Settings (OneStreamAppAppPool)

2. Identity = Service Account

3. Configuration File

4. Specify file share path.

5. Update ASP.Net Configuration File

6. Specify Shared Application Server Configuration File Path

NOTE: Configuration file must be named XFAppServerConfig.xml

Web Server(s)

1. IIS Application Pool Advanced Settings (OneStreamWebAppPool)

2. Identity = Service Account

3. Configuration File

4. Application Server Cluster

5. Update ASP.Net Configuration File

6. Specify Shared Web Server Configuration File Path

Note: Configuration file must be named XFWebServerConfig.xml
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Appendix: Performance
Optimization Checklist

Database Server Memory
Get better performance by providing a significant amount of RAM to the database server to allow

the SQL Server to cache large portions of a database. Memory requirements depend on each

client’s application specifications.

Database File IO
This spreads My Company Name, LLC database files across multiple disks.

Database Authentication
For better performance, consider using SQL Server authentication rather than Windows

integrated authentication, which showed a 15-25% performance decline in testing. This is due to

the high degree of multi-threading used by OneStream causing many database connections to be

created simultaneously and requiring many database connection authentication calls.

Database Properties
Enable Autogrowth for all database files and use ten Megabytes. See

http://support.microsoft.c om/kb/315512
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Database Instance Tuning

SQL Server Memory Parameters

Max Server Memory (In MB) (Recommend Value = [Server RAM – 2GB])

Database Server

Performance testing shows significant improvements with SQL Server over base 2016, so we

recommend SQL server 2012, 2014,2016, 2017, 2019 Enterprise Edition.

Application Server

Create separate application servers for each server type.

General Server:

l High Server Demands (Concurrency)

l User interface request, queries, and reports

Stage Server:
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l High Server Demands (Mapping)

l Data loading and transformation

l May use significant amounts of CPU time and RAM.

Consolidation Server:

l High Server Demands (Calculations)

l Analytic Model Calculations and Consolidations

l May use significant amounts of CPU time and RAM.
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Appendix: Troubleshooting

Client Web Connection Terminates Before
Web Service Returns Content
If a user has connection issues when trying to log in or during long running web service calls,

check the error log for remote server error entries.

Example:

Description: [HttpWebRequest_WebException_RemoteServer]

Arguments: NotFound

Possible solution:

1. Determine if the user's virus scan software is applying network filters to the connection.

2. Check the registry setting below: 

HKeyCurrentUser\Software\Microsoft\Windows\CurrentVersion\Internet Settings

ReceiveTimeout should be 36000000.

This value may be decreased by a virus or by any anti-virus program, causing client

connections to time-out and "Server Not Found" errors.

3. Ensure configuration files are available.

Make sure that the application server and web server files are in the Configuration folder on

the file share and use proper naming conventions.
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Long Running Server Process Hangs or
Stops With Logging Errors
If there is a hung process that does not appear to be completing, (e.g. consolidation) then check

the Event Viewer, in the summary window, then the information section, look for WAS in the

sources field.  If there are errors regarding WAS (Windows Activation Service) try the following.

1. Open IIS Manager, Click on Application Pools, Click on the OneStream Application Pool,

then Advanced settings, and scroll down to Idle Time-out (minutes) parameter. (The

standard setting is 20 minutes. Follow up with OneStream Support for further options. TBD)

2. Check Firewall settings to see that they allow two-way traffic. A rule to open the port number

to allow traffic through may need to be created. Port numbers for OneStream are 50001 &

50002.

Web Server Not Communicating With
Application Server
If a Web service error is received when first pulling up XF, confirm that the application server is

properly configured. To check this put in the following URL to a browser:

http://<Servername>:50002/OneStreamApp/svc/Data.svc

If the application server is properly configured, a page that looks something like this will display:
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Difficulties Registering the OneStream Excel
Add-In in Excel

1. To properly install the OneStream Excel Add-in, changes are required to the Windows

registry. Ensure that the user has rights to update their own registry while doing

installations, i.e. that they are an administrator of their own machine or have similar

privileges. Also, it is best of the end user is logged in while installing the Add-in and not an

IT representative.

2. Changes made to the Windows registry for the OneStream Excel Add-in during the

installation are made only for the user who is doing the installation. For example, if some on

the Information Technology staff is logged into the user’s machine to do the installation, the

business user will not be able to access the OneStream Excel Add-in.

Installation and Configuration Guide 260

Appendix: Troubleshooting



3. The registration process of the OneStream Excel Add-in requires certain Microsoft .NET

Framework rights to execute a program stored in that folder. The folder is

C:\Windows\Microsoft.NET\Framework (or Framework64 if the user is running the 64-bit

version of Excel). To manually register the Add-in, first open a Command Prompt by clicking

Start | Run and type “cmd”.

Type this command:

cd C:\Program Files\OneStream Software\OneStream Excel AddIn     

(or wherever your OneStream Excel Add-in is installed)

Then type this command:

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\RegAsm.exe

OneStreamExcelAddIn.dll

4. Other Office Add-ins may conflict with the OneStream Excel Add-in, so discuss other

registered Add-ins when discussing installation issues with OneStream Support.

5. The OneStream Excel Add-in will not register with a machine properly if Microsoft Office

has not been installed with the required settings. Ensure that the optional “.NET

Programmability Support” is selected under Excel when installing Microsoft Office.

6. If the OneStream Excel Add-in is installed and appears registered but the user still cannot

see the OneStreammenu in the Excel ribbon, check to see if the Add-in is disabled. To do

so, go to File | Excel Options | Add-ins and scroll to the bottom of the list of Add-ins to see if

the OneStream Excel Add-in is listed under “Disabled Application Add-ins.” If it is, lower on

that dialog under Manage, select Disabled Items and click Go. Select the OneStream Excel

Add-in, click Enable and click OK.

Browser Issues

If you are working with a 64-bit version of Windows operating system, we recommend that you

use the 64-bit version of Edge or another browser.
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l If you use the 32-bit version of a browser, you may experience an out of memory situation

after several hours of extended use. Restart the web browser to resolve this issue.

l If you run both the client and server on a Virtual Machine (VM) and use the 64-bit version of

Windows and the 32-bit version of a browser, browser errors may occur. Microsoft also

recommends disabling the PC Tablet Input Service or running the browser outside of the

VM when running in this mode.
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Appendix: Setting Up Encrypted
Database Connections

1. Launch the OneStream Database Configuration utility.

2. Right-click a database and select Copy to Clipboard > Connection String.
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3. Copy the encrypted string.

4. Email Connection String Example:

SmtpHost=[smtp.office365.com], SmtpPort=[587],

EnableSSL=[True], SmtpSourceMailAccount=

[userID@youremaildomain.com],

SmtpSourceMailAccountPassword=[password]

Email Connection String Example with From Address (optional)

SmtpHost=[smtp.office365.com], SmtpPort=[587],

EnableSSL=[True], SmtpSourceMailAccount=[username],

SmtpSourceMailAccountPassword=[password],

FromAddress=[userID@youremaildomain.com]

SAP Connection String Example:

"USER=YourUserID LANG=EN CLIENT=800 SYSNR=00 ASHOST=HostServerName

PASSWD=YourPassword"

5. The encrypted string is stored to the clipboard.

Encrypted Email String Example

XScpc
Dzo3an7EWAAp6Wvz1IZWE3Q+Fo8DSx0OpacS0Yp5X4sHXtiQGdAoNmNGU48xOa

3xD3C68yAl7B8aXUbv02lj4921ErgN2R+E1qlLG24p98O8a62X0n/q4PS70xzo

sL7R9HzKWT0txtfbpJMUPYrIhCDz6Ubd52/buVABQyUxf2c0Y1BmgIKE/

/6eOcMCv0D5abX6oKbEmZLlms7vXyuicD+KaYheBNX/vbtkA4=
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Encrypted SAP String Example

MF/HrDU0zQupeiyGGSUZ431S1guSfOCDoss4T7JYmiNm8BPTw7inI97W5en

ORZfrVN1Z8ADUHkavsRXKnomFKqBLmddbamOIt5s9bO3jxfXiLI

9B26SDQDKwJer1e6Jc

6. Open the OneStream Application Server Configuration tool.

7. Open Database Server Collections.
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8. Add a database connection.
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9. (Email Connection Only) In the OneStream Business Rule using the email connection, add

the code to call the mail function:

10.

11. (SAP Connection Only) In the OneStream Business Rule using the SAP connection add the

code to call the mail function:
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Appendix: Installing and
Configuring PingFederate
This section describes in detail an example of a full PingFederate installation and configuration as

OneStream’s Infrastructure team experienced it in order to implement and test user authentication

in PingFederate.

PingIdentity components installation and
configuration
PingFederate is Ping Identity's enterprise identity bridge. PingFederate enables outbound and

inbound solutions for single sign-on (SSO), federated identity management, mobile identity

security, API security, and social identity integration. Browser-based SSO extends employee,

customer and partner identities across domains without passwords, using only standard identity

protocols (Security Assertion Markup Language—SAML, WS-Federation, WS-Trust, and OAuth).

PingFederate Installation process:
1. Create a PingIdentity developer account here.

2. Request a license key via Ping Identity licensing website.

3. Download PingIdentity's PingFederate from this site.

4. System Requirements for PingFederate installation here. 

5. Download and install Java SE RunTime Environment (Server JRE) here.
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6. Set the JAVA_HOME environment variable to the Server JRE installation directory path and

add its bin directory to the PATH environment variable.

7. Install PingFederate by following these instructions.

8. Open PingFederate Admin Console and sign in as an Administrator account.

PingFederate and OAuth server
configuration steps: 

1. Server Configuration > Server Settings > Roles and Protocols screen. Select
the Enable OAuth 2.0 Authorization Server (AS) role check box. Select the OpenID
Connect check box. Select Enable Identity Provider then SAML 2.0 andWS-TRUST check

boxes. Save changes (or hit Next button until Save appears).

2. Server Configuration > SSL Server certificates > Create one (make sure it's CN matches

the server name to avoid certification errors when accessed from the clients).

3. Server Configuration > Trusted CAs > Import the just created cert (this same certificate will

need to be installed on the client side in 'Trusted Root Certification Authorities' store).

4. Server Configuration > Signing & Decryption Keys & Certificates > Create New (follow

instructions to create a new signing certificate that will be used later to validate access

tokens for Resource Owner Password flow.  Ex. I created one for my dev environment with

a CN that hints to its use: CN=Config Signing Cert, OU=Dev, O=Ping, L=Denver, ST=CO,

C=US).
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5. Server Configuration > Password Credential Validators > Create New Instance. Enter

values for Instance Name (ex.'UserPass') and ID, Select Type: Simple User Name

Password Validator > Next. In the Instance Configuration screen Add a new row to 'Users' >

Add all your test user names and passwords (store at least one of these values because

these are the user(s) that will be added in OneStream security with PingIdentity

Authentication Provider Type). Hit Next until able to Save.

6. OAuth Server > Scope Management > Add scopes: address, email, openid, phone, profile

> Save

7. Identity Provider > Manage IdP Adapter Instances > Create Instance: Example: Name =

HTMLFormSimplePCV; ID=HTMLFormSimplePCV; Type: HTML Form IdP Adapter >

Next. In IdP Adapter tab add a new row to Credential Validators, select 'UserPass' created

above. Extended Contract tab: policy.action and username should be listed under Core

Contract

8. Adapter Attributes tab: check Pseudonym checkbox for username> hit Next until able to

Save.

9. OAuth Server > Authorization Server Settings

l select 'UserPass' for OAuth Administrative Web Services Settings / Password

Credential Validator

l check "Implict", "Authorization code", "Resource Owner Password Credentials" and

"Allow unidentified clients to make Resource Owner Password credentials grants"

boxes

10. OAuth Server > Access Token Management > Create new (fill fields similar to below)
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l Instance Name: JSONWeb Tokens

l Instance ID: jwt

l Class Name: com.pingidentity.pf.access.token.management.plugins.

JwtBearerAccessTokenManagementPlugin

l Type: JSONWeb Tokens

l Parent Instance Name: None

l Instance Configuration 

l Certificates: k1, CN=Config Signing Cert, OU=Dev, O=Ping, L=Denver, ST=CO,

C=US (This is the signing certificate created in #4)

l Token Lifetime: 120

l JWS Algorithm: RSA using SHA-256

l Active Symmetric Key ID: None Selected

l Active Signing Certificate Key ID: k1

l JWE Algorithm: None Selected

l JWE Content Encryption Algorithm: None Selected

l Active Symmetric Encryption Key ID: None Selected

l Asymmetric Encryption Key

l Asymmetric Encryption JWKS URL: http://<serverName>:<port>/pf/jkws

l Include Key ID Header Parameter: TRUE

l Include X.509 Thumbprint Header Parameter: TRUE

l Default JWKS URL Cache Duration: 720

l Include JWE Key ID Header Parameter: TRUE
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l Include JWE X.509 Thumbprint Header Parameter: TRUE

l Client ID Claim Name: client_id_name

l Scope Claim Name: scope

l Space Delimit Scope Values: FALSE

l Issuer Claim Value: http://<serverName>:<port>

l Audience Claim Value: OneStreamClient

l JWT ID Claim Length: 0

l Access Grant GUID Claim Name: agid

l JWKS Endpoint Path: /oauth/jwks

l JWKS Endpoint Cache Duration: 720

l Publish Key ID X.509 URL: TRUE

l Publish Thumbprint X.509 URL: TRUE

l Session Validation:

l Check Session Validation Status: FALSE

l Check Session Revocation Status: FALSE

l Update Authentication Session Activity: FALSE

l Access Token Attribute Contract:

l Attribute: OrgName

l Attribute: sub

l Attribute: Username

l Resource URIs :
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l Access Control :

l Restrict Allowed Clients : FALSE

11. OAuth Server > OpenID Connect Policy Management > Create New (see example policy

below)

12. OAuth Server > Resource Owner Credentials Mapping > Map 'UserPass' to Persistent

Grant Contract

13. OAuth Server > Access Token Attribute Mapping > Map Default (Context) to JSONWeb

Tokens (Token Manager)

l OrgName: example mapping: Source=Text, Value=Ping Federate Corporation

l Username: Source : Persistent Grant, Value:USER_KEY

l sub: Source : Persistent Grant, Value:USER_KEY (needed to retrieve user claims)

14. OAuth Server > IdP Adapter Mappings: Map HTMLFormSimplePCV To Persistent Grant

Contract

15. Add OneStreamWeb client:

l OAuth Server > Clients > Create New:

l Client ID = OneStreamWeb

l Client Name = OneStreamWeb

l Description = Authorization Code flow for OneStreamWeb application (example)

l Client Authentication = Client Secret > Generate Secret (store this value)

l Redirect URIs: Add: http://<serverName>:<port>/OneStream/OneStreamXF.aspx,

and  http://<serverName>:<port>/OneStream/OneStreamWindowsApp.aspx
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l Bypass Authorization Approval = Check (this will be a trusted app; there is no need

for an extra Authorization Approval form)

l Allowed Grant Types: Authorization Code; Implicit

l Open Id Connect: ID Token Signing Algorithm = Default

l Save

16.  Add OneStreamMvc client:

l OAuth Server > Clients > Create New:

l Client ID = OneStreamMvc 

l Client Name = OneStreamMvc 

l Description = Authorization Code flow for OneStreamMvc application (example)

l Client Authentication = Client Secret > Generate Secret (store this value)

l Redirect URIs: Add: 'http://<serverName>:<port>/Authentication/Logon'

l Bypass Authorization Approval = Check (this will be a trusted app; there is no need

for an extra Authorization Approval form)

l Allowed Grant Types: Authorization Code; Implicit

l Open Id Connect: ID Token Signing Algorithm = Default

l Save

17. Add OneStreamClient client

l OAuth Server > Clients > Create New:

l Client ID = OneStreamClient 

l Client Name = OneStreamClient 

l Description = PingFederate placeholder for OneStream native apps authentication
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l Client Authentication: None

l Redirect URI: Add: https://[SeverName]:

[SSLPortNumber]/OneStreamWeb/OnestreamLogonCallback.aspx/

l Bypass Authorization Approval = Check (this will be a trusted app; there is no need

for an extra Authorization Approval form)

l Allowed Grant Types: Authorization Code; Resource Owner Password Credentials,

Refresh Token

l Open Id Connect: ID Token Signing Algorithm = Default

l Save

PingFederate IWA Integration Kit V3.1
Installed and configured IWA Integration kit following documentation below:

https://docs.pingidentity.com/bundle/ix_m_

downloadDocumentation/page/IWAIK31UserGuide.pdf

Configure Supported Browsers for Kerberos and
NTLM

Install and configure the Kerberos Integration Kit using these instructions:

https://docs.pingidentity.com/r/en-us/pingfederate-111/pf_config_end_user_browser
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PingFederate Notes

If SSL Settings > RequireSSL setting is enabled in IIS, ensure Accept Client Certificates option is

selected. Typically, the exception "IDX10500: Signature validation failed. Unable to resolve

SecurityKeyIdentifier: 'SecurityKeyIdentifier'”  will be thrown if the certificate is not passed to the

client.

Policy Management Example
Important: when creating the Policy Management mappings, ensure that both sub and name

attributes map to Username (Token)

Configure a new policy similar to below:

Manage Policy

Policy ID OAuthPlayground

Policy Name OAuthPlayground

Access Token Manager JSONWeb Tokens

ID Token Lifetime 5

Include Session Identifier in ID

Token
false

Include User Info in ID Token false

Include State Hash in ID Token false

Attribute Contract

Attribute sub

Attribute name

Attribute address.country

Attribute address.formatted
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Attribute address.locality

Attribute address.postal_code

Attribute address.region

Attribute address.street_address

Attribute birthdate

Attribute email

Attribute email_verified

Attribute family_name

Attribute gender

Attribute given_name

Attribute locale

Attribute middle_name

Attribute name

Attribute nickname

Attribute phone_number

Attribute phone_number_verified

Attribute picture

Attribute preferred_username

Attribute profile

Attribute updated_at

Attribute website

Attribute zoneinfo

Attribute Scopes

Attribute Sources & User Lookup

Data Sources (None)
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Contract Fulfillment

sub Username (Token)

name Username (Token)

address.locality Smallville (Text)

birthdate 1977-12-31 (Text)

gender female (Text)

preferred_username mgsample (Text)

Locale3 en_US (Text)

address.country USA (Text)

updated_at 2011-01-03T23:58:42+0000 (Text)

address.postal_code 11223 (Text)

address.region ME (Text)

nickname Name (Text)

email auser@example.com (Text)

website https://www.pingidentity.com/ (Text)

email_verified true (Text)

profile
https://www.pingidentity.com/products/pingfederate/

(Text)

phone_number_verified true (Text)

given_name Mary (Text)

middle_name Good (Text)

picture https://www.pingidentity.com/images/ping-logo.png (Text)

phone_number (555) 555-5555 (Text)

address.formatted 123 Main Street, Smallville, ME USA 11223 (Text)

family_name Sample (Text)
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address.street_address 123 Main Street (Text)

Issuance Criteria

Criterion (None)
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Appendix: Reserve URL for Native
Application Authentication
This section describes how to configure client PCs running pre -5.0 versions of your native

applications.

Disregard this section if you are installing version 5.0 or higher.

SAML 2.0 authentication with ADFS:
1. Ensure that a localhost certificate is installed in the client’s Local Machine. This certificate

needs to be trusted to avoid browser warnings. Take note of the certificate’s thumbprint (ex:

d7a045f8xxxxxxxxb9702066b88bbecf)

2. Open Command Prompt with elevated permissions and run (ex. for port 8443):

a. netsh http add sslcert ipport=0.0.0.0:8443 certhash=

d7a045f8xxxxxxxxb9702066b88bbecf appid={C183BFDB-31C2-49AE-A3ED-

BEA979A269C6}

where appid identifies OneStreamWindows application.

3. If an error is returned run: netsh http delete sslcert ipport=0.0.0.0:8443 then rerun : netsh

http add sslcert ipport=0.0.0.0:8443 certhash= d7a045f8xxxxxxxxb9702066b88bbecf

appid={C183BFDB-31C2-49AE-A3ED-BEA979A269C6}

Non ADFS SAML 2.0 or OIDC authentication:
1. Open Command Prompt with elevated permissions and run (ex. for port 8080):
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netsh http add urlacl url=http://127.0.0.1:8080/ user=Everyone

If an error is returned run first: netsh http delete urlacl url=http://127.0.0.1:8080/, followed by netsh

http add urlacl url=http://127.0.0.1:8080/ user=Everyone
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Appendix: Context Option Values
To Use With Active Directory +
SSL
Specifies the options that are used for binding to the server. The application can set one or

multiple options. This is a list of possible values that can be used along with the description:

Negotiate        

The client is authenticated by using either Kerberos or NTLM. When the user name and password

are not provided, the Account Management API binds to the object by using the security context

of the calling thread, which is either the security context of the user account under which the

application is running or of the client user account that the calling thread represents.

Sealing    

The data is encrypted by using Kerberos. This flag can only be used with the Negotiate context

option and is not available with the simple bind option.

Secure Socket Layer        

The channel is encrypted by using the Secure Sockets Layer (SSL). Active Directory requires that

the Certificate Services be installed to support SSL.

Server Bind        

Specify this flag when you use the domain context type if the application is binding to a specific

server name.
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Signing    

The integrity of the data is verified. This flag can only be used with the Negotiate context option

and is not available with the simple bind option.

Simple Bind    

The client is authenticated by using the Basic authentication.

CAUTION: Communications may be sent over the Internet in clear text if the Secure
Sockets Layer option is not specified with simple bind.

When no context options are specified the default values are Negotiate, Signing, Sealing.
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