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Scheduling the Upgrade
This section provides details related to scheduling Platform upgrades for OneStream.

Upgrading from Platform Versions Earlier 
than 8.0.0
When upgrading from a Platform Version earlier than  8.0.0 to Platform Version 8.0.0 or later, 

OneStream encourages customers to prepare for their upgrade by referencing content in the 

OneStream Community. See Platform v8+ Upgrade Resource.

OneStream cloud customers may initiate Platform Version 8.0.0 or later upgrade interest by 

submitting a Software Upgrade request through the Service Catalog. A Cloud Migration ticket will 

be opened and available to track upgrade activities.

OneStream self-hosted customers may download Platform Version 8.0.0 or later from Solution 

Exchange.

Upgrading from Platform Version 8.0.0 or 
Later
Upgrades from Platform Version 8.0.0 or later follow traditional OneStream best practices. Cloud 

customers can initiate and schedule upgrades through the Software Upgrade request on the 

Service Catalog.
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OneStream self-hosted customers may download the latest platform version directly from 

Solution Exchange and proceed with their upgrade.
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Requirements
Information Technology professionals responsible for installing, maintaining, and supporting 

OneStream must satisfy the following requirements to best support an upgrade. They must also 

review the requirements and special notes in the Installation and Configuration Guide and 

Release Notes.

IMPORTANT: Platform Version 8.2.0 and later was developed using Microsoft .NET 8. 

As a result, all Business Rules must be tailored for .NET 8. For more information, see 

Platform Version 8.0.0 or Later Readiness.

 l OneStream Platform Version 8.2.0 or later requires Microsoft .NET 8.

 o App Server and Web Servers

 n Install the latest version of ASP.NET Core Runtime (Hosting Bundle) (v8.0.x).

 n Install the latest version of .NET Desktop Runtime (x64) (v8.0.x).

 o Client

 n Install the latest version of .NET Desktop Runtime (x64) (v8.0.x).

IMPORTANT: Do not install the .NET SDK package. You may run into errors 

while upgrading if this is installed. 

 l OneStream Servers requires IIS 7 or later.

 l In each application, complete the Compile all Business Rules and Formulas to verify that 

business rules use the proper syntax.
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 l If your applications are referencing any 3rd party DLLs that are not provided by OneStream, 

verify these DLLs are .NET 8 compatible. Contact OneStream Support 

(https://www.onestream.com/support/) to discuss available upgrade options.

 l When upgrading OneStream, update the database schema to the most recent version.

IMPORTANT: All database upgrade steps must be taken sequentially. Users 

cannot skip steps or stop updates once started.

 l Back up the Configuration files in your OneStream Share directory.

 l For additional minimum system requirements, see "Hardware and Software Requirements" 

in the Installation and Configuration Guide.

 l When implementing Smart Integration Connector with the OneStream application, see 

"Requirements" in the Smart Integration Connector Guide.

IMPORTANT: Self-hosted customers must have a successful database connection 

before the Database Upgrade. See Enable the Trust Server Certificate.
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Before Upgrading
Perform these tasks before upgrading:

 1. Perform a full backup of all OneStream databases.

 2. Download Client Software and Self-Hosted Server (for on-premises installations) from 

Solution Exchange for the appropriate setup files:

 a. Log in to Solution Exchange, and select Platform to get the latest version of 

OneStream.

 b. Download Client Software and Self-Hosted Server (for on-premises installations) for 

the appropriate setup files for the server installation.

 3. Confirm the location of the OneStream configuration files:

 a. On a OneStream server, select Start > Programs > OneStream Software > 

OneStream Server Configuration Utility.

 b. Right-click the utility and select Run as Administrator.

 c. Select File > Open ASP.NET Configuration File and open the appsettings.json 

file from the following locations.

 l Web servers: C:\Program Files\OneStream Software\OneStream
WebRoot\OneStreamWeb

 l Application servers: C:\Program Files\OneStream Software\
OneStreamAppRoot\OneStreamApp

 d. The file opens and displays the path to the XFAppServerConfig.xml and 

XFWebServerConfig.xml configuration files.
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 e. Take note of the path to the configuration files. You will specify this location during 

the upgrade.

NOTE: This path is commonly set to C:\OneStreamShare\Config

 4. Make a copy of the configuration files contained in this folder, and save them to a backup 

folder of your choice.

 5. Close the file without saving and exit the utility.

 6. Obtain the OneStream service account in Internet Information Services Manager. Note the 

Windows account and password because you will enter them in IIS after the upgrade.

NOTE: The service account must be an Admin ID or in the IIS_IUSRS Group, 

Performance Log User, and Performance Monitor Users group. The ID is required 

for queuing and CPU monitoring.
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 a. On each OneStream server, select Start > Control Panel > Administrative Tools > 

Internet Information Services (IIS) Manager.

 b. Expand the server and select Application Pools. This displays application pools to 

the right. The OneStreamAppAppPool and OneStreamWebAppPool service 

accounts display in the Identity column.

 7. Confirm the IIS OneStream App Server Site and OneStream Web Server Site Binding 

Information. If they are not kept as default and the type was http or https, the port number 

(and certificate if used for https) can be restored. This information will not be available if 

OneStream is uninstalled.

 8. Confirm that the OneStream Database Configuration Utility is installed on each OneStream 

application server. Click Start > Programs > OneStream Software.

 9. Confirm that  OneStream is installed on each OneStream application server. Click Start > 

Programs > OneStream Software.

 10. Install the following:

 l App Server and Web Servers

 o Install the latest version of ASP.NET Core Runtime (Hosting Bundle) (v8.0.x).

 o Install the latest version of .NET Desktop Runtime (x64) (v8.0.x).

 l Client

 o Install the latest version of .NET Desktop Runtime (x64) (v8.0.x).

 11. On-premises customers must enable the Trust Server Certificate for the 

OneStream Database Server using the OneStream Server Configuration Utility:
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 a. Select File > Open Application Server Configuration File.

 b. Navigate to C:\OneStreamShare\Config or the location of configuration files from 

step 3e.

 c. Open the App Server Config file.

 d. Locate Database Server Connections.

 e. Click  to open the Database Server Connections.

 f. At the end of the Connection String, add TrustServerCertificate=True.

 g. Click the OK button.

All Application Databases

From the OneStream Database Configuration Utility:

Upgrade Guide 8

Before Upgrading



 a. Right-click on a database, click Edit the Database  Connection.

 b. Select Advanced.

 c. Set Trust Server Certificate to True, then click the OK button.

 d. Select Test Connection to ensure a successful connection.
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NOTE: Alternatively, set the TrustServerCertificate to True directly in the XML. 

Repeat these steps for all Application Databases.
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Upgrade System Components
Perform the tasks in the following sections to upgrade the complete OneStream system.

Uninstall OneStream Software
Uninstall the OneStream Server and, if installed, Client API.

 1. Select Control Panel > Programs and Features > Uninstall a Program.

 2. Locate the OneStream Servers component.

 3. Right-click OneStream Servers and select Uninstall.

 4. If installed, locate the OneStream Client API component.

 5. Right-click OneStream Client API and select Uninstall.

Reinstall OneStream Servers
Install the OneStream Servers on the Application Server and Web Server.

 1. Browse to the OneStream Servers package, right-click OneStreamServers-#.msi and 

select Install to run the server installation.

 2. On the landing page, click the Next button and accept the License Agreement.

 3. Specify the directory where the software was previously installed and click the Next button.

 4. Select Custom.

 5. On Select Features, select the features to install.
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 l Application Server: Select Application Server and Server Configuration Utility.

NOTE: Choose the Database Configuration Utility and Upgrade Assistant 

Utility if the application server is the server where the Database 

Configuration Utility was previously installed.

 l Web Server: Select Web Server and Server Configuration Utility.
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 6. Click the Next button.

 7. Click Install then Finish.

Reinstall OneStream for Desktop
 1. Browse to the OneStream package, right-click OneStreamDesktop-#.msi and select 

Install.

 2. Click the Next button and accept the License Agreement.

 3. Select Custom.

 4. Select the directory where the software was previously installed and click the Next button.
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 5. On Select Features, select all options and click the Next button.

 6. Click Install then Finish.

Upgrade the Framework and Application 
Databases

IMPORTANT: When updating OneStream, update the database schema to the most 

recent version. All database upgrade steps must be completed sequentially. Users 

cannot skip steps or stop updates once started.

Changes are made to stage tables for this release, so the database update may take time.

 1. Before performing these steps, have a database administrator back up all OneStream 

databases.

 2. On the OneStream application server with the OneStream Database Configuration Utility 

installed, select Start > Programs > OneStream Software > OneStream Database 
Configuration Utility.

 3. Right-click the utility and select Run as Administrator.

 4. Right-click OneStream Framework Database and select Upgrade Database Version. If 

disabled, an upgrade is not required.

NOTE: If you get an error, check the log for details: C:\Program Files\OneStream 

Software\XFDatabaseConfig\Log

 5. A dialog box displays giving you the option to process the schema upgrade on the database 

or the server. Leave the text field blank and click Yes to begin the database upgrade using 

the default setting, which is database.
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 6. Repeat the upgrade for each Application database and the Framework database until the 

option is disabled. This indicates the database is up-to-date.

Run the Upgrade Assistant Utility
This is an additional step that must be performed when upgrading from a Platform Version earlier 

than  8.0.0 to a Platform Version 8.0.0 or later. Specifically, this version of the Upgrade Assistant 

Utility will convert any legacy reports that were stored in CodeDOM format to now be stored as 

XML.

 1. On the OneStream application server with the OneStream Upgrade Assistant Utility 

installed, select Start > Programs > OneStream Software > OneStream Upgrade 
Assistant Utility.

 2. From the command line enter: 

xfupgradeassistant -c C:\OneStreamShare\Config\XFAppServerConfig.xml -t 

ReportLayoutBytes -v -update

NOTE: C:\OneStreamShare\Config is the default path to the configuration file. 

You must update this path if it has been modified for your environment.

 3. Enter exit to close the utility.

 4. Restart IIS.
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Update the ASP.NET Configuration File
The ASP.NET Configuration file (appsettings.json) must be updated on every server/folder as 

outlined in the following section:

 l Application server

 o C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamApp\appsettings.json

 o C:\Program Files\OneStream 

Software\OneStreamAppRoot\OneStreamMgmt\appsettings.json

 l Web servers:

 o C:\Program Files\OneStream 

Software\OneStreamWebRoot\OneStreamWeb\appsettings.json

 o C:\Program Files\OneStream 

Software\OneStreamWebUIRoot\OneStreamWebUI\appsettings.json

 1. On each OneStream server, launch the OneStream Server Configuration Utility by clicking 

Start > Programs > OneStream Software > Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Select File > Open ASP.NET Configuration File and browse to the appropriate location 

from the folders above.

 4. Select the appsettings.json file.

 5. When the file opens, copy the directory path of the configuration files.

NOTE: This path is commonly set to C:\OneStreamShare\Config

 6. Enable HTTP and Enable HTTPS are enabled by default.
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When SSL is not enabled, select Enable HTTP and deselect Enable HTTPS. 

NOTE: Only one protocol can be selected: Enable HTTP or Enable HTTPS.

NOTE: For the WebUI server file for the Modern Browser Experience, you are not 

asked to select a checkbox to enable HTTP or HTTPS.

 7. Save and close the file.

 8. Repeat these steps on each web and app server in the environment.

Update the Configuration Files
Update the Application and Web Server Configuration files.

Update the Application Server Configuration File
 1. Open the OneStream Server Configuration Utility, and select Run as Administrator.

 2. Select File > Open Application Server Configuration File and select the Application 

Server Configuration file from C:\OneStreamShare\Config. 

 3. In Database Server Connections, select the ellipsis and update the command time-outs 

for the OneStream Database Server connection:

 l Short = 90 (required)

 l Large = 900

 4. Select the Save icon and close the file.
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Update the Web Server Configuration File
 1. Open the OneStream Server Configuration Utility, and select Run as Administrator.

 2. Select File > Open Web Server Configuration File and select the Web Server 

Configuration file from C:\OneStreamShare\Config.

 3. To ensure the file version is updated, select the Save icon and close the file.

Update and Configure IIS
 1. On each OneStream server, open the OneStream Server Configuration Utility by clicking 

Start > Programs > OneStream Software > OneStream Server Configuration Utility.

 2. Right-click the utility and select Run as Administrator.

 3. Choose Tools > Configure IIS.

 4. In Configure IIS, specify the following:

 l For Web Site Name, enter the name of the OneStream IIS Website to update.

 l The OneStream App Server and Web Server sites

 5. Select Update IIS Default Settings.

 6. Select options to update IIS for the appropriate websites:

 l Use Web Server Settings: Specify the Web Server site.

 l Use App Server Settings: Specify the App Server site.

 l User Account Type: Specify Custom Account, then enter the user name and 

password of the OneStream Service account.

 7. Click Update IIS Settings then OK.

 8. Repeat these steps to set the appropriate IIS settings for the application pools in IIS.
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 9. Log on to each OneStream Web Server in the environment.

 10. Browse to C:\Program Files\OneStream Software\OneStreamWebRoot\OneStreamWeb

 11. Locate the OneStreamWeb.runtimeconfig.json file and open this file in a text editor.

 12. Update the configProperties section with the following line:

"System.Threading.ThreadPool.MinThreads": 128

"configProperties": {
      "System.GC.Server": true,
      "System.Reflection.Metadata.MetadataUpdater.IsSupported": false,
      "System.Runtime.Serialization.EnableUnsafeBinaryFormatterSerialization": false,
      "System.Threading.ThreadPool.MinThreads": 128
    } 

NOTE: Add a comma before the previous line as shown in the previous example.

 13. Save the file to apply the change.

 14. Click Reset IIS.

Test the Windows Client Login Using 
ClickOnce

 1. Using the Microsoft Edge Web Browser, navigate to the OneStream Windows App URL:

 l On-premises: http://<webserver>:50001/OneStreamWeb

 l Cloud: https://<customer>.onestreamcloud.com/OneStreamWeb

 2. Click Open to launch the ClickOnce Windows app.

 3. Confirm that you can log in.

 4. From Application, select System Administration, then click Connect.
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 5. Select System > Tools > Environment to identify the application servers and their status.

 6. Verify that each server is active.

Test the Modern Browser Experience Login
 1. Navigate to the OneStream Modern Browser Experience URL:

 l On-premises for Modern Browser Experience: http://<webserver>:50001

 l Cloud for Modern Browser Experience: https://<customer>.onestreamcloud.com

 2. Confirm that you can log in.

Verify the Application
 1. Compile all business rules:

 l Right-click the grid and export any errors for analysis using an Excel file format.

 l Apply updates as needed.

 2. Download and import the Standard Application and Standard System Reports from the 

Solution Exchange.
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Platform Version 8.0.0 or Later 
Readiness
Upgrading your OneStream Platform to Version 8.2.0 or later requires .NET 8.

Business Rules
NOTE: Users upgrading from Platform Version 8.0.0 or later are not expected to require 

Business Rule maintenance.

Users upgrading from a Platform  Version earlier than 8.0.0 will require Business Rule 

maintenance as Platform Version 8.0.0 includes updates and enhancements to the Business 

Rules compiler to improve syntax detection. Administrators must resolve these errors to compile 

business rules fully. Warning messages identify line items that will function, but you should update 

them to support the latest compiler’s requirements. Resolving these warnings varies. You may be 

able to use a provided replacement function or change a function’s properties.

Upgrade Guide 21

Platform Version 8.0.0 or Later Readiness



System.Data.SqlClient to Microsoft.Data.SqlClient 
Migration

IMPORTANT: 
To maintain consistency with Microsoft's recommendations, in Platform Version 8.1.0, 

the data access driver for SQL Server will be changed from System.Data.SqlClient to 

Microsoft.Data.SqlClient. This migration will be automatic and will take place during the 

database upgrade process. All references to System.Data.SqlClient will automatically 

be changed to Microsoft.Data.SqlClient in Business Rules, Member Formulas, and the 

like.

NOTE: 
These updates will take place automatically during the database upgrade to Platform 

Version 8.1.0, and when using the Load function of Application Load/Extract, instances 

of System.Data.SqlClient will automatically convert to Microsoft.Data.SqlClient.

IMPORTANT: 
If an application was migrated after the Platform Version 8.1.0 upgrade from Application 

Copy (Cloud Administration Tools (CAT)) or a database BACPAC file, then the migration 

from System.Data.SqlClient to Microsoft.Data.SqlClient will need to be applied directly 

to that application. On-premises customers can run the Upgrade SqlClient Namespace 

References from the OneStream Database Configuration utility to replace 

System.Data.SqlClient references. SaaS customers can request to have this run by 

contacting OneStream Support (https://www.onestream.com/support/).

See Platform v8+ Upgrade Resource.
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Example
Business Rule Updates: Update Using and Import statements to reference 

Microsoft.Data.SqlClient using the following code:

C# Before 8.1.0

using System.Data.SqlClient;
...
SqlConnection conn1 = new System.Data.SqlClient.SqlConnection();
System.Data.SqlClient.SqlConnection conn2 = (System.Data.SqlClient.SqlConnection)conn1;

C# for 8.1.0

using Microsoft.Data.SqlClient;
...
SqlConnection conn1 = new Microsoft.Data.SqlClient.SqlConnection();
SqlConnection conn2 = (Microsoft.Data.SqlClient.SqlConnection)conn1;    

Visual Basic Before 8.1.0

Imports System.Data.SqlClient
...
Dim conn1 As New System.Data.SqlClient.SqlConnection()
Dim conn2 As System.Data.SqlClient.SqlConnection = CType(conn1, 
System.Data.SqlClient.SqlConnection)

Visual Basic for 8.1.0

Imports Microsoft.Data.SqlClient
...
Dim conn1 As New Microsoft.Data.SqlClient.SqlConnection()
Dim conn2 As SqlConnection = CType(conn1, Microsoft.Data.SqlClient.SqlConnection)
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Custom DLLs
If your implementation or business rules reference custom DLLs that are not provided by 

OneStream, these DLLs must be .NET 8 compatible. Contact OneStream Support 

(https://www.onestream.com/support/) to discuss available upgrade options.

ERPConnect (SAP)
ERPConnect45.dll enabling connection to SAP systems is no longer available in Platform 

Versions 8.0.0 and later. A newer version ERPConnectStandard20.dll is available through the 

download "DLL Packages" from the Platform page of the Solution Exchange.

On-premises Customers:

 1. Download ERPConnectStandard20.dll file to your integrations folder.

 2. Install the required Microsoft Visual C++ Redistributable latest supported downloads.

 3. Download and copy SAP NetWeaver RFC Library DLL (sapnwrfc.dll) to the integrations 

folder.

See Theobald Software ERPConnect Requirements.

 4. Modify your business rules to use the ERPConnectStandard20.dll.

Cloud/SaaS Customers: ERPConnect is available through Smart Integration Connector. See 

the Smart Integration Connector Guide or contact OneStream Support 

(https://www.onestream.com/support/) to discuss more upgrade options.
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Smart Integration Connector
Smart Integration Connector is required for OneStream Cloud integration with local customer data 

sources when using OneStream Platform Version 8.0.0 or later. VPN is no longer supported with 

Platform Version 8.0.0 or later and reached end of service for versions earlier than Platform 

Version 8.0.0 on August 31, 2024.

See the Smart Integration Connector Guide.

Authentication
Cloud Customers: OneStream IdentityServer is required for OneStream Platform Version 8.0.0 

or later. See the Identity and Access Management Guide.

Self-hosted Customers: No changes necessary. Legacy authentication support is the standard 

for self-hosted customers.

VBA Changes
ProcessSSOAuthenticationAndCreateToken is no longer supported as an authentication option 

from VBA scripts. See "Visual Basic for Applications (VBA) Procedures" in the Design and 

Reference Guide.

Client API Changes
Client API is no longer provided with Platform Version 8.0.0 or later. OneStream recommends 

Task Scheduler or REST API to replace existing Client API use cases.
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Tiles Page
The ClickOnce journey is enhanced to launch the application with a single click of the Open button 

while eliminating the tiles page. See "Deployment using ClickOnce" in the Installation and 

Configuration Guide.

Help Documentation
Help documentation has moved from within the application to 

https://documentation.onestream.com/docs/. Clicking the in-app help icon routes you to this site.

Business Rule Groups
In Platform Version 8.0.0 the default for new Business Rule Access or Maintenance Groups is the 

Administrators group. This default can be changed by the Server Configuration Utility.

OneStream Solution Compatibility
Visit OneStream Solution Information on OneStream Community to ensure your OneStream 

Solutions are ready for your OneStream Platform upgrade.
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Help and Miscellaneous
This page contains help and other miscellaneous information related to upgrades.

Upgrade Troubleshooting
Review this section for troubleshooting and installation checks.

Incorrect Installation Order

Follow the steps in order as outlined in the Before Upgrading section. Use the following checks to 

help determine installation issue resolutions.

To check that you have the latest .NET versions installed, run the following command in the 

PowerShell:

dotnet --info

NOTE: The hosting bundle should be Microsoft.AspNetCore.App 8.0.x and the desktop 

runtime should be Microsoft.WindowsDesktop.App 8.0.x

To check that IIS is properly installed, run the following command in the PowerShell:

get-webglobalmodule

NOTE: The output must contain AspNetCoreModuleV2.

Resolution: Uninstall the hosting bundle and ensure that IIS is properly installed.
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Execution Policy when running PowerShell Script

Resolution: Run the following commands in the PowerShell.

 l PS C:\WINDOWS\system32> Set-ExecutionPolicy Unrestricted

 l PS C:\WINDOWS\system32> Set-ExecutionPolicy
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