
Getting Started 
with Solutions 
Guide



Copyright © 2026 OneStream Software LLC. All rights reserved.

All trademarks, logos, and brand names used on this website are the property of their respective 

owners. This document and its contents are the exclusive property of OneStream Software LLC 

and are protected under international intellectual property laws. Any reproduction, modification, 

distribution or public display of this documentation, in whole or part, without written prior consent 

from OneStream Software LLC is strictly prohibited.



Table of Contents

Overview 1

Solution Exchange 3

Help Documentation 5

Solution Guides 6

Solution Release Notes 9

Solution Compatibility 10

Install and Configure the Solution 13

Select the Solution Development Location 14

Create the OneStream Development Application 15

Configure Security Settings 16

Platform Version 8.0.0 or Later 17

Platform Version 7.4.4 or Earlier 18

Install the Solution 19

Set Up the Solution 20

Getting Started with Solutions Guide i

Table of Contents



Configure Solution Settings 21

Display Settings 31

Package Contents and Naming Conventions 32

Standard Format 32

Exceptions 33

Genesis 33

Forecast Value Add and SensibleAI Studio 34

Solution Database Migration Advice 35

OneStream Solution Modification Considerations 36

Getting Started with Solutions Guide ii

Table of Contents



Overview
This guide provides instructions for solution administrators to install and configure the following 

OneStream Solutions:

 l Admin Assist PV9.0.0 SV1.0.0 and later

 l Administrator Solution Tools PV7.4.0 SV1.0.2 and later

 l AI Data Tools PV9.3.0 SV1.2.0 and later

 l Allocations Management PV8.4.0 SV1.0.0 and later

 l Analytic Drill Down PV8.4.0 SV1.0.1 and later

 l Application Control Manager PV9.1.0 SV1.0.0 and later

 l BAI Parser PV8.0.0 SV1.0.5 and later

 l Cloud Administration Tools PV8.5.0 SV1.0.0 and later

 l Compliance PV6.2.0 SV1.0.3 and later

 l ESG Reporting and Planning PV9.0.0 SV2.1.0 and later

 l File Explorer Manager PV6.5.0 SV1.0.2 and later

 l Financial Close PV9.0.0 SV2.0.3 and later

 l Forecast Value Add PV9.3.0 SV1.1.0 and later

 l Genesis PV9.0.0 GV2.0.0 and later

 l Guided Reporting PV8.4.0 SV1.1.3 and later

 l MarketPlace Solution Tools PV7.2.0 SV1.0.0 and later
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 l Narrative Reporting PV9.1.0 SV1.0.0 and later

 l Navigation Center PV9.1.0 SV1.0.0 and later

 l Parcel Service PV8.5.0 SV1.0.0 and later

 l Planning Solutions PV6.2.0 SV1.0.4 and later

 l Predictive Analytics 123 PV6.2.0 SV1.0.3 and later

 l SAP Connector PV8.4.0 SV1.1.0 and later

 l Scenario Analysis 123 PV5.3.0 SV1.0.0 and later

 l Security Audit Reports PV6.2.0 SV1.0.2 and later

 l SensibleAI Forecast PV9.3.0 SV4.2.0 and later

 l SensibleAI Studio PV9.3.0 SV1.3.0 and later

 l Snippet Editor PV6.2.0 SV1.0.0 and later

 l Standard Application Reports PV6.4.0 SV1.0.1 and later

 l Standard System Reports PV4.3.0 SV1.0.2 and later

 l System Diagnostics PV8.5.0 SV1.2.0 and later

 l Table Data Manager PV6.2.0 SV1.0.3 and later

 l Task Manager PV9.0.0 SV1.0.0 and later

 l Xperiflow Administration Tools PV9.3.0 SV2.4.0 and later

 l Xperiflow Cloud Tools PV9.0.0 SV2.3.0 and later

See Install and Configure the Solution.

This guide also includes the recommended display settings, package file name conventions, 

recommendations for solution database migration, and considerations for modifications to 

solutions.
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See the following sections:

 l Display Settings

 l Package Contents and Naming Conventions

 l Solution Database Migration Advice

 l OneStream Solution Modification Considerations

Follow the instructions in the solution guide to install and configure solutions that are not in this 

guide:

 l Line Item Modeling

 l Metadata Builder

 l Power BI Connector

 l Sample Templates 

Go to documentation.onestream.com/docs/ and search for the solution guide. See Help 

Documentation.

Solution Exchange
Use OneStream Solution Exchange to download, configure, and deploy solutions to extend the 

platform.

Solution administrators typically have access to Solution Exchange. Login is required.
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To go to the Solution Catalog page, follow these steps.

 1. Hover your cursor over SOLUTIONS.

 2. Select All Solutions. 

You can browse the tiles, search for a solution, filter by platform version, creator, category, and 

pricing, and sort the items listed.
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Help Documentation

To access the help documentation, in OneStream, select  or go to 

documentation.onestream.com/docs/

NOTE: If you select  in a solution or access the documentation from Solution 

Exchange, you will go to the landing page for that solution.

All users have access to the help documentation. Login is not required.
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Solution Guides

After the solution is installed, see the solution guide for instructions for use. To find a solution 

guide, follow these steps:

 1. On the OneStream Documentation site, in the top navigation, hover your cursor over 

Solution Guides.

 2. Hover your cursor over the alphabetical range for the first letter of the solution name.
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 3. Select the guide.

The table of contents and landing page for the guide display along with a panel to explore 

more resources, including PDFs of the current guide and release notes, videos, interactive 

learning, and community support.
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 4. (Optional) To access the guides and release notes from previous versions, select Previous 
Releases.

 5. (Optional) To give feedback on the documentation, select Feedback.
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Solution Release Notes

Release notes include compatibility requirements, upgrade information, and release summaries. 

To view the release notes, follow these steps:

 1. On the OneStream Documentation site, in the top navigation, hover your cursor over 

Release Notes.

 2. Hover your cursor over Solutions.

 3. Hover your cursor over the alphabetical range for the first letter of the solution name.

 4. Select the solution.

The table of contents and current release notes for the solution display along with a panel to 

explore more resources, including PDFs of the current guide and release notes, videos, 
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interactive learning, and community support.

Solution Compatibility

The Solution Compatibility table includes solution versions and the compatible platform versions. 

To view the Solution Compatibility table, follow these steps:

 1. On the OneStream Documentation site, in the top navigation, hover your cursor over 

Release Notes.

 2. Hover your cursor over Platform.

 3. Select Solution Compatibility.
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The solution versions and compatible platform versions display along with solutions 

designated for community status and solutions designated for sunset.
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Install and Configure the Solution
Before you install the solution, review the compatibility requirements in the release notes on the 

OneStream documentation website: documentation.onestream.com/docs/

TIP: Release notes also include relevant upgrade information. Review this information 

before upgrading from a previous version.

View the compatibility with platform versions in Solution Compatibility. See Solution Compatibility.

NOTE: OneStream recommends upgrading to the latest platform version.

See Help Documentation.

Follow these steps to install and configure the solution.

 1. Select the Solution Development Location.

 2. Create the OneStream Development Application.

 3. Configure Security Settings.

NOTE: This only needs to be done once, and it applies to all solutions in the 

application.

 4. Install the Solution.

 5. Set Up the Solution.

 6. Configure Solution Settings.
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Select the Solution Development Location
Decide whether to build the solution in a separate development OneStream application or directly 

in the production OneStream application.

 l Development OneStream Application: As a best practice, use the development 

OneStream application to build the solution.

 l Production OneStream Application: The primary advantage of building the solution in a 

production application is that you will not have to migrate the resulting work from a 

development application. However, there are intrinsic risks when making design changes to 

an application used in a production capacity, so it is not advised.

IMPORTANT: OneStream strongly recommends that you implement the solution 

in the development environment with a fresh copy of the production application 

before starting work.

TIP: Use Cloud Administration Tools to create a copy of the production 

application. See "Copy Application" in the Cloud Administration Tools Guide.

See Solution Database Migration Advice.
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Create the OneStream Development 
Application

 1. Ensure all the OneStream artifacts relating to the solution (for example, security groups, 

linked dashboards, Workflow Profiles, entities) are in the production application.

 2. Create a backup copy of your production database, or copy your production OneStream 

application to your development environment and rename it. This development version will 

be used for your solution.

NOTE: Use Cloud Administration Tools to create a copy. See "Copy Application" 

in the Cloud Administration Tools Guide.

 3. Temporarily increase the Database Command Timeout settings for the installation. Set the 

Command Timeout and Command Timeout Large settings to 3600. You can revert 

these values after the installation is complete.

 l For OneStream-hosted environments, follow these steps to access the settings:

 a. Go to System > Administration > System Configuration > Application 
Server Configuration > Database Server Connections > OneStream 
Database Server.

NOTE: To access System Configuration, you must have group-

based access to the SystemConfigurationPage security role in 

System > Administration > Security > System Security Roles > 

System User Interface Roles.

 b. On the Configuration tab, in the Timeouts section, the options are listed.
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 c. For both the Command Timeout and Command Timeout Large options, 

deselect the checkbox and then enter 3600.

 l For self-hosted environments, follow these steps to access the settings:

 a. Start the OneStream Server Configuration Utility as an administrator.

 b. Select File > Open Application Server Configuration File.

 c. Under Databases, select the ellipsis next to Database Server Connections.

 d. Select OneStream Database Server.

 e. Under Connection String Settings, the options are listed.

 4. Reset IIS. This will cancel all running jobs. You can go to Cloud Administration Tools and 

select the RESET IIS button, or you can log a catalog request to reset services for an 

individual environment.

See "Home" in the Cloud Administration Tools Guide.

TIP: Schedule an outage to reset IIS because it will take time to reset.

Configure Security Settings
Configure the security settings to enable users to create and change data in the additional 

database tables. Ancillary tables are custom or supplemental tables that support additional 

business requirements, custom solutions, or Solution Exchange applications.

This configuration only needs to be done once, and it applies to all solutions in the application.

IMPORTANT: Ensure these group settings include the users who will be working on and 

setting up the solution tables. Group settings are applicable to all solutions, so use 

generic group names.
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See "OneStream Database Server Security and SQL Table Access" and "SQL Table Editor" in 

the Design and Reference Guide.

Platform Version 8.0.0 or Later

If you are using Platform Version 8.0.0 or later, follow these steps.

 1. Go to System > Administration > System Configuration > Application Server 
Configuration > Database Server Connections > OneStream Database Server.

NOTE: To access System Configuration, you must have group-based access to 

the SystemConfigurationPage security role in System > Administration > Security 

> System Security Roles > System User Interface Roles.

 2. On the Configuration tab, in the Security section, edit the following options:

 l Can Create Ancillary Tables: In the drop-down menu, select True.

 l Can Edit Ancillary Table Data: In the drop-down menu, select True.

 l Access Group For Ancillary Tables: Select the group that will view the content of 

tables.

 l Maintenance Group For Ancillary Tables: Select the group that will edit and 

maintain tables.

 l Table Creation Group For Ancillary Tables: Select the group to create tables.

NOTE: As of Platform Version 9.2.0, members of the Administrator group no 

longer have default permission to create, edit, access, and maintain ancillary 

tables.  Users must be explicitly assigned.
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 3. Reset IIS. This will cancel all running jobs. You can go to Cloud Administration Tools and 

select the RESET IIS button, or you can log a catalog request to reset services for an 

individual environment.

See "Home" in the Cloud Administration Tools Guide.

TIP: Schedule an outage to reset IIS because it will take time to reset.

Platform Version 7.4.4 or Earlier

If you are using Platform Version 7.4.4 or earlier, follow these steps.

 1. Start the OneStream Server Configuration Utility as an administrator.

 2. Select File > Open Application Server Configuration File.

 3. Under Databases, select the ellipsis next to Database Server Connections.

 4. Select OneStream Database Server.

 5. Edit the following options:

 l Access Group for Ancillary Tables: Select a group that includes those who will 

access records.

 l Can Create Ancillary Tables: Select True.

 l Can Edit Ancillary Table Data: Select True.

 l Maintenance Group for Ancillary Tables: Select the group that will edit and 

maintain tables.

 l Table Creation Group for Ancillary Tables: Select the group to create tables.
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 6. Reset IIS. This will cancel all running jobs. You can go to Cloud Administration Tools and 

select the RESET IIS button, or you can log a catalog request to reset services for an 

individual environment.

See "Home" in the Cloud Administration Tools Guide.

TIP: Schedule an outage to reset IIS because it will take time to reset.

Install the Solution
Follow these steps to install the solution.

NOTE: Some solutions must be purchased before installation.

 1. Go to OneStream Solution Exchange and find the solution to install. See Solution 

Exchange.

 2. From the drop-down menus, select the appropriate platform version and solution version.

 3. Select the DOWNLOAD SOLUTION button.

IMPORTANT: The package file name contains multiple identifiers that correspond 

with the platform. To preserve the integrity of the naming conventions, do not 

rename any of the elements. See Package Contents and Naming Conventions.

 4. Log in to OneStream.

 5. On the Application tab, go to Tools > Load/Extract.

 6. On the Load tab, use the Select File buttons to locate the solution package.

IMPORTANT: Do not extract the solution package from the .zip file.
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 7. Select the Open button.

 8. When the solution file name displays, select the Load button.

 9. Select the Close button to complete the installation.

For the following solutions, instead of downloading from Solution Exchange, contact your 

OneStream representative to receive a link to download the solution:

 l AI Data Tools

 l AI System Diagnostics

 l SensibleAI Forecast

 l SensibleAI Studio

 l Xperiflow Administration Tools

 l Xperiflow Cloud Tools

Set Up the Solution
The first time the solution is run, you are guided through the process to set up the solution.

 1. In OneStream, go to OnePlace > Dashboards > <Solution Name> > <Solution Name>.

 2. Follow the prompts to set up tables and launch the solution. 

NOTE: To set up tables, you must have group-based access to the Table Creation 

Group for Ancillary Tables security role. See Configure Security Settings.

The following solutions do not require additional setup. After loading the solution package, 

installation is complete.
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 l Admin Assist

 l Genesis

 l Xperiflow Cloud Tools

Configure Solution Settings
After installing the solution, configure the settings that relate to the functionality of the solution. 

The following table includes each solution and references to the documentation for configuration 

information. Follow the instructions in the referenced sections to configure additional settings as 

needed.

For compatibility requirements, see Solution Release Notes.

Solution Documentation

Admin Assist See the following sections in the Admin Assist Guide:

 l "Package Contents"

 l "Settings and Configuration"

Administrator Solution 

Tools

See the following sections in the Administrator Solution Tools 

Guide:

 l "Package Contents"

 l "Business Rules"

 l "Settings"

AI Data Tools See "Settings" in the AI Data Tools Guide.
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Solution Documentation

Allocations Management See the following sections in the Allocations Management 

Guide:

 l "Package Contents"

 l "Business Rules"

 l "Data Structures"

 l "Solution Administration"

Analytic Drill Down See the following sections in the Analytic Drill Down (Formerly 

DrillIt) Guide:

 l "Package Contents"

 l "Settings and Configuration"

Application Control 

Manager

See the following sections in the Application Control Manager 

Guide:

 l "Package Contents"

 l "Settings"

 l "Administration"
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Solution Documentation

BAI Parser See the following sections in the BAI Parser Solution Guide:

 l "Package Contents"

 l "BAI Dashboard Configuration"

 l "Administration Management"

Cloud Administration 

Tools

See the following sections in the Cloud Administration Tools 

Guide:

 l "Package Contents"

 l "Settings"

 l "Application Management"

 l "Cloud Database Best Practices"

Compliance See the following sections in the Compliance Guide:

 l "Package Contents"

 l "Settings"

Getting Started with Solutions Guide 23

Install and Configure the Solution



Solution Documentation

ESG Reporting and 

Planning

See the following sections in the ESG Reporting and Planning 

Guide:

 l "Package Contents"

 l "Settings"

 l "Administration"

 l "Appendix C: Tables and Package Contents"

File Explorer Manager See the following sections in the File Explorer Manager Guide:

 l "Server Settings"

 l "Package Contents"

 l "Settings"
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Solution Documentation

Financial Close See the following sections in the Financial Close Guide:

 l "Turning Off Dashboards"

 l "Review the Package Contents"

 l "Edit the Transformation Event Handler Business Rule"

 l "Settings" (Account Reconciliations)

 l "Settings" (Transaction Matching)

 l "Custom Service Factory" (Transaction Matching)

 l "Settings" (Journal Entry Manager)

 l "Templates" (Journal Entry Manager)

 l "ERPs" (Journal Entry Manager)

Forecast Value Add See "Settings" in the Forecast Value Add Guide.

Genesis See the following sections in the Genesis Guide.

 l "Import Content Blocks"

 l "Settings"

Guided Reporting See the following sections in the Guided Reporting Guide:

 l "Package Contents"

 l "Settings"
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Solution Documentation

MarketPlace Solution 

Tools

See the following sections in the MarketPlace Solution Tools 

Guide:

 l "Database Server Connections Settings"

 l "Package Contents"

 l "MarketPlace Solution Tools Settings"

Narrative Reporting See the following sections in the Narrative Reporting Guide:

 l "Package Contents"

 l "Settings"

Navigation Center See the following sections in the Navigation Center Guide:

 l "Package Contents"

 l "Settings"

Parcel Service See the following sections in the Parcel Service Guide:

 l "Package Contents"

 l "Data Management"

 l "Specify Settings"
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Solution Documentation

Planning Solutions See the following sections in the Planning Solutions Guide:

 l "Review the Package Contents"

 l "Settings"

Predictive Analytics 123 See the following sections in the Predictive Analytics 123 Guide:

 l "Dashboard Maintenance Unit"

 l "Business Rules"

 l "Settings"

SAP Connector See the following sections in the SAP Connector Guide:

 l "Package Contents"

 l "Settings"

Scenario Analysis 123 See the following sections in the Scenario Analysis 123 Guide:

 l "Package Contents"

 l "Settings"

Security Audit Reports See the following sections in the Security Audit Reports Guide:

 l "Package Contents"

 l "Business Rules"

 l "Settings"
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Solution Documentation

SensibleAI Forecast See "Settings" in the SensibleAI Forecast Guide.

SensibleAI Studio See "Settings" in the SensibleAI Studio Guide.

Snippet Editor See the following sections in the Snippet Editor Guide:

 l "Package Contents"

 l "Settings"

 l "Extract and Reload Table Data"

Standard Application 

Reports

See the following sections in the Standard Application Reports 

Guide:

 l "Package Contents"

 l "Settings"

Standard System 

Reports

See the following sections in the Standard System Reports 

Guide:

 l "How to Manually Remove Previous Versions"

 l "Package Contents"
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Solution Documentation

System Diagnostics See the following sections in the System Diagnostics Guide:

 l "Package Contents"

 l "Business Rules"

 l "Data Management"

 l "Settings"

 l "Global Settings" (AI System Diagnostics)

Table Data Manager See "Settings" in the Table Data Manager Guide.

Task Manager See the following sections in the Task Manager Guide:

 l "Package Contents"

 l "Settings"

Xperiflow Administration 

Tools

See the following sections in the Xperiflow Administration Tools 

Guide:

 l "Set Up Xperiflow Administration Tools"

 l "Xperiflow Set Up (Required)"

 l "Solution Access"

 l "Settings"
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Solution Documentation

Xperiflow Cloud Tools See the following sections in the Xperiflow Cloud Tools Guide:

 l "Set Up Xperiflow Cloud Tools"

 l "Settings"
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Display Settings
OneStream Solutions frequently require the display of multiple data elements for proper data 

entry and analysis. Therefore, the recommended screen resolution is a minimum of 1920 x 1080 

for optimal rendering of forms and reports.

Additionally, we recommend that you adjust the Windows System Display text setting to 100% 

and do not apply any Custom Scaling options.
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Package Contents and Naming 
Conventions
The package file name contains multiple identifiers that correspond with the platform. To preserve 

the integrity of the naming conventions, do not rename any of the elements.

Most solutions follow the standard format, but there are exceptions for the following solutions:

 l Genesis

 l Forecast Value Add and SensibleAI Studio

Standard Format
The standard naming convention follows this format: XXX_PV#.#.#_SV#.#.#_

PackageContents.zip

Example: OFC_PV9.0.0_SV2.0.1_PackageContents.zip

Identifier Description

XXX Solution ID

NOTE: Some solutions, for example, Standard Application 

Reports and Standard System Reports, have longer 

solution IDs.

Getting Started with Solutions Guide 32

Package Contents and Naming Conventions



Identifier Description

PV#.#.# Minimum platform version required

OneStream recommends upgrading to the latest platform version.

SV#.#.# Solution version

PackageContents File name

NOTE: The platform and solution version numbers correspond to Major, Minor, and 

Hotfix releases. Major releases update the first number, for example, 1.0.0 or 2.0.0. 

Minor releases update the second number, for example, 1.1.0 or 1.2.0. Hotfix releases 

update the third number, for example, 1.0.1 or 1.0.2.

Exceptions
See the following sections for exceptions to the standard naming convention format.

Genesis

The Genesis naming convention follows this format: XXX_PV#.#.#_GV#.#.#_

PackageContents.zip

Example: GEN_PV9.0.0_GV2.0.0_PackageContents.zip

GV#.#.# is the identifier for the Genesis version.
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Forecast Value Add and SensibleAI Studio

The Forecast Value Add and SensibleAI Studio naming convention follows this format: XXX_

SV#.#.#_XPFv#.#.#_PV#.#.#_PackageContents.zip

Example: FVA_SV1.0.0_XPFv4.1.0_PV9.1.0_

PackageContents.zip

Example: STU_SV1.2.0_XPFv4.1.0_PV9.1.0_

PackageContents.zip

XPFv#.#.# is the identifier for the Xperiflow version.
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Solution Database Migration 
Advice
A development OneStream application is the safest method for building out a solution with custom 

tables. The relationship between OneStream objects, such as Workflow Profiles and custom 

solution tables, is that they point to the underlying identifier numbers and not the object names as 

seen in the user interface. Before the solution configuration, the development application should 

be a recent copy of the production application. This will ensure the identifiers match within the 

development and production applications. After the development application is created, install the 

solution and begin design.

NOTE: Use Cloud Administration Tools to create a copy. See "Copy Application" in the 

Cloud Administration Tools Guide.

See "Managing a OneStream Environment" in the Design and Reference Guide.

See Select the Solution Development Location.
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OneStream Solution Modification 
Considerations
Review these cautions and considerations regarding the modification of OneStream Solutions:

 l Major changes to business rules or custom tables within a OneStream Solution are not 

supported because the modified solution will be significantly different from the original 

solution.

 l If changes are made to any dashboard object, business rule, or Workspace assembly, 

consider renaming it or copying it to a new object first. This is important because if the 

solution is upgraded in the future, it will overlay and wipe out the changes. This also applies 

when updating the standard reports and dashboards provided in the solution.

 l If modifications are made to a OneStream Solution, upgrading to later versions will be more 

complex depending on the degree of customization. Simple changes, such as changing a 

logo or colors on a dashboard, do not impact upgrades significantly. Making changes to the 

custom database tables and business rules, which should be avoided, will make an 

upgrade even more complicated.
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